none
Hyper-V Networking disrupting host networking

    Question

  • Hello,

    Here is my setup

    Dell Precision 7510

    Windows 10 Pro (10.0.14393)

    Wifi - Intel Dual Band Wireless AC-8260 (19.2.0.1)

    Ether - Intel Eithernet 1219-LM (12.13.17.7)

    When connected to the docking station it uses Reltek USB-C GbE Family Controller (10.12.1007.2016)

    I have a Windows 2016 Server and Ubuntu 16 VM.  They both installed correctly and when networking actually works properly, they function fine.  

    I created an external virtual switch for each the Wifi and the Ethernet.   Removing the External switches fixes my problem in that my laptop no longer gets knocked off the network.  When I have any of the virtual adapters connected, that is when the problem begins.  Initially, connectivity works, but then it gets trashed on my laptop and thus my guest can no longer connect.  I have tried each individually, but I get the same exact issue.  After a period of time, my network adapter on my laptop can no longer get Internet Connectivity.

    I have searched and tried various solutions people have had from previous versions of the Windows OS and Hyper-V and none have worked.

    What pisses me off the most is that when I use the free version of Virtual Box, I have zero networking issues.  I have since removed Virtual Box because my company wants me to use Hyper-V.

    Would anyone have any suggestions or ideas of how I may fix this issue as I cannot do any work at all with the network constantly dropping out.

    Friday, April 14, 2017 6:43 PM

All replies

  • On each vSwitch you have created there is a check box for "Allow management operating system to share adapter" You'll only want to have checked the box on one or the other. The host OS will use the one you checked.

    Also I suppose the docking / undocking / wireless can be causing other various confusion.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Friday, April 14, 2017 7:19 PM
  • This forum is designed for Hyper-V Server products.  You are running Hyper-V on Windows 10.  There are some differences in getting it to work with desktop/laptop networking, particularly when using wifi.  There is a forum for Hyper-V on Windows 10 at https://social.technet.microsoft.com/Forums/en-US/home?forum=win10itprovirt.  You will find many many posts over there on getting networking to work on laptops.  And if your problem is not addressed there, it would be the better forum for posting questions on Hyper-V on Windows 10.

    tim

    Saturday, April 15, 2017 12:32 PM