none
Problems with IE 11, Edge, Chrome and GitExtensions RRS feed

  • Question

  • I recently installed Git and GitExtensions on my Win 10 Pro Desktop so that I could do some support for various projects on Github and when I tried to open a browser I had problems. I have my defaults to to open Chrome when a browser is opened. My problem is when GitExtensions tries to open a browser Edge opens instead... with no navigation buttons/arrows/etc whatsoever. And GitExtensions complains about setting compatibility-mode or using Firefox or Chrome or whatever. I tried setting the defaults to IE 11 with no change. How do I get either  IE11 (installed) or Chrome (installed) to open instead of the chopped-down-not-usable Edge?

    Monday, July 18, 2016 10:50 PM

Answers

  • Hi,

    you'll have to set IE11 as your default browser. Internet Options>Programs tab, Have you installed the Visual Studio Git Hub extension? You can manage your repositories from within VS i/o the browser.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    • Proposed as answer by Tony_TaoModerator Wednesday, July 20, 2016 9:35 AM
    • Marked as answer by K Benson Wednesday, July 20, 2016 4:53 PM
    Tuesday, July 19, 2016 12:23 AM
  • Hi Ken,

    I forgot to mention also that you have to change your Canary/Chromium preferences so that it does not check to see if its the default http(s) handler.

    Chrome://settings > Default browser.... mmm.... I have Canary, which can't be made the OS default..

    When you make IE the default (from Internet Options>Programs tab), the changes take effect when you re-start or start a new IE process...

    Regards.


    Rob^_^

    • Marked as answer by K Benson Wednesday, August 31, 2016 4:58 PM
    Thursday, July 21, 2016 12:02 AM

All replies

  • Hi,

    you'll have to set IE11 as your default browser. Internet Options>Programs tab, Have you installed the Visual Studio Git Hub extension? You can manage your repositories from within VS i/o the browser.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    • Proposed as answer by Tony_TaoModerator Wednesday, July 20, 2016 9:35 AM
    • Marked as answer by K Benson Wednesday, July 20, 2016 4:53 PM
    Tuesday, July 19, 2016 12:23 AM
  • As Rob mentioned, please try it.


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, July 20, 2016 9:35 AM
    Moderator
  • There are days when I want to throw this thing off the Brooklyn Bridge. 😛
    I tried to change the default about ten times over two hours time and it never changed. So I turned the PC off and did some reading about Linux. That must have scared my PC because when I booted it up about two hours later the default was changed! I then ran a test with GitExtensions and it worked. Thank you for the info and have a better day then I've had so far!
    Wednesday, July 20, 2016 4:53 PM
  • Hi Ken,

    I forgot to mention also that you have to change your Canary/Chromium preferences so that it does not check to see if its the default http(s) handler.

    Chrome://settings > Default browser.... mmm.... I have Canary, which can't be made the OS default..

    When you make IE the default (from Internet Options>Programs tab), the changes take effect when you re-start or start a new IE process...

    Regards.


    Rob^_^

    • Marked as answer by K Benson Wednesday, August 31, 2016 4:58 PM
    Thursday, July 21, 2016 12:02 AM