locked
Outlook 2016 cached mode metered connection cannot access shared Calendars RRS feed

  • Question

  • We are running Outlook 2016 64bit v16.0.4549.100 in cached mode on Windows 10 Enterprise 64bit v1511.  When we connect on a Cellular or WiFi metered connection - we cannot access Shared or Team Calendars online.  Click on them and don't get an error just nothing happens.  If we remove and re-add them - then we can access them.  This does not happen on non-metered connections and started happening after we disabled the Offline Address Book (and deleted OAB files) so the Outlook client would use the GAL for addressing emails.  If I download the OAB files and still leave the OAB disabled in the group policy this issue doesn't occur. I have the Outlook group policy for "Disable shared mail folder caching" set to enabled.  I have the Outlook policy for "Download Shared non-mail folders" disabled.  I set this to "enabled" so non-mail folders would cache and same issue - can't access the Shared Calendar folders until I remove/re-add them.  This also applies to Group Calendars - the "Show Manager's Team Calendars" - If I uncheck, then recheck the option - I can access them when connection is metered.  The metered connection does not affect mailboxes I have "full permissions" set through Exchange.  I can access the Calendar in those mailboxes whether connected metered or not. 

    Why do we have to remove/re-add shared Calendars in order to access them when on a metered connection?  this issue does not occur when "not" on a metered connection. 

    Resolution:  I opened a ticket with Microsoft and they provided two registry key settings that told Outlook to ignore the metered connection which solved the issue.  I should note that MS has not documented this as a solution nor has the Outlook team implemented as a feature of Outlook -so test diligently before you roll the keys out.

    HKCU\Software\Microsoft\Office\16.0\Outlook\Power

    HighCostMeteredNetworkBehavior

    ConservativeMeteredNetworkBehavior

    <u5:p> </u5:p>

    Set both to value: 1


    Wednesday, August 9, 2017 2:06 PM

Answers

  • Yes - I am using a MSI install.  I opened a ticket with MS and am currently trouble shooting this issue with them.  Will post back the results.

    Resolution:  I opened a ticket with Microsoft and they provided two registry key settings that told Outlook to ignore the metered connection which solved the issue.  I should note that MS has not documented this as a solution nor has the Outlook team implemented as a feature of Outlook -so test diligently before you roll the keys out.

    HKCU\Software\Microsoft\Office\16.0\Outlook\Power

    HighCostMeteredNetworkBehavior

    ConservativeMeteredNetworkBehavior

    <u5:p> </u5:p>

    Set both to value: 1

    Monday, August 28, 2017 11:59 AM

All replies

  • It's really odd. Theoretically, metered connection won't prevent you to access the shared calendars. I couldn't reproduce it on my computer. I noted the Office version you are using is not the latest one, maybe you can try to update your Office suit, and then test again.

    -Gavin

    Thursday, August 10, 2017 10:18 AM
  • Gavin - I ran offcat and it doesn't show Outlook is missing any updates.  What is the latest version your are referring to?    I went to File tab > Account info > about Outlook for v 16.0.4549.1000   If I look at the Outlook.exe properties the version is 16.0.4573.1001 

    Also - it's almost like the Navigation pane becomes corrupt when disconnecting and reconnecting which causes the issue because all I have to do is either start Outlook /resetnavpane and re-add the shared Calendars or manually remove and re-add them.  Doesn't make sense to me either.

    Thursday, August 10, 2017 12:08 PM
  • I should add that we have disabled the downloading of the Offline Address book to force Outlook in cached mode to use the online GAL when addressing emails.  I also compared Outlook's connection status and when a laptop connects to our local LAN - it has two Exchange Directory connections with one Session Type: Foreground and one Session Type: background and accessing the Shared Calendars and Team Calendars work fine.  When I connected the laptop using WiFi/VPN I only get one Exchange Directory Connection with Session Type: Background and cannot access the Shared or Team Calendars until I remove/re-add them in the Calendar pane.  Then I check the Outlook connection status and it now shows 2 Exchange Directory connections, one Session Type Background and one Session Type Foreground.  So by removing and re-adding the Shared/Team Calendars it forced Outlook to make a new Exchange Directory connection with Session Type: Foreground.  Thoughts on that? 
    Tuesday, August 15, 2017 6:49 PM
  • Gavin - I ran offcat and it doesn't show Outlook is missing any updates.  What is the latest version your are referring to?    I went to File tab > Account info > about Outlook for v 16.0.4549.1000   If I look at the Outlook.exe properties the version is 16.0.4573.1001 

    Also - it's almost like the Navigation pane becomes corrupt when disconnecting and reconnecting which causes the issue because all I have to do is either start Outlook /resetnavpane and re-add the shared Calendars or manually remove and re-add them.  Doesn't make sense to me either.

    I'm using version 1704, it seems you are using a MSI install. 
    Monday, August 28, 2017 9:26 AM
  • Yes - I am using a MSI install.  I opened a ticket with MS and am currently trouble shooting this issue with them.  Will post back the results.

    Resolution:  I opened a ticket with Microsoft and they provided two registry key settings that told Outlook to ignore the metered connection which solved the issue.  I should note that MS has not documented this as a solution nor has the Outlook team implemented as a feature of Outlook -so test diligently before you roll the keys out.

    HKCU\Software\Microsoft\Office\16.0\Outlook\Power

    HighCostMeteredNetworkBehavior

    ConservativeMeteredNetworkBehavior

    <u5:p> </u5:p>

    Set both to value: 1

    Monday, August 28, 2017 11:59 AM