"The update does not apply to your system" RRS feed

  • Question

  • Hi

    when trying to install "Update for Windows Vista" (eg. 921590) on a 5384 release, i got this error message:
    "the update does not apply to your system" ???

    I tried 6-7 more, but the same error message...


    Wednesday, July 19, 2006 9:22 AM

All replies

  • I experience this error too, i was trying to apply KB920143, patch for Norton Antivirus Corp. Ed. Please help us resolve this problem. Thanks!
    Thursday, July 27, 2006 1:04 AM
  • 1. Extract the contents of the .MSU file using the following command:
    'expand -f:* "Vista 32-bit.msu" C:\Temp'
    This extracted the msu file and we got the .CAB file.

    2. Installed the .CAB file using package manager utility. We used the following
    'pkgmgr.exe /ip /m:"path\package_name.CAB"'

    • Proposed as answer by ira555 Friday, March 12, 2010 2:45 PM
    Thursday, July 12, 2007 12:51 PM
  • Hey!


    i did it, but in the first command i saw the cmd showing up then closed very fast, in the sencond command the pkgmgr.exe ask me for permession i press continue then nothing appears , so i am not sure if it's works or not ,


    and these 2 command does works with *.msu ???



    Wednesday, February 6, 2008 1:34 PM
  • I was trying to install update Windows6.0-KB940199-x64.msu for
    Install this update to resolve an issue where an error message is displayed when installing a new hardware device on a system running Windows Vista,

    and it said the same error message, then I noticed there was an update for the update Windows6.0-KB940199-x86.msu, but neither work and all I get is -This update does not apply to your system

    not a happy chappy, I have not been able to use any usb devices for days now, and would rather not have to restore...
    Any ideas?

    Wednesday, April 16, 2008 11:41 AM
  • Jonathan


    You replied to a thread that was started in July, 2006 about a beta version of Windows Vista.


    You need to start a new thread and describe the problem with the USB devices. Include any error messages, any related Event Viewer messages, a description of your system and the USB devices you that are having problems. Include which version and type of Vista that you have installed. (64bit or 32bit)




    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience

    Wednesday, April 16, 2008 7:41 PM
  • Well my fresh install Vista X64 Sp1 (MBP Laptop) refuses to install any, yes any .msu files, they all don't apply to my system. My Vista werkstations @home X64 sp1 too simpy accepts them.


    For me it's a myterie why somethings that isn't installed on my system and applies doesnot for the installer, what wisdom is in the installer to decide that? The check inside the msu installers must be very bad!

    Wednesday, May 21, 2008 8:22 AM
  • Should I type: 'expand -f:* "Vista 32-bit.msu" C:\Temp' into the program called Command Prompt?
    Monday, July 21, 2008 7:24 AM

    ok, I did that and it worked, but then what am I supposed to do?
    Saturday, November 8, 2008 9:49 PM
  • OK, if KB941314 is installed, you cannot install RSAT.  Remove the update, reboot, attempt again to install RSAT.
    Wednesday, January 14, 2009 6:12 PM
  • Thank you so much!
    That's the only way that worked for me to force Vista to install the patch.


    Software engineer
    • Proposed as answer by ira555 Friday, March 12, 2010 2:44 PM
    Friday, March 12, 2010 2:44 PM