none
Secondary DPM 2012 is not making backup of system state, Replica Inconsistence after some time!! RRS feed

  • Question

  • hi,

    i have a problem in my secondary DPM 2012, which is not making system state (BMR) backup properly, even though my primary dpm is working fine . both dpm's are on different sites and connected through WAN link on VPN connection.

    here is the ERROR DETAILS,

    Affected area: Computer\System Protection(servername.domain.com)
    Occurred since: 12/20/2012 3:33:01 AM
    Description: The replica of System Protection Computer\System Protection(servername.domain.com) on dpmserver.domain.com is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. You can recover data from existing recovery points, but new recovery points cannot be created until the replica is consistent. 

    For SharePoint farm, recovery points will continue getting created with the databases that are consistent. To backup inconsistent databases, run a consistency check on the farm. (ID 3106)
    The protection agent on dpmserver.domain.com was temporarily unable to respond because it was in an unexpected state. (ID 60 Details: Internal error code: 0x809909B0)
    More information
    Recommended action: Retry the operation.
    Synchronize with consistency check.
    Run a synchronization job with consistency check...
    Resolution: To dismiss the alert, click below
    Inactivate

    thank you!!

    ~~~~Sam

    Thursday, December 20, 2012 5:15 PM

Answers

  • Hi,

    Secondary protection for SystemState / BMR will always transfer more data than other workloadss, so in a slow WAN link it could cause problems.

    Please add following regkey on DPM and PS, restart DPMRA service on both systems and rerun the CC or Recovery point jobs. 

    NOTE: Without the registry values, the default timeout is 300 (5 minutes).

    Under  "HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent" 
    Add a DWORD value with name “ConnectionNoActivityTimeoutForNonCCJobs”
    Set it to 7200 decimal.

    Under  "HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent"
    Add a DWORD with name “ConnectionNoActivityTimeout”
    Set it to 7200 decimal.


    To make this easy for you, follow these steps.

    1) Copy the below into notepad, then save the file as connect-timeout.reg  (make sure it does not have a .txt extension)


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft Data Protection Manager\Agent]
    "ConnectionNoActivityTimeoutForNonCCJobs"=dword:00001c20
    "ConnectionNoActivityTimeout"=dword:00001c20

    If that alone does not help, then enable bandwidth throttling on the secondary DPM server so it does not use more that 85% of the network speed and see if that helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, December 21, 2012 11:23 PM
    Moderator

All replies

  • Hi,

    Secondary protection for SystemState / BMR will always transfer more data than other workloadss, so in a slow WAN link it could cause problems.

    Please add following regkey on DPM and PS, restart DPMRA service on both systems and rerun the CC or Recovery point jobs. 

    NOTE: Without the registry values, the default timeout is 300 (5 minutes).

    Under  "HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent" 
    Add a DWORD value with name “ConnectionNoActivityTimeoutForNonCCJobs”
    Set it to 7200 decimal.

    Under  "HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent"
    Add a DWORD with name “ConnectionNoActivityTimeout”
    Set it to 7200 decimal.


    To make this easy for you, follow these steps.

    1) Copy the below into notepad, then save the file as connect-timeout.reg  (make sure it does not have a .txt extension)


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft Data Protection Manager\Agent]
    "ConnectionNoActivityTimeoutForNonCCJobs"=dword:00001c20
    "ConnectionNoActivityTimeout"=dword:00001c20

    If that alone does not help, then enable bandwidth throttling on the secondary DPM server so it does not use more that 85% of the network speed and see if that helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, December 21, 2012 11:23 PM
    Moderator
  • Hello Mike,

    i really appreciate your response, so far i had modified my both registries , primary as well as secondary.and re run the consistency check again. it will take some time to show me any change.

    so, as soon as i get any result. i will post here .

    thank you !!

    Monday, December 24, 2012 4:35 PM