none
DCOM got error "2147746132" when attempting to activate the server

    Question

  • One of my DC's is constantly spitting out this error. Tried looking into it, but all the suggested posts are not helping.

    http://community.spiceworks.com/windows_event/show/83-dcom-10006

    I can see all the systems in question, checked all the named computers reporting the error and they all have the same settings as suggested they should have.

    When following the final suggestino to keep the event open to grab the CLSID and check the registry to grab the "friendly name" the CLSID is nowhere to be found under that reg directory .... HKCR\Clsid\clsid value\

    the CLSID is the same for all different computers reported, and all events are coming from one DC. Lets say {f3DCxxxx-xxxxx-blah-blah}

    And then when I goto Computers\My Computer\DCOM Config (On the reporting DC) I get this warning..

    The CLSID {8A2xxxxx-bla-bla}, item "C:\Pro~\Symantic\BEUtility.exe" and the title BEDatabaseServices Class has the named value AppID, but not recorded under \\HKCR\APPId. Do you wish to record it.

    I'm at a loss as to what could be casuing this if that clsid isn't even the registry...


    This is on a 2008 R2 DC, I have checked dcdiag all test passed, replication is working great.
    • Edited by Zewwy Wednesday, November 6, 2013 10:26 PM
    Wednesday, November 6, 2013 10:24 PM

All replies

  • Is this path correct?  "C:\Pro~\Symantic\BEUtility.exe"

    I would think it should be "\Symantec\"...as it looks like it is related to Backup Exec.

    If so, there is a similar issue noted with another one of their products here:

    http://www.symantec.com/business/support/index?page=content&id=TECH130211

    If that is the case, I'd follow up with them.  If not, let us know.

    Thursday, November 7, 2013 3:52 AM
  • Yeah, that just tell you the work around of just replying to the pop up.

    But that doesn't explain why our sever is getting numerous 10006 errors.

    As I had mentioned one of the CLSID reported on the error could not be found in the registry anywhere, {F3DC957F-00CA-4D2A-A9AD-03FA855AAE38} Nor can I find it under DCOM config in Component Services, Apparently happening since 2011.

    When looking at a couple older events of 10006 with different CLSID those came back with a friendly name of Windows Management and Instrumentation (WMI) {8BC3F05E-D86B-11D0-1075-00C04FB68820}

    I tried to follow along with the Answer from this page, but all owner and permissions settings where correct.

    I have posted the link to the listed solutions to try, but all the settings seem to be correct on both server and client settings. I did notice that the account system did not have allow permissions checked..



    • Edited by Zewwy Thursday, November 7, 2013 3:45 PM
    Thursday, November 7, 2013 3:17 PM
  • Any other thoughts or suggestions?
    Wednesday, November 13, 2013 9:15 PM
  • refer to http://www.eventid.net/display-eventid-10006-source-DCOM-eventno-272-phase-1.htm

    are there agent updates available? run the update manually on each server...

    Best,

    Howtodo

    Thursday, November 14, 2013 4:38 PM