none
IPv6-Routing with Hyper-V

    Question

  • Hello there,

    I am biting already a long time on a strange problem:

    Situation:

    There is one dedicated Windows Server 2012 R2 Standard edition with one NIC with a /64-Subnet. Im running a Hyper-V with two switches, switch one "Internets" is connected to a external network which is the physical NIC of the server with the option to allow management of the OS.
    The second switch "Server-Net" is connected to a internal-only network where all the VMs are connected to. 

    To set up the whole thing, I used this tutorial, as my provider is Hetzner: https://wiki.hetzner.de/index.php/Windows_Server_2012_Subnet/en

    Done everything as described, enabled forwarding, routes are set, everything looks good, I can ping from the VMs to the host and vice versa. But I can not get to the outside world from the VMs, but I get full ipv6-internet from the Host. 

    Both Virtual NICs are in public mode, only the "Server-Net"-NIC says "not internet" with IPv6. No dropped packets are loggen in firewall.

    Now the magic starts: 
    I wanted to check with wireshark where the packets are lost. As soon I started capturing in promiscuous mode, everything was working fine!! As soon I stopped wireshark, back to broken system...

    Does anyone has a clue whats going on here?

    The same setup worked already on another 2012R2 Box, same setup from scratch.

    I you need more details or missing information, I will try to get it.

    Thank you very much!

    Greetings
    blitzdesigner

    PS: This is the routing table

    IPv6 Route Table
    ===========================================================================
    Active Routes:
     If Metric Network Destination      Gateway
     17    261 ::/0                     fe80::1
      1    306 ::1/128                  On-link
     19    261 2a01:4f8:xxx:xxxx::/64   On-link
     17    261 2a01:4f8:xxx:xxxx::/128  On-link
     17    261 2a01:4f8:xxx:xxxx::1/128 On-link
     19    261 2a01:4f8:xxx:xxxx::2/128 On-link
     19    261 2a01:4f8:xxx:xxxx:875e:4cfb:6bc2:8b88/128
                                        On-link
     21    276 fe80::/64                On-link
     22    276 fe80::/64                On-link
     17    261 fe80::/64                On-link
     19    261 fe80::/64                On-link
     22    276 fe80::1c72:542e:33ff:2851/128
                                        On-link
     21    276 fe80::5006:3c15:1477:6112/128
                                        On-link
     19    261 fe80::98ba:6ecd:412c:2d2f/128
                                        On-link
     17    261 fe80::999f:cb7:32e2:cd91/128
                                        On-link
      1    306 ff00::/8                 On-link
     21    276 ff00::/8                 On-link
     22    276 ff00::/8                 On-link
     17    261 ff00::/8                 On-link
     19    261 ff00::/8                 On-link
    ===========================================================================
    Persistent Routes:
     If Metric Network Destination      Gateway
      0 4294967295 ::/0                     fe80::1
      0 4294967295 ::/0                     fe80::1
      0 4294967295 2a01:4f8:xxx:xxxx::/128  On-link
    ===========================================================================

    • Edited by blitzdesigner Monday, March 27, 2017 8:16 PM added info
    Monday, March 27, 2017 8:12 PM

Answers

  • Hello readers,

    after a thoundth round of searching, I found a solution! :-)

    You have to disable the randomizing of the IPv6 Identifiers on the Host...

    netsh interface ipv6 set global randomizeidentifiers=disable

    done that, everything works like a charm!

    Credit goes to the Fubarcoder (German Site)

    So, case closed...

    regards
    blitzdesigner


    Tuesday, April 04, 2017 5:47 PM

All replies

  • Hi Sir,

    >> Im running a Hyper-V with two switches, switch one "Internets" is connected to a external network which is the physical NIC of the server with the option to allow management of the OS.

    Have you tried to remove that external virtual switch in hyper-v manager and restart hyper-v host ?

     

    >>As soon I started capturing in promiscuous mode, everything was working fine!!

    Did you find which NIC "needs" to enable promiscuous mode ?

     

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 28, 2017 9:10 AM
    Moderator
  • Hi Elton,

    thank you for your reply.

    I already removed the whole Hyper-V-Role and set up everything again several times in different order. Heck, even reinstalled the whole system. But then  I needed to set it live so I continued first without ipv6, now would possible avoid reinstalling the whole thing again...

    It seems it has to be the External NIC...

    Regards,

    blitzdesigner

    Tuesday, March 28, 2017 9:50 AM
  • Hi Sir,

    >> But then  I needed to set it live so I continued first without ipv6, now would possible avoid reinstalling the whole thing again...,

    Do you mean you are going to use only IPV4 as a workaround for these VMs which need to access internet ?

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 29, 2017 5:38 AM
    Moderator
  • Hi Elton,

    yes, thats true, right now im using ipv4 only.

    Just the host-server is accessible via ipv6 on its External NIC.

    Regards,

    blitzdesigner

    Wednesday, March 29, 2017 9:46 AM
  • Hi Elton,

    yes, thats true, right now im using ipv4 only.

    Just the host-server is accessible via ipv6 on its External NIC.

    Regards,

    blitzdesigner

    Sorry to bother, but the goal is to have ipv6 access for the VMs...

    I am wondering what is changing in the system/routing when I activate the prepromicious mode....

    Wednesday, March 29, 2017 1:33 PM
  • Just a little bump, someone here who could give me hint how to solve my problem?

    Much appreciated!

    blitzdesigner

    Sunday, April 02, 2017 2:47 PM
  • Hello readers,

    after a thoundth round of searching, I found a solution! :-)

    You have to disable the randomizing of the IPv6 Identifiers on the Host...

    netsh interface ipv6 set global randomizeidentifiers=disable

    done that, everything works like a charm!

    Credit goes to the Fubarcoder (German Site)

    So, case closed...

    regards
    blitzdesigner


    Tuesday, April 04, 2017 5:47 PM