locked
Application stuck in a loop after entering credentials .Web.InvalidRequestException: MSIS7042 RRS feed

  • Question

  • I have a 3rd party application i am trying to federate but it errors out after entering my credentials in the ADFS sign in page. It appears its in a loop. Here are the errors

    Exception details: 
    Microsoft.IdentityServer.Web.InvalidRequestException: MSIS7042: The same client browser session has made '6' requests in the last '1' seconds. Contact your administrator for details.
       at Microsoft.IdentityServer.Web.Protocols.PassiveProtocolHandler.UpdateLoopDetectionCookie(WrappedHttpListenerContext context)
       at Microsoft.IdentityServer.Web.Protocols.WSFederation.WSFederationProtocolHandler.SendSignInResponse(WSFederationContext context, MSISSignInResponse response)
       at Microsoft.IdentityServer.Web.PassiveProtocolListener.ProcessProtocolRequest(ProtocolContext protocolContext, PassiveProtocolHandler protocolHandler)
       at Microsoft.IdentityServer.Web.PassiveProtocolListener.OnGetContext(WrappedHttpListenerContext context)

    Can someone help with troubleshooting this issue? I have done to configuration again five times but its still the same error. All other federated applications are fine, its just this new application i am trying to configure.

    Thanks in advance

    Monday, October 3, 2016 8:01 AM

All replies

  • Ensure that the identifier of the RP matches exactly the identifier that the actual application has in its configuration.

    Ensure that time is also in sync. The ADFS should not provide a token which is not yet valid for the RP.

    A fiddler trace might help. Try taking one, sanitize it (remove credentials) and share it over here!


    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Monday, October 3, 2016 12:37 PM