none
Credentials are not accepted when trying to attach a workgroup server RRS feed

  • Question

  • Firstly, I read the other two threads on the same issue: DPM Agent install Error 32680  and Unable to attach non-domain server to DPM 2010. The DCOM problem was not the case and the second didn't offer a solution.

    Whatever I do, no matter how many times I reboot, reinstall or change the password, with out without DNS suffix: I can not authenticate.

    PS C:\Program Files\Microsoft Data Protection Manager\DPM2010\bin> Attach-NonDomainServer.ps1 -DPMServername DPMDummy004 -PSName PSDummy001 -Username dpmagent
    
    Password:: *********************
    There is failure while attaching production server
    C:\Program Files\Microsoft DPM\DPM\bin\Attach-NonDomainServer.ps1 : The credentials specified for server PSDummy001 are invalid.
    
    (...)
    
    Rerun the operation with the same credentials that were provided when running SetDpmServer for the target server.

    Both machines can perfectly ping each other and the PS can access the shares on the DPM and vice versa, so there is no connection problem either.

    I wonder why this "easy backing up of non-domain machines in DPM2010" seems to go wrong for me.


    My grandmother always used to say: "::1: sweet ::1:"



    Thursday, February 9, 2012 4:33 PM

All replies

  • Ping and File Share Access doesn't use the same protocols used by DPM when attaching to a remote computer.

    This pretty much goes via RPC channels.

    Did you run setdpmserver.exe  first on your PSDummy001?


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights

    Thursday, February 9, 2012 9:24 PM
  • Of course:

    C:\Program Files\Microsoft Data Protection Manager\DPM\bin>SetDpmServer.exe -dpmservername DPMDummy004.mydomain -isNonDomainServer -username dpmagent
    
    Make sure that this computer is not part of a perimeter network. DPM does not support protection of computers on a perimeter network.
    Enter the password for 'dpmagent' to connect to 'DPMDummy004.mydomain:
    Retype the password to confirm:
    Enter the password for 'dpmagent' to connect to 'DPMDummy004.mydomain:
    Configuring dpm server settings and firewall settings for dpm server =[DPMDummy004.mydomain]
    Configuration completed successfully!!!

    Tried it both with and without DNS suffix.


    My grandmother always used to say: "::1: sweet ::1:"

    Friday, February 10, 2012 8:56 AM
  • Hi,

    I've seen this error once when i tried to put the DPM agent on a Virtual Machine template.

    I was forced to uninstall DPM on the protected computer and install it one more time and then everything worked fine.

    Have you tried that?

    Laith.

    Monday, February 20, 2012 7:37 PM
  • I have the same problem.
    How you solved it?
    Friday, August 3, 2012 11:26 PM
  • Very much a guess based purely on issues I've seen with non-domain servers, but have you tried using a different username rather than the existing "dpmagent" one? The Attach-NonDomainServer.ps1 and SetDpmServer.exe processes create the specified user with the password you enter on the protected server and DPM server, so there's nothing stopping you from having completely different logins on each and every machine you setup. I know that's what we do in my place, though I can't remember if it was due to us having issues when using the same login across multiple servers. Also note that unless changed on the server the default password expiration on the account will apply, BUT you'll likely find that once expired any other servers using that login won't immediately stop working, therefore it's not impossible for the account to be locked which I imagine could cause problems logging in, while not stopping the other servers from functioning. It took us a while to work out what was going on when suddenly a load of servers (all those setup more than a month previously) couldn't connect after we restarted our DPM server!
    Sunday, August 12, 2012 7:44 PM