none
robocopy copied and skipped the same number of directory

    Question

  • Hi all,

    I was running robocopy for 1 TB of DATA. There was no failure or mismatch of file/directories. But what I can see, it copied 57000 directories and also skipped 57000 directories.

    Is it because of I have used /MT switch ?

    Regards,

    Suhag.

    Tuesday, January 5, 2016 12:07 PM

Answers

  • Hi Suhag Desai,

    As MikeVATX said, I think also there may be some security issues or opened file block the copying process. So, please restart your PC and try again, make sure your media for copying file is healthy.

    Best regards,

    Teemo Tang


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, January 11, 2016 1:48 AM
    Moderator

All replies

  • Hi Suhag,

    Have you used the log option, so you can see what has been done.

    THe on I use most of the time is: robocopy SOURCE DESTINATION *.* /mir  /r:3 /w:3 > copylog.txt

    Kind regards,

    Matthijs

    • Proposed as answer by M. ter Horst Tuesday, January 5, 2016 3:35 PM
    Tuesday, January 5, 2016 3:35 PM
  • Yes, I have the log files and I also checked the destination and found all well. But curious to know why it is showing like this...Same no of copied and skipped

                           Total          Copied       Skipped       Mismatch    FAILED       Extras
        Dirs :           57928        57928        57928               0              0              0

     
    Tuesday, January 5, 2016 4:22 PM
  • What's the exact syntact that you used?
    Tuesday, January 5, 2016 4:26 PM
  • robocopy.exe SOURCE DESTINATION  /MT:6 /NDL /COPYALL /ZB /MIR /R:0 /W:0 /log:f:\123.txt /NP /V /TEE

    Tuesday, January 5, 2016 4:33 PM
  • Not sure what might be going wrong.
    Try to eliminate some (unnecessary) options, for instance the /MT.

    Tuesday, January 5, 2016 4:51 PM
  • Yes, I already did by removing /MT and it is showing perfect, no skipped directory.

    Again, when I put /MT back, I can see same number in copied and skipped...

    Tuesday, January 5, 2016 4:57 PM
  • I believe files that are skipped are ones that already exsist.  Did you run this mutiple times and are the files on the destination?  Files that have security issues or that are open will be listed as failed.

    Thanks,
    MikeV
    MCSE 2012

    Tuesday, January 5, 2016 5:01 PM
  • No, I ran it fist time only. After robocopy, I also checked  and there was no fail or mismatch files. I cross checked source and Destination Byte to Byte and all found ok.
    Tuesday, January 5, 2016 5:04 PM
  • Hi Suhag Desai,

    As MikeVATX said, I think also there may be some security issues or opened file block the copying process. So, please restart your PC and try again, make sure your media for copying file is healthy.

    Best regards,

    Teemo Tang


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, January 11, 2016 1:48 AM
    Moderator
  • Hi,
    Would you mind letting me know the result of the suggestions? If you need further assistance, feel free to let me know. I will be more than happy to be of assistance.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, January 13, 2016 8:43 AM
    Moderator
  • Had this same issue but can confirm all Data is 100% copied so it must be a glitch in this version of RoboCopy.

    Ran it on Server 2012R2 Standard


    I have found different versions of Robocopy support different commands across the Windows OS Builds.

    Monday, October 1, 2018 5:31 PM