locked
Outlook 2016 RDS Programmatic Acccess RRS feed

  • Question

  • Hi all

    I have a problem with Outlook 2016 and programmatic access. I need to disable the warning because our client has a web CRM that sends mail via Outlook. Each time a mail is being sent we receive this message and have to allow it (sorry for the small picture):

    Outlook is running on a Remote Desktop Server. So I tried to apply GPO settings (which I had to manually import) for this (it is in german) followed some of these instructions --> http://yourcomputerguru.com.au/windows/disable-outlook-programmatic-access-via-group-policy

    :

    unfortunately it is still always greyed out here and I still had the prompt:

    The GPO is applied according to gpresult /r. I also rebooted the server.

    I have also tried editing the registry --> https://www.slipstick.com/developer/change-programmatic-access-options/

    What am I doing wrong? This is driving me nuts :(

    Thanks in advance for all the help!

    silbro


    • Edited by silbro Thursday, September 20, 2018 8:49 AM
    Thursday, September 20, 2018 8:48 AM

Answers

  • Hi silbro,

    Have you tried running Outlook as administrator and see if the options can be modified?

    As per the registry method mentioned in the second link you shared above, have you tried adding all the registry keys to see the result? (Be sure to back up the registry before modifying in case problems occur.)

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Outlook\Security
    DWORD: ObjectModelGuard
    Value: 2

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\outlook\security
    DWORD: PromptOOMSend
    Value: 2

    DWORD: AdminSecurityMode
    Value: 3

    DWORD: promptoomaddressinformationaccess
    Value: 2

    DWORD: promptoomaddressbookaccess
    Value: 2

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    Friday, September 21, 2018 3:03 AM

All replies

  • Hi silbro,

    Have you tried running Outlook as administrator and see if the options can be modified?

    As per the registry method mentioned in the second link you shared above, have you tried adding all the registry keys to see the result? (Be sure to back up the registry before modifying in case problems occur.)

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Outlook\Security
    DWORD: ObjectModelGuard
    Value: 2

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\outlook\security
    DWORD: PromptOOMSend
    Value: 2

    DWORD: AdminSecurityMode
    Value: 3

    DWORD: promptoomaddressinformationaccess
    Value: 2

    DWORD: promptoomaddressbookaccess
    Value: 2

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    Friday, September 21, 2018 3:03 AM
  • Hi Yuki Sun

    Thank you for your response. I've tried adding the registry keys and running Oultook as an admin. Unfortunately both with no succuess.

    I rebooted the servers and it didn't change anything either.

    Now to the strange part though, a client just told me that it works now. What I did is, I uninstalled the AntiVirus and reinstalled a newer version of it. Maybe this has something to do with it?

    I'll report back in a few days to see if it keeps working and put the thread to resolved if it worked and try to find out if it had to do with the AV so I can give a more specific answer.

    sincerely
    -silbro

    Tuesday, September 25, 2018 8:13 AM
  • Hi silbro,

    Thanks for getting back to us with the your findings. Personally I'd like to suggest trying to temporarily turning off the AV to narrow down whether the issue is related to the antivirus software. 

    Feel free to post back at your convenience if you get any further updates. Good luck! :)  

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, September 25, 2018 8:26 AM
  • Ok so I reinstalled the AV again and rebootet the server. It still works, but the AV still isn't correctly recognized by Outlook. I don't know what the exact problem/solution was. Anyways, thanks for your assistance Yuki Sun.

    I'm sorry for anyone else in the future having this problem and coming to this thread because there is no real answer. I'd try the settings I set in the GPO and/or follow Yuki Sun's instructions.

    sincerely
    -silbro

    Thursday, September 27, 2018 7:44 AM
  • Hi Silbro,

    Same Problem.

    I am currently testing the reg settings according to this Microsoft article.

    The article seems to be new and the settings can also be used in Office 2019.

    I give a feedback.

    Link: https://support.microsoft.com/en-us/help/3189806/a-program-is-trying-to-send-an-e-mail-message-on-your-behalf-warning-i

    greetings
    Michael



    • Edited by Much_r Monday, January 28, 2019 4:32 PM
    Monday, January 28, 2019 4:31 PM
  • Hi,

    Currently the described Regkeys solve my problem. I could not recognize any disadvantages.
    I will configure this via GPO on the terminal servers.

    greetings
    Michael


    • Proposed as answer by Much_r Tuesday, February 19, 2019 11:02 AM
    Tuesday, February 19, 2019 11:02 AM