locked
Sequencing AX 2012 Client with App-V 4.6SP1: Memory error RRS feed

  • Question

  • I am attempting to sequence the AX2012-client.

    Each time I get a memory-error during the installation-process:

    The instruction at 0x7756e663 referenced memory at 0x00000024. the memory could not be read.

    When I click 'OK' everything (both AX setup and sequencer) crashes.

     

    I tried this on both a 32-bit Win7 and a 64-bit Server 2008 R2, both produce the same issue.

     

    Is this a known issue, and/or is there a knwown workaround/fix for this?

     

    Many thanks in advance!

     


    Thursday, August 25, 2011 9:32 AM

Answers

All replies

  • I presume you're talking about Microsoft Dynamics AX 2012? As it's new/beta(?) I doubt it's a known issue outside of Microsoft - usually App-V support comes after the final release.

    The only available documentation is the existing Application Virtualization with Microsoft Dynamics NAV 2009 R2: http://msdn.microsoft.com/en-us/library/gg670186.aspx; you might be able to adapt these instructions to version 2010

    These client deployment details for 2010 might be of use: http://technet.microsoft.com/en-us/library/aa834494.aspx



    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Thursday, August 25, 2011 9:56 AM
    Moderator
  • If this is with the 4.6 SP1 sequencer, we are working on some issues related to this w/ Dynamics

    What version of the sequencer are you using?

     


    Steve Thomas, SSEE, Microsoft
    App-V/MED-V/SCVMM/SCCM/AppCompat
    http://madvirtualizer.wordpress.com/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”
    Friday, August 26, 2011 9:17 PM
  • We are trying to sequence the AX 2012 RTM client as well. (Previous AX 2009 client have always successfully been packages with App-V 4.6)

    Our base is Windows 7, 32 bit.

    We have no issues going trough all prerequisites, but when actually installing the AX 2012 client options we run into errors.

    We also get the error "The instruction at 0x778c7515 referenced memory at 0x18758bc9 memory could not be read. Click on OK to terminate the program"

    After running into this error we applied App-V 4.6 SP1, but the error keeps coming.

    We tried two ways of running the installer:

    1) Just by double clicking setup.exe.

    Result is we get the error: "Cannot open "C:\setup.exe" AutoRun=1"

    2) running it from explorer

    Result is the memory reference error as described above

    I hope there is a quick solution / workaround available soon.

    Is there any idea on a solution? Would that require a new client or workaround procedure?

    Monday, August 29, 2011 8:55 AM
  • Hello,

    If you are using 4.6 SP1 - try the later release of the sequencer;

    http://support.microsoft.com/kb/2571168

    Also retrieve the latest update for AX;

    http://blogs.technet.com/b/dynamicsaxse/archive/2011/08/03/announcing-dynamics-ax-2012-cumulative-update-1.aspx

    Considering the following statement from Dynamics AX 2012 you can probably open a support case if it still fails

    Virtual client support
     
    The Microsoft Dynamics AX Windows client is certified to work as a virtual application on MicrosoftApplication Virtualization (App-V) 4.6.App-V transforms applications into virtual services. When an application is virtual, it is no longer installed on a user’s PC, which means that it does not conflict with other applications. Updates are centrallymanaged so that users do not experience prompts for updates or reboots. 


    /Znack
    Tuesday, August 30, 2011 9:18 AM
  • Same problem here.

    Installed latest App-v (x64) Sequencer on a Windows 2008 R2 X64 system and tried installing AX client RTM release with latest updates and got stuck at the same memory error. Is there a solution yet?

    Have already contacted microsoft but got no confirmation on a solution yet.

     

    Any new result available?

    Saturday, September 17, 2011 5:44 PM
  • There's no answer here yet.
    Saturday, September 17, 2011 5:52 PM
  • I have had contact with Microsoft.

    For us, the big difference was that trying to sequence the package including prerequisites finished with the memory error.

    Based on a Vista VM, when we had the prerequisites installed before sequencing the client installation, we had a succesful client sequencing procedure.

    There will probaply be a documented solution in a while, but this might get you started on forehand. 

     

    • Proposed as answer by znack Monday, September 19, 2011 4:06 PM
    • Unproposed as answer by Aaron.ParkerModerator Wednesday, November 30, 2011 7:43 PM
    Monday, September 19, 2011 3:20 PM
  • I had sort of same question coming from microsoft. But I used the sequencer on Windows 2008 R2 and all prequisites where installed already before staring the sequencer. So, no solution for me yet.
    Monday, September 19, 2011 4:14 PM
  • A solution for sequencing Dynamics AX 2012 has been posted here: How to sequence the Dynamics AX 2012 client with App-V 4.6 SP1 on Windows 7/2008 R2

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Wednesday, November 30, 2011 7:44 PM
    Moderator
  • Is it possible to sequence AX 2012 with AppV 5.0 sp1?

    Wednesday, July 24, 2013 7:17 PM