locked
Problem merging large folders RRS feed

  • General discussion

  • Whenever i try to merge folders between my laptop and flash drive, Windows 7 always cuts and pastes the folder instead of merging it with the folder with the same name on the flash drive. Is there any way around this right now?
    Friday, February 20, 2009 12:47 PM

All replies

  • 1. folder on my laptop named folder1, folder on my flash drive also named folder1* (designated by * to show difference in location)
    2. i right click folder1 and click copy
    3. i open the windows explorer window for the flash drive and see folder1* on the flash drive
    4. i paste folder1 into explorer window containing folder1*
    5. it asks if i want to merge folder1 with folder1*
    6. it starts to copy but instead of merging the two folders it creates a separate folder1 called folder1(2). Thus instead of merging the folders it instead pastes the folder1to the location on the flash drive
    Friday, February 20, 2009 8:02 PM
  • mataio1984 said:

    1. folder on my laptop named folder1, folder on my flash drive also named folder1* (designated by * to show difference in location)
    2. i right click folder1 and click copy
    3. i open the windows explorer window for the flash drive and see folder1* on the flash drive
    4. i paste folder1 into explorer window containing folder1*
    5. it asks if i want to merge folder1 with folder1*
    6. it starts to copy but instead of merging the two folders it creates a separate folder1 called folder1(2). Thus instead of merging the folders it instead pastes the folder1to the location on the flash drive

    Hi

    I tried to recreate what you are doing here.

    In step 5, when I select Yes for the merge,




    I then get another popup window with 3 options:

     


    It asks this for each of the duplicate files in Folder1*. There is also an optional check box in the second popup window that you can select to perform the same action for xx files. (Where xx is the total number of duplicate files in the folder)

    Is this what you are seeing?

    Let us know.


    Thank You for testing Windows 7 Beta

    Ronnie Vernon MVP
    Saturday, February 21, 2009 12:23 AM
  • Yes that is what I am seeing, however, after the last screen you posted in which you press ok it still copies and pastes to a new folder instead of merging. I will keep trying to see if there is any difference.
    Saturday, February 21, 2009 2:01 AM
  • Just to make this clear, by "press ok" do you mean that you select the "Copy and Replace" option?
    Saturday, February 21, 2009 2:05 AM
  • yes i select the "copy and replace" option
    Saturday, February 21, 2009 2:07 AM
  • Hi mataio1984

    I'm not sure why this is happening, but I cannot recreate the behavior you are seeing?

    What happens if you just select all of the files in that first folder and then copy/paste them into the second folder on the flash drive?

    Let us know.


    Thank You for testing Windows 7 Beta

    Ronnie Vernon MVP
    Saturday, February 21, 2009 8:04 AM
  • If i select all of the files in the first folder and copy/paste them into the second folder it works properly and merges. The problem i am having seems to be only when i try to merge the two big folders. If no one else has this problem it may be only on my computer that this is happening. Other things i am considering are the size of the two folders and the sheer volume of files in these folders. The folder has over 300 folders and over 1,000 files in all.
    Saturday, February 21, 2009 11:41 AM
  • Hey, I'm having what I think is a similar problem, but getting different results.

    Files on two different USB Drives.

    E:\Docs\Taxes.tax
    F:\Docs\Taxes.tax

    Both files already exist in BOTH locations.  I drag taxes.tax from E:\Docs to F:\Docs and end up with a files called Taxes - copy.tax

    Never does it prompt me to overwrite duplicates, ask me which file to keep, etc.

    Tried it with a left drag and with a right drag.  Same result. 

    Any ideas?
    Thanks
    Bryan Jones
    Sunday, February 22, 2009 2:27 AM