locked
Forward to External SMTP Address RRS feed

  • Question

  • Hi all,

    I am running Exchange 2016 on Windows Server 2012 R2. Everything seems to be working great, except forwarding to external email addresses. I can get the emails to forward out, but they aren't forwarding the way I'd like them to. I have set it up through mail contacts and through powershell, I have not been able to get it to work correctly. Let me try to explain the scenario.

    Almost all of our mailboxes are being forwarded off site to personal email addresses. I have set up mailbox 5268 to forward out to personal@gmail.com through a mail contact. When I send an email from another mailbox in the organization, it forwards out to the personal@gmail.com as if it's from the other mailbox. The From: field shows othermailbox@mydomain.com. I would like it to say it's from mailbox 5268@mydomain.com. The reason for this is because we primarily use Unified Messaging and it would be nice to have the voicemails forward out as if they are from their own mailbox. In mailbox 5268 I set up "othermailbox" as having permissions under Send As:. This changed nothing. Oddly enough when I leave a voicemail for 5268 it sends the email out From:MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@mydomain.com on behalf of (caller id of received voicemail). Since it is coming from a strange address it ALWAYS gets flagged and dropped into Spam on the personal mailbox that it's forwarded to.

    I would like to achieve one of two things. Either; figure out how to make forwarded messages send as if the forwarding mailbox sent them, or figure out how to change the name 'microsoftexchange329e71ec88ae4615bbc36ab6ce41109e@mydomain.com'.

    Any suggestions?


    Michael Fralick

    Thursday, August 11, 2016 9:07 PM

All replies

  • Hi all,

    I am running Exchange 2016 on Windows Server 2012 R2. Everything seems to be working great, except forwarding to external email addresses. I can get the emails to forward out, but they aren't forwarding the way I'd like them to. I have set it up through mail contacts and through powershell, I have not been able to get it to work correctly. Let me try to explain the scenario.

    Almost all of our mailboxes are being forwarded off site to personal email addresses. I have set up mailbox 5268 to forward out to personal@gmail.com through a mail contact. When I send an email from another mailbox in the organization, it forwards out to the personal@gmail.com as if it's from the other mailbox. The From: field shows othermailbox@mydomain.com. I would like it to say it's from mailbox 5268@mydomain.com. The reason for this is because we primarily use Unified Messaging and it would be nice to have the voicemails forward out as if they are from their own mailbox. In mailbox 5268 I set up "othermailbox" as having permissions under Send As:. This changed nothing. Oddly enough when I leave a voicemail for 5268 it sends the email out From:MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@mydomain.com on behalf of (caller id of received voicemail). Since it is coming from a strange address it ALWAYS gets flagged and dropped into Spam on the personal mailbox that it's forwarded to.

    I would like to achieve one of two things. Either; figure out how to make forwarded messages send as if the forwarding mailbox sent them, or figure out how to change the name 'microsoftexchange329e71ec88ae4615bbc36ab6ce41109e@mydomain.com'.

    Any suggestions?


    Michael Fralick

    This all sounds pretty convoluted, but if you want to change the 'microsoftexchange329e71ec88ae4615bbc36ab6ce41109e@mydomain.com' :

    https://technet.microsoft.com/en-us/library/bb430759(v=exchg.160).aspx

    ( applies to 2016 as well)


    Blog:    Twitter:   

    Thursday, August 11, 2016 10:43 PM
  • I was afraid my explanation would be hard to follow. I believe the link you shared will fix my problem though. Thanks!

    Michael Fralick

    Thursday, August 11, 2016 10:54 PM
  • Hi,

    Yeah, it’s really convoluted. Could you please describe the detailed information of your settings?

    Is User’s mailbox->5268@yourdomain.com -> mailcontact(a DG of contacts) -> enternal@gmail.com your mail flow path? 

    Hope the following blog helps:

    https://blogs.technet.microsoft.com/timmcmic/2015/06/08/exchange-and-office-365-mail-forwarding-2/

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jason Chao
    TechNet Community Support

    • Edited by Jason.Chao Friday, August 12, 2016 9:34 AM
    Friday, August 12, 2016 7:48 AM
  • Hi,

     

    Would you please provide us with an update on the status of your issue? If the solution helped, if so, please help to mark as answer, it'll be helpful and easily to search for others, thanks for your time.

     

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jason Chao
    TechNet Community Support

    Monday, August 22, 2016 1:55 AM