none
Windows 10 1809 RSAT

    Question

  • I want to install RSAT on Windows 10 1809, but these tools have been moved to Features On Demand. However installing using DISM does not work. I want to add several features using the following commands:

    dism /Online /add-capability /capabilityName:Rsat.ActiveDirectory.DS-LDS.Tools~~~~0.0.1.0 /Source:E: /LimitAccess
    dism /Online /add-capability /capabilityName:Rsat.DHCP.Tools~~~~0.0.1.0 /Source:E: /LimitAccess
    dism /Online /add-capability /capabilityName:Rsat.Dns.Tools~~~~0.0.1.0 /Source:E: /LimitAccess
    dism /Online /add-capability /capabilityName:Rsat.WSUS.Tools~~~~0.0.1.0 /Source:E: /LimitAccess
    dism /Online /add-capability /capabilityName:Rsat.GroupPolicy.Management.Tools~~~~0.0.1.0 /Source:E: /LimitAccess

    In E:\ I have mounted the Windows 10 ISO. What I get is an error that the source files cannot be found:

    DISM   DISM Package Manager: PID=7368 TID=6816  Error in operation: source for package or file not found, ResolveSource() unsuccessful. (CBS HRESULT=0x800f081f) - CCbsConUIHandler::Error

    Did anyone manage to install these features successfully? I tried this on 2 workstations, same result.

    Thursday, October 4, 2018 9:45 AM

Answers

All replies

  • Hi Yordan,

    If you run either DISM /image:<path_to_image> /get-capabilities or DISM /online /get-capabilities do you see the features you want above?


    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, October 4, 2018 9:57 AM
  • The binaries are not in the Windows 10 ISO.
    You need the "Feature on Demand" DVD1 if you want to do it offline...

    Gérald


    Thursday, October 4, 2018 11:37 AM
  • The Feature on Demand (FOD) ISO file is being talked about a lot everywhere, also in the Feature on Demand official documentation, but nowhere does it say where to obtain it?

    The Windows Server Feature on Demand (FOD) ISO can be downloaded from the Windows Server 2019 Evaluation Center, when you choose to download the Windows Server 2019 ISO file, you will automatically get the Windows Server FOD ISO.

    17763.1.180914-1434.rs5_release_amd64fre_SERVER-FOD-PACKAGES_OEM_amd64fre_MULTI.iso

    Direct download: https://software-download.microsoft.com/download/pr/17763.1.180914-1434.rs5_release_amd64fre_SERVER-FOD-PACKAGES_OEM_amd64fre_MULTI.iso


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, October 4, 2018 12:14 PM
  • The Feature on Demand (FOD) ISO file is being talked about a lot everywhere, also in the Feature on Demand official documentation, but nowhere does it say where to obtain it?

    I think that they are only available in VLSC or VisualStudio (fomerly MSDN).

    Thursday, October 4, 2018 12:47 PM
  • Thanks for clearing that up, I didn't check the obvious :-)

    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, October 4, 2018 12:52 PM
  • You can try to install these features not using DISM, but with the PowerShell cmdlet Add-WindowsCapability:

    Add-WindowsCapability –online –Name “Rsat.ActiveDirectory.DS-LDS.Tools~~~~0.0.1.0”

    see if that helps: http://woshub.com/install-rsat-feature-windows-10-powershell/


    • Edited by MaxBak83 Friday, October 5, 2018 4:26 AM
    Thursday, October 4, 2018 12:52 PM
  • Indeed, it worked with the FoD ISO. The tools listed are in the binaries found in the Part 1 FoD package (there are two parts of this). I downloaded them from my.visualstudio.com using an MSDN subscription. 

    Thursday, October 4, 2018 1:25 PM
  • Now RSAT is installed on win10 1809.

    I had to modified local computer policy before running the Add-WindowsCapability PowerShell CmdLet.
    Launch local group policy editor via gpedit.msc and navigate to "Computer Configuration\Administrative Templates\System\Specify settings for optional component installation and component repair"
    Enable the setting and select "Download repair content and optional features directly from Windows Update instead of Windows Server Update Services (WSUS)"
    Now launch powershell as admin and execute "Add-WindowsCapability -Online -Name Rsat.ActiveDirectory.DS-LDS.Tools~~~~0.0.1.0"

    This worked for me.


    SourabhR

    Friday, October 5, 2018 5:38 AM
  • And here's a handy script that I wrote to enable certain RSAT tools using binaries from the ISO. For me, this is the only way as access to Microsoft Update is disabled using Group Policy (to prevent Windows 10 from doing dual scanning)

    Mount-DiskImage -ImagePath "\\path\to.iso"
    $imgDrive = (Get-DiskImage "\\path\to.iso" | Get-Volume).DriveLetter
    Add-WindowsCapability -Online -Name "Rsat.ActiveDirectory.DS-LDS.Tools~~~~0.0.1.0" -Source ($imgDrive+":") -LimitAccess 
    Add-WindowsCapability -Online -Name "Rsat.DHCP.Tools~~~~0.0.1.0"  -Source ($imgDrive+":") -LimitAccess
    Add-WindowsCapability -Online -Name "Rsat.Dns.Tools~~~~0.0.1.0"  -Source ($imgDrive+":") -LimitAccess
    Add-WindowsCapability -Online -Name "Rsat.WSUS.Tools~~~~0.0.1.0"  -Source ($imgDrive+":") -LimitAccess
    Add-WindowsCapability -Online -Name "Rsat.GroupPolicy.Management.Tools~~~~0.0.1.0"  -Source ($imgDrive+":") -LimitAccess
    Dismount-DiskImage -ImagePath "\\path\to.iso"

    Friday, October 5, 2018 7:14 AM
  • With this command you will have the list name of the features:

    DISM /online /get-capabilities

    With this you will add them:

    dism /Online /add-capability /capabilityName:Rsat.WSUS.Tools~~~~0.0.1.0


    Eros

    Friday, October 5, 2018 7:15 AM
  • Hi Yordan, 

    We are very glad the issue could be resolved at the assistance of TechNet community and Microsoft engineer. If you have another other issue on Windows operating system, welcome backing to TechNet forum at any time. 

    Bests, 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 18, 2018 7:25 AM
    Moderator
  • No access to WSUS here. I didn't want to mount the ISO or copy the whole 4.6GB down to the clients to install this, so I experimented to see what the bare minimum I needed for just the Active Directory Users and Computers for Australian English was.

    I first just copied

    Microsoft-Windows-ActiveDirectory-DS-LDS-Tools-FoD-Package~31bf3856ad364e35~amd64~~.cab
    and
    Microsoft-Windows-ActiveDirectory-DS-LDS-Tools-FoD-Package~31bf3856ad364e35~amd64~en-US~.cab

    .. but it was failing, saying I needed to specify the source.

    I copied over the metadata folder and then it got further, but was still getting errors.  I monitored CBS.log for failures and eventually figured out that I also needed:

    Microsoft-Windows-ActiveDirectory-DS-LDS-Tools-FoD-Package~31bf3856ad364e35~wow64~~.cab
    Microsoft-Windows-ActiveDirectory-DS-LDS-Tools-FoD-Package~31bf3856ad364e35~wow64~en-US~.cab
    Microsoft-Windows-ServerManager-Tools-FoD-Package~31bf3856ad364e35~amd64~~.cab
    Microsoft-Windows-ServerManager-Tools-FoD-Package~31bf3856ad364e35~amd64~en-US~.cab

    I did not need FoDMetadata_Client.cab.  

    45 files at 14.8MB total, as per below.



    • Edited by nzdude Wednesday, December 5, 2018 5:24 AM
    Tuesday, December 4, 2018 2:36 AM
  • I hate to be naive, but what did you do with the files after you had the files?  

    I have tried everything from, expanding the files, to dism /online /add-package /packagepath:c:\yadayada

    To adding a source path... you didn't just copy to the WinSXS folder after expanding did you?  I have been trying this with WSUS, I have the Features getting DL'd with WSUS, I have to do this on basically a near airgapped PC. 

    Thanks!

    ************

    Well actually I believe I just got it, copied expanded files to a temp directory called c:\TEST. 

    Typed:

    DISM.exe /Online /add-capability /CapabilityName:Rsat.ActiveDirectory.DS-LDS.Tools~~~~0.0.1.0 /Source:c:\TEST /LimitAccess

    And it completed successfully... ugh.


    • Edited by rallymasta Friday, December 14, 2018 9:01 PM
    Friday, December 14, 2018 8:15 PM
  • This worked for me!

    Friday, December 28, 2018 7:13 PM