locked
Server 2008 R2- how to activate Allow service to interact with desktop in task scheduler ? RRS feed

  • Question

  • Hi, 

    I am trying to migrate news batches from windows server 2003 to windows server 2008 R2.
    To launch the tasks properly as it was on my previous server I need to check the option 'Allow servive to interact with desktop' in the task scheduler in Services.msc  .
    The problem is the option is greyed out and I cannot activate it.
    Would anyone know how to do ?

    Sébastien

    Wednesday, December 19, 2012 9:08 AM

Answers

  • Hello,

    You can change this setting by modifying the following value in registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Schedule => modify value "Type" from 20 to 120 (in hexadecimal)

    Then restart the server

    Regards
    Julien

    Wednesday, December 19, 2012 10:10 AM

All replies

  • Hello,

    You can change this setting by modifying the following value in registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Schedule => modify value "Type" from 20 to 120 (in hexadecimal)

    Then restart the server

    Regards
    Julien

    Wednesday, December 19, 2012 10:10 AM
  • I'll try this ! Thanks a lot for your answer.

    Regards

    Sébastien
    Wednesday, December 19, 2012 1:41 PM
  • Right click Task Scheduler service and selct Allow service to interact with desktop.

    Tuesday, June 24, 2014 8:06 PM