locked
Sharepoint 2010 site usage report using spweb.getusagedata method RRS feed

  • Question

  • Hi,

      I am developing custom webpart to dispay site usage data using spweb.getusagedata. It is showing some wrong data. 

    For example 

    User              Hits

    ddd\345         4

    DDD\345        0

    it is showing like this. For same user it is showing two rows with different no of hits. But domain name (ddd or DDD) is different.

    And one more bug is it is showing some user data who is not belongs to that site collection.

    Help please?

    Friday, July 26, 2013 3:41 PM

Answers

  • Hi Rathi,

    as i know domain name should be case-insensitive, i am not quite sure how there is more data in the table which getusagedata goes to.

    as i know there are 2 types of getusagedata method,

    http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.spweb_members.aspx

    which parameters did u use for this one? because those 2 method goes to different tables i think.

    is there any processes that updates those tables manually on your environment?


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by star.wars Monday, August 5, 2013 1:27 AM
    Thursday, August 1, 2013 9:56 AM

All replies

  • Hi Rathi,

    I am trying to involve someone familiar with this topic to further look at this issue.

    Thanks


    Daniel Yang
    TechNet Community Support

    Thursday, August 1, 2013 9:09 AM
  • Hi Rathi,

    as i know domain name should be case-insensitive, i am not quite sure how there is more data in the table which getusagedata goes to.

    as i know there are 2 types of getusagedata method,

    http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.spweb_members.aspx

    which parameters did u use for this one? because those 2 method goes to different tables i think.

    is there any processes that updates those tables manually on your environment?


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by star.wars Monday, August 5, 2013 1:27 AM
    Thursday, August 1, 2013 9:56 AM