locked
SSL for SharePoint 2007 Web Application RRS feed

  • Question

  • Hi All,

    I have Web Application in port 333 and for our requirement we need to extend the same Web Application to 334 port also. In the new extended 334 port app I need to have SSL enabled. May I know the best solution for this problem.

    In future if I need to have SSL for another port for example 777, is it possible to have SSL enabled in multiple Web Application in SharePoint Server ?


    Thanks Vivek http://www.redpipit.com
    Friday, December 16, 2011 3:26 AM

Answers

  • Hi,

     

    Did you once set SSL on the default web site and remove the certificate, then try to set it up on a second Web site?

     

    If this is your case, I suggest that you follow this article to resolve your issue.

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by Wayne Fan Friday, December 23, 2011 7:50 AM
    Tuesday, December 20, 2011 2:41 AM

All replies

  • You can extend the existing web application to port 334 and also enable SSL on this extended web application using the central admin.
    Stefan Goßner
    Senior Escalation Engineer - Microsoft CSS
    This post is provided "AS IS" with no warrenties and confers no rights.
    Friday, December 16, 2011 9:46 AM
  • Hi,

    I am in agreement with Stefan.

    You also need to provide certificates in IIS websites for the sites under SSL to work properly.


    Thanks, Rahul Rashu
    • Edited by Rashu,Rahul Sunday, December 18, 2011 8:03 PM Typo
    Sunday, December 18, 2011 8:03 PM
  • Hi,

     

    Agree with Stefan and Rashu.

     

    By default, SSL protocol uses port 443. You can use any port whatever you like, but you need to let your clients know that before you enable SSL. You can also enable SSL in multiple web applications, however, you need to use different port for each web application.

     

    For the detailed information about how to configure a SharePoint website to allow SSL connections, check out the following links:

     

    http://blog.mastykarz.nl/configuring-ssl-in-sharepoint-2007-development-environment/

     

    http://www.sharepointconfig.com/2010/03/configuring-a-sharepoint-website-to-allow-ssl-connections/

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    Monday, December 19, 2011 3:45 AM
  • Yes, I did as per your suggestion.

    But after extending with SSL, I am getting Page Cannot Be Displayed error for the Extended site


    Thanks Vivek http://www.redpipit.com
    Tuesday, December 20, 2011 12:34 AM
  • Hi,

     

    Did you once set SSL on the default web site and remove the certificate, then try to set it up on a second Web site?

     

    If this is your case, I suggest that you follow this article to resolve your issue.

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by Wayne Fan Friday, December 23, 2011 7:50 AM
    Tuesday, December 20, 2011 2:41 AM
  • Hi,

    How is it going? If you have any questions, feel free to reply to the forum.

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    Thursday, December 22, 2011 2:34 AM