Power Pivot Data Type Error RRS feed

  • Question

  • Hi All,

    I'm fairly new to Power Pivot & even newer to Power Query (installed it today!).  I have a data table with a column formatted as number.  However, when I add this to the data model is simply gives the error message

    "The following system error occurred:  Type mismatch.
    Datatype conversion failed for [Table: 'TBL_SMaster_PPT', Column: 'Value', Value: 'TRUE']."

    The 'Value' column data type in Power Pivot is showing as 'text'.  I've tried changing the data type in the source table and in the Power Pivot window.  I've even tried adding a calculated column converting it to numbers via Value to no avail.

    I can find mention of similar problems on the web but so far haven't found the solution.

    NB This is probably not relevant but I created the data table by taking a flat table & converting it to columns via power query.  The forma in the resulting table states 'number'


    M Short

    • Edited by MAS42 Wednesday, November 26, 2014 2:10 PM
    Wednesday, November 26, 2014 2:09 PM


  • Hi Again,

    Solved my own problem a few seconds after posting my message above.  I was 100% wrong when I said this probably had nothing to do with Power Query.

    I went back to power Query & had another look. This time I noticed that if you right click on the suspect column header (not the column itself which I had done previously) you get several more options, including 'Change Type'.  By changing this to number & rerunning the query this appeared to change the underlying data type which then pulled through to Power Pivot.

    I'll leave this message posted for any other Power Query/Power Pivot newbies out there like me.


    M Short

    • Marked as answer by MAS42 Wednesday, November 26, 2014 2:17 PM
    • Edited by MAS42 Wednesday, November 26, 2014 2:18 PM
    Wednesday, November 26, 2014 2:17 PM