locked
Windows 7 folder in new window RRS feed

  • Question

  • Hi!
    I installed windows 7 ultimate yesterday on my official laptop and it was working fine until today morning when i installed some updates from windows updates. I had also installed .net framework 1.1 at the sametime. now after reboot, my os would fail to open folders in the existing window. it would create a new window for each folder inspite of the settings where open in same window is set in folder settings.
    I have uninstalled the updates, .net framework 1.1 and also did a system restore to the previous point but in vain. i had installed the following applications after which my os went kaput.
    Acrobat reader 9.0
    .Net framework 1.1
    Vault Souce control
    WinRAR.

    I uninstalled and rebooted all of them one by one.

    Sunday, January 24, 2010 1:56 PM

All replies

  • Hi there,

    Have you try another restore point as a test? Do you have encounter any error message when try to restore the system?

    If all restore point did not work, I think the settings in Registry is incorrect/corrupted. Please copy the following text (Do not include the star marks lines) to Notepad and save it as a reg file, double click to open and import the key, reboot and check if you still have the same issue:
    ****************************
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
    "Settings"=hex:0c,00,02,00,1b,01,e7,77,60,00,00,00

    ****************************

    If reboot still not work, please also import the following key:
    ****************************
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoSaveSettings"=dword:00000000
    ****************************

    PS: not sure why would you install .Net Framework 1.1 as Windows 7 includes the following versions of the .NET Framework:
    v1.0.3705
    v1.1.4322
    v2.0.50727
    v3.0
    v3.5

    Monday, January 25, 2010 5:58 AM
  • Hi!

    I installed .Net Framework 1.1 since while installation of vault, it have me an error that .net framework 1.1 is required to install vault. I will try the resolution provided about and get back to you.

    Ravi Gokulgandhi
    Monday, January 25, 2010 3:43 PM
  • Hi!

    The above solution dod not work. The registry values have been modified but after reboot, this still does not work. If i rightclick on a folder and click open, it rightly opens the new folder in the same window but the problem seems to be when i double click on the folder.

    Ravi Gokulgandhi
    Monday, January 25, 2010 3:52 PM
  • Hi,

    Since the two register key control the new open window style, I would be helpful if you can check the current value of the two keys and paste it in you post.
    ----------------------
    Open Regedit and open [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
    Right click “CabinetState” and chose “Export”, open the reg file via right click -> Edit, copy and paste the value in your reply.
    Repeat your steps and paste “Explorer” key under : [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

     

    Tuesday, January 26, 2010 5:15 AM
  • Hi!

    Find the required info below

    --- CabinetState
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
    "Settings"=hex:0c,00,02,00,1b,01,e7,77,60,00,00,00
    "FullPath"=dword:00000000

    --- Policies
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoSaveSettings"=dword:00000000

     

    Tuesday, January 26, 2010 8:57 AM
  • Hi,

    The current value is correct, since the setting was saved under “HKEY_CURRENT_USER”, I suggest you test the issue in New Account as a test.
    http://windows.microsoft.com/en-us/Windows7/Create-a-user-account

    Do you still have the same issue now? You can consider transfer/copy data from previous account to new one as a quick fix.

    Tuesday, January 26, 2010 9:23 AM
  • Hi!

    I created a new administrator user "RG".. logged in using that ID but it didn't work.  

    Ravi Gokulgandhi
    Tuesday, January 26, 2010 5:35 PM
  • First of all, I think it’s necessary to run a full scan with anti-virus program since this type of issue can be caused by virus.

    If the system is clean, I believe this is not a config issue but a system register info corrupted one.

    I suggest you download and run RegisterActxprxyAndIeproxy.cmd file from the following link to re-register two dll related files:
    http://www.davidmoore.info/wp-content/uploads/2009/12/RegisterActxprxyAndIeproxy.zip

    You must run this batch file with administrative privileges (right click on the file and choose Run as administrator), do you still have this issue in your original account after a reboot?

    PS: this batch file is safe and attached it’s source(running fine in both 32 bit and 64 bit):

    @echo off
    
    :: 32 bit and 64 bit
    IF EXIST "%SystemRoot%\System32\actxprxy.dll" "%SystemRoot%\System32\regsvr32.exe" "%SystemRoot%\System32\actxprxy.dll"
    IF EXIST "%ProgramFiles%\Internet Explorer\ieproxy.dll" "%SystemRoot%\System32\regsvr32.exe" "%ProgramFiles%\Internet Explorer\ieproxy.dll"
    
    :: 64 bit only (32bit on 64 bit)
    IF EXIST "%WinDir%\SysWOW64\actxprxy.dll" "%WinDir%\SysWOW64\regsvr32.exe" "%WinDir%\SysWOW64\actxprxy.dll"
    IF EXIST "%ProgramFiles(x86)%\Internet Explorer\ieproxy.dll" "%WinDir%\SysWOW64\regsvr32.exe" "%ProgramFiles(x86)%\Internet Explorer\ieproxy.dll"
    Wednesday, January 27, 2010 1:12 AM
  • The problem seems to be caused by Vault

    See this thread, and search on "vault":

    http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/d5d3e5fc-d8ce-4f42-b7ea-9bbbb7756a20

    Monday, March 1, 2010 5:06 PM
  • Monday, March 1, 2010 5:07 PM
  • This solved the problem. I didn't even have to reboot. Thanks a lot. I had been trying to find a solution to this for quiet some time, but with no success. Till now I had been using "Right click -> Open" to open folder in the same window which was very annoying. Now everything is fine.

    Thanks again!

    Saturday, June 19, 2010 5:43 AM
  • Hi,

     

    I had exactly the same issue too, the .bat file resolved it!

     

    Thanks!

    Saturday, August 20, 2011 5:02 PM