locked
How to disable wireless when docked in Vista? RRS feed

  • General discussion

  • Hi there. Sorry for posting here but I did not find an appropriate forum for Windows Vista.

    Hardware profiles...
    In Windows XP, I could in Device Manager, go to options on the wireless card, and then select Do not use this device in the current hardware profile (disable). Thus it would auto-enable the WLAN card if I undocked the computer.

    But in Vista, I am no longer able to do this. The choice is not present (Microsoft REMOVING features in Vista instead of adding features? :)  )

    Can anybody please help us how to do this in Vista?
    Sunday, March 1, 2009 10:21 AM

All replies

  •  

     

    Hi,

     

    Thank you for posting.

     

    Based on my research, I found this feature in Windows XP is no longer supported by Windows Vista. Windows Vista will automatically create hardware profiles depending on the type of computer you are using. If you are using a laptop, Windows Vista will automatically create a profile called "Undocked." When you dock your laptop, Windows Vista will use the wired connection, since wired connection is faster than the wireless connection. Therefore, we don’t need to disable the wireless card while docking the laptop.

     

    Hope this helps.

     

    Thanks.

     

     


    Nicholas Li - MSFT
    Wednesday, March 4, 2009 9:15 AM
    Moderator
  • Well that is a nice intention, however when a program is somehow "locked" to a connection, you cannot make it break if you dock it. Thus if you are in a live meeting or similar, you still continue on the old wireless connection, even if you dock it, which in our case is not what we intend.

    It's nice to see that Microsoft is trying to do things automatically, but one cannot always remove features that are actually useful to control!
    Wednesday, March 4, 2009 3:10 PM
  •  
    How are you after my research, at windows vista no longer supports this feature, windows vista will automatically create a document fixed then practice your laptop, if not using a wireless network adapter, please select in the Control Panel Network Connections to prohibit the wireless card you can! !
    Saturday, March 7, 2009 12:21 PM
  • with all due respect liuyihang, that was the most strange english i've read for ages. I suggest you read my posts once more and erase your strange comment. There is no solution for my problem now.
    Monday, March 9, 2009 9:59 AM
  •  

    Hi,

     

    Thank you for your response.

     

    When the current connection is using by a program, it is not recommended to switch the connection from wireless to wired since this may cause unexpected issues. 

    If you want to force to disable the connection, you can try to do this manually in the device manager or your connection management utility.

    Thanks.


    Nicholas Li - MSFT
    Friday, March 13, 2009 9:58 AM
    Moderator
  • You expect our users to understand that? Are you even working in Microsoft?

    I still await a good answer for why Microsoft chosed to remove a good feature from XP.
    Wednesday, March 25, 2009 9:40 AM
  • Sunday, May 31, 2009 1:45 PM
  • Thank you very much wlanbook! this resolves this thread I guess! :)

    Strange how Microsoft seem to work against us users.
    Tuesday, June 2, 2009 9:25 AM
  • This is Microsoft’s way of dealing with laptops that have a Wired Network Card (NIC), a Wireless Card and, perhaps Bluetooth. Each card has its own TCP/IP and they can all work together when configured to work to a priority. The TCP/IP configuration has a special setting for ‘Metric‘. If they have different numbers in the Metric entry, the actual connection would default to the one with the lower number, e.g. if you set Metric to 5 in the Wired Network connection and to 10 in the Wireless Connection, the system would default to the wired connection. Obviously, when the cable is unplugged (or not present) it would automatically switch to wireless connection (if present). When the cable is plugged back in, it would take over the connection since it has a lower metric setting.

    This has to be done on all connections; e.g. Ethernet, Bluetooth and wireless, as follows:
    Go to Control Panel > Classic View > Network and Sharing Center > Manage Network Connections (in the left pane) then right-click a network interface > Properties > scroll down and highlight, in turn, each TCP/IP > Properties > General Tab > Advanced (at the bottom) and click the Automatic Metric box to clear the tick, then enter the value that you want in the Interface Metric field.

    Tuesday, June 2, 2009 1:34 PM
  • Burr this is nice to know, however windows will not reconnect EXISTING TCP/IP connections, only NEW connections. Thus it creates a problem when a user e.g. uses the WLAN during a video conference. And when other people complain about laggy picture/sound if the bandwith is low he/she then plugs the computer in a wired connection. By using the software from wlanbook it will automatically close down the wlan and enforce the program to re-connect, whilst by using only Microsoft it will still continue using the WLAN connection since the exising session is still active.
    Wednesday, June 3, 2009 6:15 AM