locked
Windows 7 64bit with Office 2003 slow opening files network RRS feed

  • Question

  • I have several Dell Optiplex 380 computers running windows 7 pro 64bit.  Whenever I try to open an excel or word file from my network share it takes between 7-10 seconds to open the file.  This happens if I use explorer to open, open with the program, or use the recent file lists.  I am running a fully patched version of 7 and fully patched version of office.  The share is located on a Netware 6.5 server.
    Friday, October 29, 2010 1:04 PM

Answers

  • Hi,

    Based on our experiences, 7 to 10 seconds is a normal behavior.

    Your network file server may not SMBv2 because it was developed prior to SMB2. If you would like to speed up, try to disable SMBv2. Please use the following commands.

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc config mrxsmb20 start= disabled

    Please note: there's an extra " " (space) after the "=" sign.

    However I do not think that SMBv2 should be disabled in this case. The following article introduces the advantages of SMB2.

    SMB2, a complete redesign of the main remote file protocol for Windows
     
    Network performance issues can also be caused by auto-tuning, because not all network devices support auto-tuning well. To disable auto-tuning, use the following command.

    netsh interface tcp set global autotuninglevel=disabled

    Please note that all the commands need to be run in cmd window that with high privilege.

    Arthur Xie
    TechNet Subscriber Support in forum  
    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Wednesday, November 3, 2010 9:40 AM
    Monday, November 1, 2010 6:33 AM

All replies

  • Hi,

    Based on our experiences, 7 to 10 seconds is a normal behavior.

    Your network file server may not SMBv2 because it was developed prior to SMB2. If you would like to speed up, try to disable SMBv2. Please use the following commands.

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc config mrxsmb20 start= disabled

    Please note: there's an extra " " (space) after the "=" sign.

    However I do not think that SMBv2 should be disabled in this case. The following article introduces the advantages of SMB2.

    SMB2, a complete redesign of the main remote file protocol for Windows
     
    Network performance issues can also be caused by auto-tuning, because not all network devices support auto-tuning well. To disable auto-tuning, use the following command.

    netsh interface tcp set global autotuninglevel=disabled

    Please note that all the commands need to be run in cmd window that with high privilege.

    Arthur Xie
    TechNet Subscriber Support in forum  
    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Wednesday, November 3, 2010 9:40 AM
    Monday, November 1, 2010 6:33 AM
  • We too are having issues with the 64bit version of Windows 7 Pro (and XP Pro) and performance.

    In some cases, it's a matter of very slow access to network folders and in other cases, it's a matter of Excel taking forever to open a spreadsheet (also on network folders).

    Same locations and same files on 32 bit OS computer and no problems!

    Some servers are 2008 R2 patched as of 11/25/2010 and others are 2008R2 fully patched as of a week ago.

    Thanks,

    Danny


    Danny C.
    Wednesday, February 9, 2011 11:28 PM
  • Hi,

    Based on our experiences, 7 to 10 seconds is a normal behavior.

    Your network file server may not SMBv2 because it was developed prior to SMB2. If you would like to speed up, try to disable SMBv2. Please use the following commands.

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc config mrxsmb20 start= disabled

    Please note: there's an extra " " (space) after the "=" sign.

    However I do not think that SMBv2 should be disabled in this case. The following article introduces the advantages of SMB2.

    SMB2, a complete redesign of the main remote file protocol for Windows
     
    Network performance issues can also be caused by auto-tuning, because not all network devices support auto-tuning well. To disable auto-tuning, use the following command.

    netsh interface tcp set global autotuninglevel=disabled

    Please note that all the commands need to be run in cmd window that with high privilege.

    Arthur Xie
    TechNet Subscriber Support in forum  
    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    Arthur,

    We have this issue at several clients and each time disabling SMB v2 fixed the issue. Any idea why we need to disable this. Is there any known issue about this?

     

    Thanks!

     

    Regards,

    Robin

    Thursday, May 26, 2011 2:20 PM
  • My files were taking up to 4 minutes to open!  Security Update for Microsoft Office Excel 2003 KB2502786 and KB2541025 were the problem for me- uninstalled those and excel files open quick on the network-  re-install them and its back to very slow.  
    Friday, July 15, 2011 5:46 PM
  • I was also getting the same issue. Just one machine on the network (Windows 7 Home Premium 64bit) was very slow opening Excel spreadsheets. Under the recommendation of wmundy3, I uninstalled the two security fixes and all was back working as expected, so thank you very much for the help ... much appreciated.

    What I am not so happy about is the fact that I have now removed two security fixes which both seem to be related to the ability for malicious code to be run compromising the security of excel.

    Can anyone help with a solution that does not involve removing security patches that are obviously needed.

    Many thanks,

    Mark.

    Friday, July 22, 2011 12:24 PM
  • Excellent advice, it has worked for me, many thanks, Keith
    Tuesday, August 9, 2011 2:22 PM
  • Hi,

    I am facing the same issue on 64bit WIN7 ent. and Office 2003 installed. However, the patches mentioned above are definetly not installed. Does anybody gather some more results in regards to this problem?

    Thanks,

    Markus

    Thursday, August 11, 2011 8:38 AM
  • Hi,

    *** Update ***

    While investigating this problem, I gathered the installed updates from the affected remote machine with a script ( http://msinfluentials.com/blogs/jesper/archive/2007/12/28/remotely-listing-all-installed-updates.aspx )

    For some reasons, the log created from the script does not contain the KB updates mentioned above.
    I went to the machine and in Control Panel - Software the kb2541025 update was listed. Uninstalled this, works fine.

    Thanks for the advise in his tread,

    Regards

    Markus

    Thursday, August 11, 2011 11:55 AM
  • Same here - Excel 2003 taking MANY minutes to open files on the network share.

    I was only looking at the network and serving device, it was driving me crazy.

    Finally found this thread....

    Uninstalled the Security Updates for Microsoft Office Excel 2003 KB2502786 and KB2541025

    Now Excel opens files instantly.

    Thanks,

    Bruce

    Tuesday, September 6, 2011 6:15 PM
  • I am having a similar issue:

    All my citrix servers (windows 2008) are taking ages to open office documents from our 2003 file server

    The servers have loads of resources and we are on a gig lan
    I have disabled smb2
    I have checked and i dont have hofixes KB2502786 and KB2541025 installed

    This is really frustrating as we have invested a lot of money recently and have moved into a new office but the office files slow opening speed is driving everyone nuts

     

    Can anyone help?

    Thursday, December 22, 2011 12:32 PM