locked
new sharepoint application and site collection gives blank page RRS feed

  • Question

  • Hi I'm using WSS 3.0 and the default site works fine.

    I deciede to create a new application to run on port 80so I created a 'new web application' and then I created a 'site collection'. but when I browse to http://extranet I get a blank page.

    So I then created a test website through IIS7 and this works ok ?

    Any ideas ?

    Thanks

     

    • Moved by Clayton Cobb Saturday, January 8, 2011 12:23 AM 2007 question (From:SharePoint 2010 - General Questions and Answers)
    • Edited by Mike Walsh FIN Saturday, January 8, 2011 8:00 AM There is no WSS 2007. Corrected to the correct WSS 3.0
    Friday, January 7, 2011 9:31 PM

Answers

All replies

  • You can create only one Web application/IIS Web site on one port. You say that "..the default site works fine". Is it on another Port ?

    From your Central administration, find out the URL of the new "Site Collection" you created, and try to open the site in browser using this URL.

    Friday, January 7, 2011 9:48 PM
  • Hi

    I'm using Host Headers so I should be able to host more than one IIS site on a single port. eitherway I've only got the new web application running on port 80 at moment.

    When I navigate to the new site collection i get a blank page.

    I've just tried the whole thing again but this time when I browse to the new site http://outings I'm now promped for a username and password  which i provide but still get a blank page.

    Really stuck on this. any help appreciated.

    Friday, January 7, 2011 10:23 PM
  • Roaschicken, this is your 2nd 2007 thread in the 2010 forums.  Is there a reason you're doing that?

    You can't have more than one site on port 80 unless you use a host header.  You should first disable the default site, so it doesn't take up port 80.  Then, if you're using a host header for the new web app, make sure you either 1) add it to DNS so that machines on the network now how to browse to it, or 2) modify your local machine's Hosts file so that you can map the host header to your local IP.  Your browser can't know where to go without telling it how to resolve the URL.  It only works without DNS or a Hosts file entry if you're using machine name as the URL, which won't work on port 80 unless no other site is on port 80.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Saturday, January 8, 2011 12:21 AM
  • YOu also have to Disable the Loopback check if you're browsing from the server itself to a host header URL:


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Saturday, January 8, 2011 12:22 AM
  • Hi,

    I don't know if is the same problem, but when I was using http:\\localhost it was working.
    I've created a Host Header to 127.0.0.1 called http:\\testing and I was getting a blank website still.
    My problem was with the IE logon, was anonymous logon enabled. To change it I've followed the steps bellow:

    At the Internet Explorer go to Tools, after Internet Options, than at the Security tab, go to Custom level... User Authentication >> Logon >> Prompt for user name and password I hope it can help somebody.


    Tito

    Friday, March 11, 2011 2:39 AM