locked
Cannot find any user with search RRS feed

  • Question

  • Hi,

    New S4B 2015 environment, this has never worked.

    I cannot find any user with search, when using real names. I can find user with sip address though.

    When accessing to https://<s4b server>/abs/handler  i will get  401 - unauthorized

    Is that reply normal? How to verify functionality of Address Book?

    I have created new client policy with WebSearchOnly, but that does not solve the issue.

    Test-CsAddressBookService gives:

    Target Fqdn   : <server fqdn>
    Target Uri    : https://<server fqdn>:443/abs/handler
    Result        : Failure
    Latency       : 00:00:02.4068183
    Error Message : No response received for Web-Ticket service.
                    Inner Exception:The HTTP request is unauthorized with client au
                    thentication scheme 'Ntlm'. The authentication header received
                    from the server was 'Negotiate,NTLM'.
                    Inner Exception:The remote server returned an error: (401) Unau
                    thorized.

    Diagnosis     :
                    Inner Diagnosis:X-MS-Server-Fqdn : <server fqdn>
                    X-MS-Correlation-Id : 2147483897
                    client-request-id : e9e9186d-2cdc-4726-9875-7b0a695f66de
                    Strict-Transport-Security : max-age=31536000; includeSubDomains
                    Cache-Control : private
                    Content-Type : text/html; charset=utf-8
                    WWW-Authenticate : Negotiate,NTLM
                    X-Content-Type-Options : nosniff
                    Date : Thu, 18 May 2017 07:55:22 GMT
                    Content-Length : 4902


    Thursday, May 18, 2017 7:42 AM

All replies

  • And found it... CsWebServiceConfiguration was missing the use windows auth.

    So running Set-CsWebServiceConfiguration –UseWindowsAuth Negotiate solved this one.

    • Proposed as answer by jim-xu Friday, May 19, 2017 9:10 AM
    Thursday, May 18, 2017 9:08 AM
  • And found it... CsWebServiceConfiguration was missing the use windows auth.

    So running Set-CsWebServiceConfiguration –UseWindowsAuth Negotiate solved this one.

    Hi Hannu,

    Thanks for your back and share your solution with us,  we suggest you make it as answer so that someone who has similar issue could find solution in this thread as soon as possible.



    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 19, 2017 9:10 AM