locked
Hiding users on the login screen RRS feed

  • Question

  • Hi there peeps,
    I was wondering if anyone had any ideas on this subject.
    I have just performed a clean install of Windows 7 Professional on a company laptop for one of our less trustworthy users.

    I have the hidden 'true" admin account which is password protected, then I have created a user with administrative priveledges (user 1) and an additional user as a standard user (user 2).
    I am trying to display only 'User 2' on the login screen, therefore I need to hide 'Administrator' and 'User 1'.

    I could get this to work with no problems on Vista by following these steps:

    "Open regedit.
    Navigate to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonRight-click the Winlogon key in the left-hand pane and select New -> Key. Name this new key SpecialAccounts. Right-click the new SpecialAccounts key in the left-hand pane and select New -> Key. Name this new key UserList. Select this key after it is created. With the UserList key selected, right-click in the Right-hand pane and select New -> DWORD (32-bit) Value. Name the new DWORD value the same as the account you want hidden. In my case, the name of the value was User 1. Make sure the value of this new DWord is set to zero (0) to hide the account."

    I have followed this for the User 1 account and the Administrator account, but only the Administrator account is now hidden from the login screen.

    Is there anything else I could try?

    Thanks in advance!

    Thursday, November 12, 2009 3:26 PM

Answers

  • Hi BeckyBoo123,

     

    I reread your first post and noticed that you were trying to hide all the accounts with administrator privilege from the Welcome Screen. Please understand that once we hide all the administrator accounts by changing the registry key, we will no longer change the registry key back since the Standard user has no permission to modify the registry key and the administrator accounts can no longer be accessed.

     

    Therefore, it is not recommended disabling all the administrator accounts from the Welcome Screen.

     

    However, you can use the following suggestions to enter the user account automatically as a workaround.

     

    1.     Go to Start, type Run in the Search box.

    2.     Click on Run in the Program list.

    3.     Type "control userpasswords2" (without the quotation marks) and then press Enter.

    4.     Highlight "user 2" in the list.

    5.     On the Users tab, uncheck "Users must enter a user name and password to use this computer.

    6.     Click Apply.

    7.     Enter the password for "user 2".

    8.     Click OK.

     

    Please restart the computer and user 2 will be logged in automatically.

     

    Regards,

    Linda

     

     

     

    • Marked as answer by Linda Yan Thursday, November 19, 2009 2:51 AM
    Monday, November 16, 2009 3:28 AM

All replies

  • Hi BeckyBoo123,

     

    You can try the following steps to see if the accounts can be hidden:

     

    NOTE: Please carefully when hiding the user account from the Welcome Screen, or you may lock out yourself from accessing the system.

     

    1. Click Start, type REGEDIT into Search bar and press Enter. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

     

    3. Right click Winlogon in the left pane, click Export, select Desktop in the Save in box and type Backup (without the quote) in File Name, then click Save.

     

    Note: The backup file is on the Desktop and named as Backup.reg. We can simply restore the registry by double-clicking the backup.reg file. Once we have completed the troubleshooting and the issue has been resolved we may delete that file.

     

    4. Right click on Winlogon on the left pane, click New -> Key.

    5. Name the key as SpecialAccounts.

    6. Right click on SpecialAccounts on the left pane, click New -> Key.

    7. Name the key as UserList.

     

    8. Right click on UserList on the left pane, click New -> DWORD (32-bit) value.

    9. The value name is the exact username that you want to hide.

     

    For example, I would like to hide user account "Test" from the Welcome Screen, the value name for this key is Test.

     

    10. The numerical value is a 0 or a 1. If you set it to 0, then the account will be hidden. Set it to 1, and it will be shown.

     

    Regards,

    Linda

     

    Friday, November 13, 2009 6:35 AM
  • Hi Linda, thanks for the suggestion but I have already tried that. Is there anything else I could try or even any software out there like Tweak UI which includes the option to hide accounts which work with Windows 7?
    Friday, November 13, 2009 9:00 AM
  • Hi BeckyBoo123,

     

    I reread your first post and noticed that you were trying to hide all the accounts with administrator privilege from the Welcome Screen. Please understand that once we hide all the administrator accounts by changing the registry key, we will no longer change the registry key back since the Standard user has no permission to modify the registry key and the administrator accounts can no longer be accessed.

     

    Therefore, it is not recommended disabling all the administrator accounts from the Welcome Screen.

     

    However, you can use the following suggestions to enter the user account automatically as a workaround.

     

    1.     Go to Start, type Run in the Search box.

    2.     Click on Run in the Program list.

    3.     Type "control userpasswords2" (without the quotation marks) and then press Enter.

    4.     Highlight "user 2" in the list.

    5.     On the Users tab, uncheck "Users must enter a user name and password to use this computer.

    6.     Click Apply.

    7.     Enter the password for "user 2".

    8.     Click OK.

     

    Please restart the computer and user 2 will be logged in automatically.

     

    Regards,

    Linda

     

     

     

    • Marked as answer by Linda Yan Thursday, November 19, 2009 2:51 AM
    Monday, November 16, 2009 3:28 AM