WUSA.exe error when attempting to install Windows updates from Microsoft Downloads RRS feed

  • Question


    When I attempt to install several of the recent compatibility and reliability updates manually from the Microsoft downloads web site, I recieve the following error message:


    Installer encountered an error: 0x8007000d

    The data is invalid.


    In the event log, the error reads:


    The Windows update could not be installed because of an error: 2147942413 "The data is invalid." (Command line: ""C:\Windows\system32\wusa.exe" "C:\Windows6.0-KB941649-v2-x86.msu" ")


    The specific hotfixes are:







    I honestly have no clue where to start with this one. Couldn't find anything relevant online or MS's site. I thought it might be firewall/antivirus blocking problem, but even turning those off accomplished nothing. Any ideas as to what I could try???


    **(Also posted in Windows Setup Forum)

    Thursday, November 1, 2007 10:23 PM

All replies

  • Could be an unsigned security update from the past, try this to locate and destroy the update:


    - Click Start > Run
    - Type "SIGVERIF" (w/o quotes) Press OK
    - Click Advanced
    - Select "Look for other files that are not digitally signed"
    - In the "Look in this folder" box type in C:\WINDOWS\SYSTEM32\CATROOT
    - Check Include Subfolders
    - Click OK, then click Start

    When the report completes it should list any unsigned files, CAT files. If we see any here we will want to locate them and move them out of the CATROOT folder.

    Download and install the updates from Windows Update.



    hope this works fine for you...
    Friday, November 2, 2007 12:40 AM
  • Not entirely helpful, as you can't specify the folders in Vista (unless I'm missing something?). However, it appears that there are no unsigned files in the catroot folder, so I don't think it will work. Thanks for trying though.


    Friday, November 2, 2007 1:21 AM
  • I too have this same problen dgardner, i have emailed microsoft and have 11 emails with several sugestions but nothing has helped. in the end they sugested i reinstal vista.

    Saturday, November 3, 2007 2:41 AM
  • I suppose you already tried this:


    - stop Windows Update service

    - delete contents in %systemroot%\SoftwareDistribution, both folders Datastore and download

    - restart the service


    also looking in the WindowsUpdate.log file could tell you why something crashes. Some KB article can decrypt the contents hereby...


    Personally, I had some troubles in the past with the Updates, and had to re-install once, but now for some months all works fine for me... Also try some restore points, and re-install... should this doesn't work: as a last resort, but maybe not a bad idea at all: reinstall Vista.


    Sunday, November 4, 2007 2:43 PM

    Yep tried that already. Basically all the updates I listed are scheduled to be part of SP1, so I may just wait for that rather than try and update now. My concern with that strategy, though, is that I will not be able to install SP1 because of the WUSA errors, as I believe service packs are installed through this app. I think I'll try a startup repair from the windows disk, but a complete reinstall may be inevitable anyways.
    Tuesday, November 6, 2007 1:07 AM

    Hi, I had the same problem, I could not install that update. But I read about a solution on another forum...and it WORKS.


    You go into Control Panel>Uninstall a Program click the 'view installed updates' and then find the update and unistall it. Then you download it and reinstall it. It appears that microsoft came out with a new version of it, but it is still named the same as the old one. Hope this works for you guys.

    Wednesday, March 5, 2008 6:46 PM