none
Resources do not list for a User Set Up as Resource Manager in Project Server 2010 RRS feed

  • Question

  •  I have a fully functioning Project Server 2010 PWA instance in VMware .

    I have a user setup as a Resource Manager ie

    - In Settings >> Server Settings >> Manage Users >> Edit User: <User Name> >> Security Groups >> Groups that contain this user – entry is “Resource Managers”

    - In Settings >> Server Settings >> Manage Users >> Edit User: <User Name>  >> Security Categories >> Selected Categories – no entry

    - In Settings >> Server Settings >> Manage Groups >> Resource Managers >> Add or Edit Group >> Users >> Selected Users – entry is <User Name>

    - In Settings >> Server Settings >> Manage Groups >> Resource Managers >> Add or Edit Group >> Categories >> Selected Categories – entries are “My Direct Reports”, “My Organisation”, “My Projects”, “My Resources”

    Each of the categories “My Direct Reports”, “My Organisation”, “My Projects”, “My Resources” have been set up with the default settings.

     

    My problem is the Resource Manager does not have any resources listed at Resources >> Resource Center yet my Project Managers do. The Project Managers are at the same level as the Resource Manager in the RBS.

     

    Is there a setting I have missed?

    Friday, January 21, 2011 1:00 AM

Answers

  • First thing I try in any security issue is the 2007 View Effective Rights tool.  It hasn't been released for 2010, but informal testing seems to indicate that it works on a 2010 environment.  It might help point you in the right direction.


    Andrew Lavinsky [MVP] Twitter: @alavinsky
    • Marked as answer by TJSAU Monday, January 24, 2011 7:43 AM
    Monday, January 24, 2011 2:20 AM
    Moderator
  • Hi Trevor,

    Further to the Andrew response, here is the link where you can find the details about how to use the tool and download the tool. This definetly will help you find the problem within your group/categories permissions.

    Also, if i were you i would eliminate all the categories except one (My resources) from the Resource Manager group, set the appropriate permission to view all the enterprise resources with that one category and then try. this is how you can atleast isolate the problem, and with all the categories part of your group it would be nightmare, without tool, to find exactly where is the problem.

    Let us know if it help you by any mean or provide us some detail about the issue.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    • Marked as answer by TJSAU Monday, January 24, 2011 7:43 AM
    Monday, January 24, 2011 5:45 AM

All replies

  • HI TJSAU,

    check the Resource Managers categories and see if the following is "Deny" or not checked on any of the categories:

    Have you set the resource center and build team views in your Resource Managers categories?

    1. go to the category (repeast this for all the cateogies attached with the Resource Managers group)

    2. expand the 'View - add to category ',

    3. scroll down to the Resource Center,

    4. Check the All resources OR Work Resources OR both, (if you can do this you can see the resources in resource center, but not in build team)

    5. scroll down further to the Team Buildier,

    6. select work resources OR all the option (now the resource will also available in Build team for you)

    Let me know if it works for you.



    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    • Proposed as answer by Khurram Jamshed Sunday, January 23, 2011 11:26 AM
    • Unproposed as answer by TJSAU Sunday, January 23, 2011 9:55 PM
    Friday, January 21, 2011 10:19 AM
  • Thanks for your response Khurram - apologies for the delay.

    I have reviewed the Resource Center and Team Builder settings for each of the categories and they are all checked as per the default settings ie checked for  “My Organisation”, “My Projects”, “My Resources” and not checked for "My Direct Reports" (even when I set these the Resource Centre does not appear).

     

    So no success so far.

     

    Thanks

    Trevor

    Sunday, January 23, 2011 10:00 PM
  • First thing I try in any security issue is the 2007 View Effective Rights tool.  It hasn't been released for 2010, but informal testing seems to indicate that it works on a 2010 environment.  It might help point you in the right direction.


    Andrew Lavinsky [MVP] Twitter: @alavinsky
    • Marked as answer by TJSAU Monday, January 24, 2011 7:43 AM
    Monday, January 24, 2011 2:20 AM
    Moderator
  • Hi Trevor,

    Further to the Andrew response, here is the link where you can find the details about how to use the tool and download the tool. This definetly will help you find the problem within your group/categories permissions.

    Also, if i were you i would eliminate all the categories except one (My resources) from the Resource Manager group, set the appropriate permission to view all the enterprise resources with that one category and then try. this is how you can atleast isolate the problem, and with all the categories part of your group it would be nightmare, without tool, to find exactly where is the problem.

    Let us know if it help you by any mean or provide us some detail about the issue.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    • Marked as answer by TJSAU Monday, January 24, 2011 7:43 AM
    Monday, January 24, 2011 5:45 AM
  • Thank you Andrew and Khurram

    Was able to use the tool - using it has helped me understand the interplay between categories, groups and ALSO the impact of the RBS.

    I can now see the resources!!

    Thank you

    Monday, January 24, 2011 7:37 AM