locked
Connect-ExchangeServer Proxy results in "creation has been skipped for the following command" RRS feed

  • Question

  • When using the Connect-ExchangeServer cmdlet there is only one server I can connect too, the others are giving the following error:

    I know SERVER-B is also a CAS server located in the same AD site as SERVER-A is. Same IP range, subnet etc. But also conecting to the local mailbox server it is the same.

    Connect-ExchangeServer SERVER-B
    VERBOSE: Connecting to SERVER-B

    WARNING: Proxy creation has been skipped for the following command:

    'Add-ADPermission, Add-AvailabilityAddressSpace, Add-ContentFilterPhrase, Add-DatabaseAvailabilityGroupServer, ETC ETC ... because it would shadow an existing local command.  Use the AllowClobber parameter if you want to shadow existing local commands.

    WARNING: Can't generate Export-Module for the current session using Import-PSSession.

    TIA

    Thursday, March 1, 2012 2:53 PM

Answers

  • It was to simple:

    Connect-ExchangeServer %ServerName% -AllowClobber

    • Marked as answer by CKZ-NLD Wednesday, March 28, 2012 9:17 AM
    Wednesday, March 28, 2012 9:17 AM

All replies

  • Let us know if it helps
    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/aec04691-1560-43a0-b973-8e566e7849f2/

    Gulab Prasad,
    MCITP: Exchange Server 2010 | MCITP: Exchange Server 2007
    MCITP: Lync Server 2010 | MCITP: Windows Server 2008
    My Blog | Z-Hire Employee Provisioning App

    Thursday, March 1, 2012 3:06 PM
  • Hi

    Please Amended the script line in:

    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://ADF-V-EMAIL01.adf.lan/PowerShell/ -Authentication Kerberos -Credential $cred; Import-PSSession -AllowClobber $Session

    Cheers

    Zi Feng


    Zi Feng

    TechNet Community Support

    Monday, March 5, 2012 2:36 AM
  • Hi TIA

    Any update on this thread?

    Cheers


    Zi Feng

    TechNet Community Support

    • Marked as answer by CKZ-NLD Friday, March 9, 2012 9:41 AM
    • Unmarked as answer by CKZ-NLD Friday, March 9, 2012 9:42 AM
    Friday, March 9, 2012 6:27 AM
  • I'll check this out today. Thnx for the response.
    Friday, March 9, 2012 9:42 AM
  • It was to simple:

    Connect-ExchangeServer %ServerName% -AllowClobber

    • Marked as answer by CKZ-NLD Wednesday, March 28, 2012 9:17 AM
    Wednesday, March 28, 2012 9:17 AM