none
Cannot Join Windows 7 HomeGroup - have tried almost everything

    Question

  • I have seen many many threads about homegroup issues, but no one seems to give enough data regarding their initial problem, the threads get hijacked by other users with similar non-descriptive homegroup issues, and I'm seeing the same 'solutions' being given that don't seem to help. Please! I'm going crazy with this.

    My issue:
    When I create a home group on any computer, none of the other computers can see it. Each computer only offers the 'Create a home group' option.

    Details:
    - I'm running 2 Windows 7 Home Premium (64 bit) desktop computers. No laptop involved.
    - Both computers can see each other over the local network.
    - IPv6 is enabled on both.
    - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents = 0
    - Windows Firewall is enabled on both.
    - AVG Free Anti-Virus on both (not AVG Internet Security/Firewall)
    - Network type is set to 'Home' on both.
    - Network discovery is ON on both computers.
    - 128-bit encryption is ON on both computers.
    - Password protected sharing is OFF on both computers.
    - Windows is set to manage the homegroup.
    - Workgroup is same on both computers
    - HAVE run the Home Group troubleshooter on both computers. Once it complained about the clocks not syncronized but they are set to exactly the same time, (17 seconds difference between the 2 computers). No luck there obviously.
    - Router is Linksys WRT610N vers. 2

    Services running on both computers (Set to Automatic):
    - DNS Client
    - Function Discovery Provider Host
    - Function Discovery Resource Publication
    - Peer Networking Grouping
    - HomeGroup Provider
    - HomeGroup Listener
    - SSDP Discovery
    - UPnP Device Host

    There was 1 time when suddenly a HomeGroup was visible to the other computer. After joining and later restarting, the computers could not see each other via the HomeGroup.

    Any help would be greatly appreciated.
    Saturday, February 27, 2010 6:01 AM

Answers

  • Thanks for your help Nano Warp. Completely uninstalling AVG fixed everything.

    ...which I discovered after buying a new router, reinstalling Windows 7 on both computers and going half insane!

    AVG is the anti-HomeGroup and anti-Play-To!!!!!!! As you suggested, I think that the "LinkScanner" feature may be the culprit, but I got rid of the app completely. During our previous testing I had only deactivated "ResidentShield" which didn't do the trick obviously.

    Again, thanks for you help.
    Tuesday, March 9, 2010 12:44 PM

All replies

  • Unfortunately I have no answer.

    My T61 and my HP both running Win 7 x64, will only occasionally connect via network and verry very occasionally connect via Homegroup even with both set exactly the same way.

    I think the simplest answer for me is going to be Apple.

    And this is the new and improved version of Windows we are told.

    There should be a Homegroup for Dummies setting that matches each of 2, 3 or 4 computers if you have admin privileges on each and that resets the 80-11 different settings that need to be tweaked.

    Good luck, but I have invested 12 hours in this today and am reverting to the old tried and true sneaker net settings that worked in the days of DOS and 5.25 floppies.

    Perry
    Sunday, February 28, 2010 2:44 AM
  • Is there no Microsoft expert here who can give me an idea of where to go next? I'm obviously not the only person experiencing these types of HomeGroup issues.

    There is another HomeGroup thread running at the moment that moderators are repling to, but I don't want to hijack that users thread. His problem may not be identical to mine.

    Sunday, February 28, 2010 7:00 AM
  •  

    Hi,

     

    Here are some suggestions you can try:

     

    1. Temporarily turn off firewall and antivirus program on each machine.

     

    2. Assure the Time Zone and Time/Date are the same on each machine.

     

    3. Reset HomeGroup.

     

    a. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. In the popup window, type the following commands and press Enter one by one:

     

    Net stop p2pimsvc

     

    c. Access t he following folder and clear all files inside:

     

    C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking

     

    d. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Net start p2pimsvc

     

    If the issue persists, please run "Ipconfig /all" in Command Console on each machine and post the result here for research.

     

    Thanks,

    Novak

    Monday, March 1, 2010 6:50 AM
  • Thanks for your reply Novak :)

    So I did as you requested on both computers and then created a HomeGroup on one computer, but the other computer still cannot see the HomeGroup and says only 'Ready to create'. I then restarted both machines and same thing. Then with the HomeGroup still created I did the same process all over again and nothing.

    Here are results of each step (which were identical on both computers), with the IP Config results at the bottom:

    net stop p2pimsvc:
    The PNRP Machine Name Publication Service service is stopping.
    The PNRP Machine Name Publication Service service was stopped successfu

    The Peer Networking Grouping service is stopping.
    The Peer Networking Grouping service was stopped successfully.

    The Peer Name Resolution Protocol service is stopping.
    The Peer Name Resolution Protocol service was stopped successfully.

    The Peer Networking Identity Manager service is stopping.
    The Peer Networking Identity Manager service was stopped successfully.

    net start p2pimsvc:
    The Peer Networking Identity Manager service is starting.
    The Peer Networking Identity Manager service was started successfully.

    ipconfig /all (computer with homegroup):
    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Slytherin
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : socal.rr.com

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : socal.rr.com
       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
       Physical Address. . . . . . . . . : 00-04-4B-18-CF-49
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:4881:4707:0:98e8:f46e:c519:998(Prefe
    rred)
       Temporary IPv6 Address. . . . . . : 2002:4881:4707:0:bcca:6836:516a:68c1(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::98e8:f46e:c519:998%12(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Monday, March 01, 2010 8:35:20 PM
       Lease Expires . . . . . . . . . . : Tuesday, March 02, 2010 8:35:20 PM
       Default Gateway . . . . . . . . . : fe80::225:9cff:fec4:d3b8%12
                                           192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : 285213771
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-E2-EE-E1-00-04-4B-18-CF-4A

       DNS Servers . . . . . . . . . . . : 192.168.1.1
                                           209.18.47.61
                                           209.18.47.62
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.socal.rr.com:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : socal.rr.com
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:240b:1975:b77e:b8f8(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::240b:1975:b77e:b8f8%11(Preferred)
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Disabled

    ipconfig /all (computer without homegroup):
    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Gryffindor
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : socal.rr.com

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : socal.rr.com
       Description . . . . . . . . . . . : Generic Marvell Yukon 88E8057 PCI-E Gigab
    it Ethernet Controller #3
       Physical Address. . . . . . . . . : 00-1F-BC-08-80-34
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:4881:4707:0:6908:dec4:1b4f:900b(Pref
    erred)
       Temporary IPv6 Address. . . . . . : 2002:4881:4707:0:bd74:ab6c:29ff:5209(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::6908:dec4:1b4f:900b%12(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.101(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Monday, March 01, 2010 8:36:40 PM
       Lease Expires . . . . . . . . . . : Tuesday, March 02, 2010 8:36:40 PM
       Default Gateway . . . . . . . . . : fe80::225:9cff:fec4:d3b8%12
                                           192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : 285220796
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-E1-DD-52-00-1F-BC-08-80-34

       DNS Servers . . . . . . . . . . . : 192.168.1.1
                                           209.18.47.61
                                           209.18.47.62
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.socal.rr.com:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : socal.rr.com
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2845:3346:b77e:b8f8(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::2845:3346:b77e:b8f8%11(Preferred)
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tuesday, March 2, 2010 4:54 AM
  • Still not working but something just happened:

    I restarted both computers and suddenly the 2nd computer had the option available to join the HomeGroup. I entered the password, but it told me HomeGroup had encountered an error and could not join the HomeGroup. It told me to run the troubleshooter, which I did on the same machine, and it didn't fix anything. Now the computer is back to telling me that there is no HomeGroup on the network, with the usual 'Ready to create' option.

    I should also add that the 'Play to...' feature does not work in Windows Media Player which gives the error of 'Device is not responding'.
    Also in the first computers Windows Media Player the other computer showed up twice in the libraries list.

    Please note the ipconfig information I posted as requested, in the previous post.

    Thanks!

    Tuesday, March 2, 2010 5:04 AM
  • Hi,

     

    Based on my research, I would like to suggest the following:

     

    1.    On both computers, are all the network profiles set to “Home?”

    2.    Please also try the following method:

     

    Why can't I join a homegroup?

     

    Meanwhile, I would like to share the following with you as well:

     

    Windows 7 HomeGroup: Frequently Asked Questions

     

    Hope this helps. Thanks.

    Wednesday, March 3, 2010 2:18 AM
  • After I saw those links I have to admit that I laughed so hard that I choked on my saliva. They are probably the first pages I found online when I was at the basic troubleshooting stage. Again, In my first post I noted that I have done and checked all those basic things.

    Please, I don't mean to come across rude, but the problem I'm having is definitely not as basic as checking which network profile I'm using.

    - I take it that you did not see anything awry in the ipconfig information I posted?

    - Are there any router settings I should be looking out for? In case its relevant, I'm using a Linksys WRT 610N which I know do support IPv6.

    I don't know if this helps, but my Windows Media Player "Play to" does not work either. I can select "Play to..." and then the other computer but I get a "Device is not responding" error. Then if I try to access a media library via "Other libraries" I get "The remote media library did not allow the connection".

    I found some suggestions to turn on "Filter multicast" in the router settings and after setting this I was able to create a HomeGroup and then join it from the other computer. But then when I tried to access the HomeGroup the 2 computers stopped seeing each other again via the HomeGroup. Doh!

    Wednesday, March 3, 2010 5:24 AM
  • After analyzing the Ipconfig result, I did not find any wrong information. At this stage, I suggest you assign a static IP address on each machine for a test.

     

    Before we proceed, I would like to let you know some general router IP addresses.,  In most cases, the router address is “192.168.1.1”, “192.168.0.1” or “192.168.18.1”. If we know the IP address of the router, please  perform the following steps.

     

    1. Click "Start", input "NCPA.CPL" (without quotation marks) and press Enter.

     

    2. Right click on the connection that you use for the local connection, and then click "Properties".

     

    3. Click “Continue” to verify the administrator permission.

     

    4. Click to select "Internet Protocol Version 4 (TCP/IPv4)", and then click "Properties".

     

    5. Select “use the following IP address”.

     

    Manually set “IP address” (For example, if your router IP address is 192.168.1.1, we can type the IP address as 192.168.1.22. If the router IP address is 192.168.0.1, we should type in 192.168.0.22.)

     

    Manually set “Subnet mask” as 255.255.255.0 (Note: We can use this address as the default subnet mask.)

     

    Manually set “Default gateway” (Note: Default gateway is the IP address of the router.)

     

    Manually set “preferred DNS server” (Note: Preferred DNS server is also the address of the router.)

     

    6. Click “OK”.

     

    Then, please create a new HomeGroup and join it on another machine. If the issue persists, I suggest you restart each machine to Safe Mode with Networking and check the result.

     

    Thanks,

    Novak

     

    Thursday, March 4, 2010 6:36 AM
  • I've just made those changes and the HomeGroup cannot be seen on the second computer. I'll give it a couple of minutes.

    In the meantime, I wanted to post a screengrab of my network window. One thing that confuses me is why one media device uses the computer name ('SLYTHERIN') and the other uses the user name ( 'Craig (GRYFFINDOR: Media Player)' ).

    http://www.eveningarwen.com/external/network_window_screenshot.jpg
    http://www.eveningarwen.com/external/network_window_screenshot_2.jpg

    Also, the Media Devices and Computers will randomly disappear at times, but not all at the same time. Maybe this will indicate something.

    Update: After setting the static IP address HomeGroup was still not seen by the second computer.
    Thursday, March 4, 2010 6:54 AM
  • Hi BadMonkey (lol, i like it)
    In the Network and Sharing Center, Advanced Sharing Settings, review the settings:
    Network Discovery ON
    File and Printer Sharing ON
    Public Folder Sharing ON
    File Sharing Connections- Try lower encryption, higher after homegroup works
    Media Streaming ON
    Password Protected Sharing OFF
    HomeGroup Connections-Allow Windows to manage

    Check this on both computers.

    I looked at the AVG users guide and couldn't determine if Resident shield or Link Scanner could be blocking something. You may want to try to temporarily disable the AVG on both computers to determine if it is blocking something Homegroup uses. I doubt it, but it's an easy rule out.


    Thursday, March 4, 2010 2:26 PM
  • Thanks Nano Warp, but as I pointed out in my first post, I've already checked those things, and disabling my firewall and antivirus was a test we did about half way through this thread.

    The basics have definately been checked.

    I'm thinking I might need to test with a different router, but that means going and buying another one after spending $160 on my linksys WRT610n.

    I don't know if it helps, but I do keep creating a HomeGroup on one computer (A) and every now and then the other computer (B) sees it and is able to join it. But computer A never sees the B on the HomeGroup once it is joined and after restarting neither computer can see the other on the HomeGroup.
    Friday, March 5, 2010 7:58 AM
  • OK,
    The longshot. Have you tried a hard reset of the router. The Linksys typically has a button for that function. Disconnect the cable from the modem. Power off any computers or devices connected to the router and reset it to factory settings. Connect it to you modem, then power on your computers and devices.
    If not, then you must perform the reset from Adminstration\Diagnostics in the router with all connected.

    I also noticed that your ip addresses are 192.168.1.100. Have you set the range to begin there? The router should default to 192.168.1.2 for the first device and on.
    (192.168.1.3, 192.168.1.4....)

    So, that's why I am thinking a reset and test on the default settings may help.

    If you are connecting the Linksys to a modem\router device from your ISP, then the IP range of the Linksys should start at 192.168.100.1  (daisy chain routers) Modem only from ISP, then 192.168.1.1 for the Linksys. (default)

    Saturday, March 6, 2010 1:14 PM
  • Yeah, I've done several hard resets on the router. IP settings are also all correct. I have also tried static IPs which gives me the same results as using DHCP.

    I think I'm starting to go mad. Will try the different router option tomorrow. At least that will confirm whether the router is or is not the problem.

    Novak, you given up on me? :)
    Sunday, March 7, 2010 1:56 AM
  • As the router has storage server functionality with the default name of WRT610N, perhaps changing the joined Workgroup name to WRT610N would solve this.
    Do this on each computer in the network. 

    1. click Start button
    2. right-click computer
    3. select properties
    4. Computer name, domain, workgroup settings, select Change Settings
    5. select last button to rename or change...workgroup
    6. change to WRT610N (caps used in manual)
    7. select Ok
    8. close out
    9. a reboot is usually required
    10. reboot
    11. create homegroup on computer 0
    12. join homegroup on computer 1

    Any help?
    Sunday, March 7, 2010 1:21 PM
  • Thanks for your help Nano Warp. Completely uninstalling AVG fixed everything.

    ...which I discovered after buying a new router, reinstalling Windows 7 on both computers and going half insane!

    AVG is the anti-HomeGroup and anti-Play-To!!!!!!! As you suggested, I think that the "LinkScanner" feature may be the culprit, but I got rid of the app completely. During our previous testing I had only deactivated "ResidentShield" which didn't do the trick obviously.

    Again, thanks for you help.
    Tuesday, March 9, 2010 12:44 PM
  • gawwd i m having the same prob n pulling my hair ..i ve a node32 smart security on both comps n one is 32 n 64 bit ...i cant see join only create ..i ve disabled the firewall n everything but it still is the same ..this win 7 sharing sucks big time and this is the biggest drawback of it so far ...i really dunno watta do i did try it on 32-32 bit version as well but it couldnt acess tho it could see each other ...any help since u ve worked it out i hope !!!plz let me know too (:
    Monday, May 3, 2010 7:39 AM
  • I think I have found the solution:

    try changing your computer name -

    Step 1) On your Keyboard Press the "Windows key and pause break" to bring up the "System Menu"

     

    Step 2) When the "System menu" comes up on the bottom right corner click "Change Setting",

     

    Step 3) Click "Change" on "System Properties".

     

    Step 4) Change the "Computer Name" (must be DIFFERENT!! to other Computers)

     

    Step 5) Press "ok"  (you will get a pop up just press ok)

     

    Step 6) On the Systems Properties "Change" the "Computer name" to the same one on (Step 4)

     

    Step 7) Click "Ok" and let the computer restart  (if it doesn't Restart Just log out and log back in)

     

    Follow These Steps and you shouldn't have a problem.

     

    Cheers 

     

    Mani :)

    • Proposed as answer by ManminderB Friday, July 30, 2010 4:16 PM
    Friday, July 30, 2010 4:14 PM
  • I also have a problem with Homegroup after installing the latest Windows Updates (today is Aug 15, 2010).  Since these updates, every time I restart any computer on the network, Homegroup cannot find any of the other computers.  The only way I can get Homegroup to recognize the other computers is to leave the Homegroup and create a new Homegroup.

    Anyone know which of the updates is creating this problem?

    BTW, I HATE Windows 7 (I have both Professional and Home Premium).  It is supposed to be better than XP.  What a joke.  I never had networking problems with XP; nor did I have problems with Explorer locking up.  I have to agree with Perry Kincy.  My next computers will be Apple or Linux.  The only reason I keep using Windows is because of my investment in Windows Apps.  If I keep having problems with Windows 7, I'll go back to XP until I can afford to switch to another operating system.

    The worst thing about Microsoft is that they are so arrogant that they don't have a way to report bugs/problems.  If it were my company, I would have a dedicated team to investigate complaints and resolve them.

    Internet Explorer, since version 7 also have major problems.  Why when saving to favorites, does the tree open fully expanded.  It is not expanded when opening favorites.  Just plain stupid.  I complained about this when IE7 first appeared.  The IE7 team was taking feedback and I actually got a call from an engineer who said a fix would be ready in a couple of days after he contacted me.  Obviously this was a blatant lie.

    • Proposed as answer by ManminderB Monday, August 16, 2010 12:21 PM
    Monday, August 16, 2010 12:31 AM
  • I also have a problem with Homegroup after installing the latest Windows Updates (today is Aug 15, 2010).  Since these updates, every time I restart any computer on the network, Homegroup cannot find any of the other computers.  The only way I can get Homegroup to recognize the other computers is to leave the Homegroup and create a new Homegroup.

    Anyone know which of the updates is creating this problem?

    BTW, I HATE Windows 7 (I have both Professional and Home Premium).  It is supposed to be better than XP.  What a joke.  I never had networking problems with XP; nor did I have problems with Explorer locking up.  I have to agree with Perry Kincy.  My next computers will be Apple or Linux.  The only reason I keep using Windows is because of my investment in Windows Apps.  If I keep having problems with Windows 7, I'll go back to XP until I can afford to switch to another operating system.

    The worst thing about Microsoft is that they are so arrogant that they don't have a way to report bugs/problems.  If it were my company, I would have a dedicated team to investigate complaints and resolve them.

    Internet Explorer, since version 7 also have major problems.  Why when saving to favorites, does the tree open fully expanded.  It is not expanded when opening favorites.  Just plain stupid.  I complained about this when IE7 first appeared.  The IE7 team was taking feedback and I actually got a call from an engineer who said a fix would be ready in a couple of days after he contacted me.  Obviously this was a blatant lie.

    Personal try what ive written above and see if it makes a difference, personally ive done all the updates and not having a problem at all. so try the above settings im sure it will work
    Monday, August 16, 2010 12:22 PM
  • I think I have found the solution:

    try changing your computer name -

    Step 1) On your Keyboard Press the "Windows key and pause break " to bring up the "System  Menu "

     

    Step 2) When the "System menu " comes up on the bottom right corner click "Change Setting ",

     

    Step 3) Click "Change " on "System Properties ".

     

    Step 4) Change the "Computer Name " (must be DIFFERENT!! to other Computers)

     

    Step 5) Press "ok"  (you will get a pop up just press ok )

     

    Step 6) On the Systems Properties "Change" the "Computer name" to the same one on (Step 4)

     

    Step 7) Click "Ok" and let the computer restart  (if it doesn't Restart Just log out and log back in )

     

    Follow These Steps and you shouldn't have a problem.

     

    Cheers 

     

    Mani :)


    This worked!  I just created an account just so I can respond and say thanks. 

    Both my PCs had the same name.  Renaming one did the trick.  Silly, how simple it was, after all the more technical routes we were taking.  Thanks Manminder!

    Friday, October 8, 2010 4:34 AM
  • I also have a problem with Homegroup after installing the latest Windows Updates (today is Aug 15, 2010).  Since these updates, every time I restart any computer on the network, Homegroup cannot find any of the other computers.  The only way I can get Homegroup to recognize the other computers is to leave the Homegroup and create a new Homegroup.

    Anyone know which of the updates is creating this problem?

    BTW, I HATE Windows 7 (I have both Professional and Home Premium).  It is supposed to be better than XP.  What a joke.  I never had networking problems with XP; nor did I have problems with Explorer locking up.  I have to agree with Perry Kincy.  My next computers will be Apple or Linux.  The only reason I keep using Windows is because of my investment in Windows Apps.  If I keep having problems with Windows 7, I'll go back to XP until I can afford to switch to another operating system.

    The worst thing about Microsoft is that they are so arrogant that they don't have a way to report bugs/problems.  If it were my company, I would have a dedicated team to investigate complaints and resolve them.

    Internet Explorer, since version 7 also have major problems.  Why when saving to favorites, does the tree open fully expanded.  It is not expanded when opening favorites.  Just plain stupid.  I complained about this when IE7 first appeared.  The IE7 team was taking feedback and I actually got a call from an engineer who said a fix would be ready in a couple of days after he contacted me.  Obviously this was a blatant lie.

    Personal try what ive written above and see if it makes a difference, personally ive done all the updates and not having a problem at all. so try the above settings im sure it will work
    Try it, I just did and it worked!
    Friday, October 8, 2010 4:35 AM
  • I think I have found the solution:

    try changing your computer name -

    Step 1) On your Keyboard Press the "Windows key and pause break " to bring up the "System  Menu "

     

    Step 2) When the "System menu " comes up on the bottom right corner click "Change Setting ",

     

    Step 3) Click "Change " on "System Properties ".

     

    Step 4) Change the "Computer Name " (must be DIFFERENT!! to other Computers)

     

    Step 5) Press "ok"  (you will get a pop up just press ok )

     

    Step 6) On the Systems Properties "Change" the "Computer name" to the same one on (Step 4)

     

    Step 7) Click "Ok" and let the computer restart  (if it doesn't Restart Just log out and log back in )

     

    Follow These Steps and you shouldn't have a problem.

     

    Cheers 

     

    Mani :)


    Although I was confused by number 6 as you have just done that on number 4 and cannot change it again until the computer is restarted, I followed these instructions disregarding numbers 6 and 7 and it finally worked. I have spent hours and hours and hours over this. Whoever at Microsoft thought that Homegroup was an easy way to connect computers must have been out of his/her mind at the time. Judging by my experience and the sheer numbers of people on the search engines who cannot get this to work you can safely say that this is far far harder than most people can possibly achieve to work. As from tonight I am the only one of numerous friends who have finally got it to work thanks to ManminderB. I do have to say that I am disappointed by the entry comment by Novak Wu who quite clearly never bothered reading the thread at all and I thought their comments were a little bit insulting to BadMonkey_NoBanana and he/she is clearly way about the level of those suggested links which, to be honest, are a waste of space as they help no one. Thanks ManMinderB.
    • Proposed as answer by HomeyV Sunday, December 12, 2010 8:18 PM
    Sunday, October 24, 2010 12:25 AM
  • Read this forum through -and performed the suggestions TWICE. The first time I kicked off Homegroup it worked fine, like someone else stated, after I rebooted-the Win7 x32 Laptop recognized the Win 7 x64 Desktop, but the DT did not recognize the LT. On my third attempt; looking at my D-link router, I realized my router's time was off. I had made some config changes recently and had to reset it but never synched the time with my PC. After making sure all three items were in time sync, I removed both PCs from the Homegroup, rebooted them and started a new Homegroup. So far it is working like a champ. If that changes I will repost.
    Sunday, December 12, 2010 8:26 PM
  • I have just been through volumes of forums discussing the problem of computers not seeing one another on the network.  I have a decent computer background and work at a college that does computer training.  My two computers ... a desktop (using Windows 7 Pro) and my laptop (using Windows 7 Home Premium) initially setup Network Sharing using home group initially very easily and worked flawlessly.  Suddenly without cause or explanation, one could not see the other.  I have never been more frustrated than trying to get both of them to see one another again.  I have gone through every F&Q, forum, and everything else one could imagine and shared the frustrations many other had found also ... nothing seemed to work.  All settings were as recommended, all clocks were in sync, the router was reset, I left homegroup on both computers and set back up a homegroup and got a new password on the Windows 7 Pro, and I then tried to join on the laptop (which initially would not let me join), all planets the solar system were were aligned, the proper chants and sacrifices were made and nothing seemed to work.  Argg!

    This is what I did discover and there is one item in another forum string that did work:

    After I created the new homegroup on my desktop, got the new password and checked everything I wanted to share,  I found the laptop still could not see the homegroup to join.  I did discover, however, that if I went back to the desktop, went to my libraries, right clicked one of my libraries, in the menu selected "Share With" and selected "share with Homegroup" suddenly the laptop could find a homegroup to join.  I followed the "join homegroup" process (on the laptop)and put in the newly created password I created from the desktop.  The laptop now saw my desktop.  It was a sort of "Eureka!" moment.  I then found the desktop still could not see the laptop even if went to the laptop libraries to do the same right click sharing and selected a "share with homegroup" option .  I thought then that perhaps a reboot of both computers might resolve the problem.  I did that very thing and upon reboot, I was back to square one.  Neither computer could see the other.  

    Now, the moral of this story ... I tried one thing mentioned in another forum that instantly allowed both computers to see each other.  My desktop is directly connected to my router.  The laptop feeds to it wirelessly.  I connected my laptop directly (hardwired) to my router and poof, both could see each other and the "homegroup" was a happy family again.  

    I am wondering how many people that have the problem of their computers not seeing one another have a desktop directly connected to their router and a laptop that connects wirelessly.  It could well be that there is a bug in the wireless connection process or a setting that has changed (something not covered in all of these forums) that is causing the problem.  Connecting both computers directly to the router seems to work, however.

    Any thoughts?

    Sunday, December 12, 2010 10:45 PM
  • 10 days later-still working....

     

    Wednesday, December 22, 2010 9:27 PM
  • Have discovered everything you have just discribed wierd and anoying.
    Thursday, December 23, 2010 3:12 PM
  • This is not a good answer.  Homegroup does not support ipv4 and requires ipv6 so I fail to see how setting a static ipv4 address would resolve the issue.
    Tuesday, January 25, 2011 6:04 AM
  • After messing with everything, I noticed that my router had the wrong time.  I am using DD-WRT and all I had to do was change the timezone to the correct one for me and restarted both computers.  I was able to see the Join button right away!
    Tuesday, January 25, 2011 8:52 PM
  • Hi, Yes going to Apple is a viable solution. Operating system (that works) $26.00. Simple program to install windows XP, Vista, or 7 on it as well. Apple hardware is more expensive but it actually delivers. One should also note that the operating systems and suites seem to be downgrading...in prep for new version?

    Anyway nothing is perfect, and I have shown patience for quite some time (years), and since I got an iPhone and iPad, it changed everything...and no I have no affiliation with Apple, just I am also choosing to not play the MS game any longer.

    Tuesday, April 5, 2011 9:01 PM
  • I'm using Win7 H/P and I have the same problem stated above. However when trying to go to C:\ServiceProfiles\Localservice\ there is no Roaming etc. Local Service brings up some folders.

    All I get is This computer can't connect to a homegroup. And I can't create one either.

     

    Can I create a group on my other computer which is running XP?

    Tuesday, May 3, 2011 9:25 PM
  • I am having a similar problem to Brad's except for the fact that I'm using Win7Pro64 on both my desktop and my wirelessly attached HP4510s laptop. I can see and access shared folders on the laptop from my desktop with no problem. The laptop can access the router configuration browser page and my Ready NAS Duo, but not my desktop shared folders, instead I get "\\Centurion is not accessible. You might not have permission to use this network resource. Contact to administrator...... THE SPECIFIED NETWORK PROVIDER NAME IS INVALID" UPDATE: All my problems were solved by reinstalling the "Client for Microsoft Networks" on the laptop!!!! I must have somehow disabled it.
    Sunday, June 5, 2011 1:12 PM
  • After trying above said methods N Googling out also ... It dint work..... Problem is with the Antivirus (In my case was using the Nod32 which used to block connectivity for Homegroup) On uninstalling the antivirus it gave a option to join the network before I could restart after uninstalling !! Not an issue with the Windows7 home group. =)
    After Uninstalling...3rd PARTY ANTIVIRUS it worked... !! Home group was available to JOIN =) within no seconds.
    Give a try ... Sure it will work
    ~uj
    Sunday, December 11, 2011 4:54 PM
  • I am a newby to all this, but I uninstalled network magic and all my homegroup problems went away!
    • Proposed as answer by lextex Monday, February 6, 2012 12:11 PM
    • Unproposed as answer by lextex Monday, February 6, 2012 12:11 PM
    Saturday, February 4, 2012 12:34 AM
  • Look man, I cannot tell you how helpful this was going over so many supposed answers to the problem and yours was the only one that worked.  I just wish i knew why it did.

    Sunday, February 12, 2012 10:43 AM
  • I know this thread is old, but after going through it briefly as I had the same troubles with not being able to access the HomeGroup that I had created on my Windows Home Server 2011, I discovered that my Windows 7 x64 Ultimate Ed. had two clocks (one for a different timezone). The minute I removed that clock I was able to see the Homegroup on the server.

    It's a ridiculous solution and some poor coding/design put in place by Microsoft, but at least I got it working.

    Thanks for the informative thread.

    Friday, March 2, 2012 8:49 PM
  • I have exactly same issue and solution to this most probably something to do with your router settings.

    I am using Huawei MT841 Type-4 wifi adsl router.

    The issue occurs for me if I take my device (desktop / laptop ) to Ethernet wired connection. I am not even able to see shared location via traditional share method on other devices. in short devices connected to router via Ethernet goes blind however respective device can access internet.

    Although respective device is able to access internet without any issue, it is unable to see any other device connected to same router either wired/wireless.

    When I connect respective device to router via wifi it is able to homegroup other devices connected via wifi and it is able to see shared location via traditional share method on other devices.

    So my conclusion is this is something to do with router settings.

    Can someone tell what must be changed in router to make Ethernet connected devices can talk each other ?

    Wednesday, July 4, 2012 3:42 PM
  • Good work fella! After registry change to enable IPv6 on both, restarting all the required services on both , disabling firewalls & AV on both and a lot of head scratching it is a simple as having duplicate hostname on both the desktop & laptop! Doh!! Could explain the wireless dropouts too and why when i looked at my router client list I had two machines with the same name but different ip's, should have probably twigged at that point! Always start at the obvious.

    Thanks again

    Adrian

    Saturday, July 28, 2012 4:56 PM
  • The way I fixed this was actually just resetting my router! I couldn't believe how frustrating it was but in the end that's all it took...
    Monday, October 29, 2012 8:48 PM
  • In case this helps anyone else this is what it took to solve this problem for me:

    The symptoms I had was that my home group would show on the pc I wanted to join from but on clicking 'join' windows 8 would think for 2 min then say 'that home group is no longer available'. I'd click ok and then it would ask me if I wanted to join the same group again! Round and round. All machines windows 8, router was Cisco SRP527W.

    First, the timezone was different on each pc and the router. I fixed these. No change.

    I looked at the Mr Fixit, but it didn't run on win 8.

    I checked ipv6 was enabled. It was.

    I tried static ip's - no change.

    I ran a cable instead of wifi - no change.

    I tried static ip's and cables all round... ah hah! Success. Switched back to wifi and dhcp and still good. But I was worried a security recheck in future on reboot or something might break it again... and it did. I still had fileshare but the printer share was now 'not authenticated'.

    I updated the firmware on the SRP527w from 1.1.22 to 1.1.27 (numbers are from memory - I think they are correct). Same problem. I took the PC with the printer share off the homegroup and reconnected straight away this time - wifi and dhcp and all. Printer sharing and filesharing worked right out of the box.

    So in the end, my problem was a firmware update for the router... but there was a lot of pain getting there. Even the firmware upgrade was bad as I lost internet and had to hard reset and reprogram it twice. Now though, home group sharing is a dream! I highly recommend it and hope my experience helps someone.

    Friday, December 28, 2012 3:44 AM
  • In case this helps anyone: Just run the troubleshooter on the computer where the homegroup is already working.  Also, bring up another computer where the homegroup was working before.  Now join the homegroup on the new computer.  It seems to work for me.

    Cheers. -Amitabh

    Wednesday, January 9, 2013 10:36 PM
  • I've try many solutions to this problem also. None success. But today I try deleting the old Home Group and create a new one. Everything goes fine and now Home Group is working. Hope this help.
    Wednesday, May 15, 2013 1:52 AM
  • this problem occur when you have same computers name and description in your LAN  . computers can't connect each other in homegroup when have same computer name.

    the solution is to set different name in computers:

    window 7->

    right click computer --> properties --> Advanced system settings --> Computer Name Tab --> 

    * change your computer description 

    * press change to open compuer Name/Domain Changes --> change Computer name --> hit OK

    * press OK

    * require restart -- > Done

    if you have more than two computers you should set unique name for each one

    Thursday, July 18, 2013 3:44 PM
  • Geez after spending hours and hours on this windows 8.1/windows 7 homegroup nightmare (because I'm so doggone stubborn and refuse to be beaten) I came across this post and voila. If you ever get round to viewing your post again ManminderB thanks. Works for me.

    Jazzzzy

    Monday, November 4, 2013 2:05 PM
  • disabled avg completely. this worked for me. now just need to figure out which piece of avg is the problem
    Wednesday, November 27, 2013 1:44 AM
  • I had this problem my self, Comes to find out that you cannot have both pcs as the  Same Name. I changed the first computers name, restarted it and boom worked! problem solved! hopes this helps!
    Thursday, June 19, 2014 9:44 PM
  • Allrighty than. I havent read trough all the replies here, so I hope I dont repeat some1's words. I have been going trough numerous forums and reading alot of nothing. So, I have taken the lead myself. I see that many have similar network configuration, Desktop, wrouter and laptop or other desktop. This is also my case. Windows 7 desktop, windows 7 laptop, and some random Belkin wireless router.

    Solving this homegroup problem is simple. There is no need to turn of your PC firewalls, to disable your ipv6 protocols, to rename your PC's unless they are really same named, to bang your head into the keyboard after 100th time seeing your other PC wont join homegroup after 100th restart and recreation of group. Maybe, I am not sure if its needed, you do need to sync your router system time to that of PCs or laps on network, tho I doubt that also.

    The problem the whole time was in- router firewall. If you want, you can turn it off for whole network. If you want, you can protect all computers with built in router firewall but the one that is having trouble recognizing the network infrastructure, with this option called DMZ. The DMZ feature allows you to specify one computer on your network to be placed outside of the NAT firewall.

    This came to me as a solution while looking trough network maps of each computer on my network. Only the desktop that is lan connected to router wasnt able to recognize Belkin. The only thing that helped was putting down firewall or using DMZ feature.

    Hope this will be useful info for any other wireless router product.

    Wednesday, June 17, 2015 11:59 PM
  • I've fought this problem for 4 days.  I followed your instructions and got my old computer to display the password.  Thank you for that.  But the new computer cannot join the network.  I clicked join, then input the password and it says "windows cannot set up a homegroup on this computer".  I ran ipconfig and here are the results:

    For Release and Renew, if no adapter name is specified, then the IP address

    leases for all adapters bound to TCP/IP will be released or renewed.

    For Setclassid and Setclassid6, if no ClassId is specified, then the ClassId is

    removed.

    Examples:

        > ipconfig                       ... Show information

        > ipconfig /all                  ... Show detailed information

        > ipconfig /renew                ... renew all adapters

        > ipconfig /renew EL*            ... renew any connection that has its

                                             name starting with EL

        > ipconfig /release *Con*        ... release all matching connections,

                                             eg. "Local Area Connection 1" or

                                                 "Local Area Connection 2"

        > ipconfig /allcompartments      ... Show information about all

                                             compartments

        > ipconfig /allcompartments /all ... Show detailed information about all

                                             compartments

    C:\Users\Jim>

    WHAT NOW???


    • Edited by carnyman Thursday, July 28, 2016 7:03 PM
    Thursday, July 28, 2016 7:01 PM
  • As for me, you nailed it right there.  "Step 4.  CHANGE THE COMPUTER NAME".  I build (or take apart, put back together and try to make better) computers, laptops, almost anything technical.  I set up one laptop, Windows 7 Home Premium, no special programs, using only Microsoft Security Essentials with nothing else virus related installed.  I could create a home group just fine on it.  I then put together a custom built desktop with nothing special, much the same as mentioned for the laptop.  Not thinking at the time, I set up both computers with the same name.  I could create a home group on the desktop (B), just as I could on the laptop (A).  A would not see B, B would not see A.  I ran troubleshooter on both, to no avail.  I checked network settings, internet connections, file sharing, protocols and even tried all of the steps listed above here until I got to Mani in the above reply.  Changed the name of just one of the computers, (computer B in this instance) and suddenly, without even rebooting, B appeared on A and asked for the initial password.  I can access A on B, B on A, share files, etc., and everything working just perfect.  Mani you're a BIG help to me.  Thank you.  Got my vote.  Just glad I wasn't out spending any money trying to fix something that simple and easily overlooked!
    • Edited by Jonathan0895 Saturday, October 22, 2016 3:51 AM wrong name
    Saturday, October 22, 2016 3:47 AM