locked
Workstations updating not reporting status RRS feed

  • Question

  • Hi,

    I have WSUS problem - some of the worksations are not reporting status. Updates are downloaded and installed but status is not reported, and in reports those stations are visible as "No status". About 50 from 1500 is affected, some is not reporting from more than a half year. I have changed "Private memory limit" to 0, deleted all superseded updates. On workstations deleted Softwaredistribution folder, registered dlls again, used those commands:

    REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f
    REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f
    Reg Delete "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f
    Reg Delete "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientValidation /f
    REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v LastWaitTimeout /f
    REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v DetectionstartTime /f
    Reg Delete "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v NextDetectionTime /f

    wuauclt.exe /resetauthorization
    wuauclt.exe /detectnow
    wuauclt.exe /reportnow

    It resolved problem in couple of stations but most of them are still not reporting, and right now I'm without ideas what could cause this. WSUS is on Windows Server 2012R2 version: 6.3.9600.18838

    Stations are mostly Windows 10 with some Widnows 7.


    • Edited by LucasDeltaB Friday, October 18, 2019 8:40 AM
    Friday, October 18, 2019 8:39 AM

All replies

  • Hi Lucas,
       

    In the WSUS console, we can check the client's last status report time and last connection time. Please first consider the above two times of this part of the client, whether it exists and is the most recent.
       

       

    Second, since the problem only occurs on some clients, I think the problem is very likely to appear on the client.
    Refer to the steps in this article: "Tips for troubleshooting WSUS Agents that are not reporting to the WSUS server".
        

    Reply back with the results would be happy to help.
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 18, 2019 9:26 AM
  • Last Contact date and Last Status report date are different. In some cases the difference is more than half year.

    I checked the article and:

    1. GPO is applied to the station and in registry wsus server is configured correctly

    2. Services are running, updates are downloaded and installed

    3. Server is reachable, no proxy on client

    4. No SCOM so this do not apply

    5. SoftwareDistribution folder was deleted couple of timea

    6. SusClientID registry was deleted and new one has generated

    None of this things helps.

    Friday, October 18, 2019 11:04 AM
  • Hi Lucas,
       

    Please consider removing these unreported computers from the WSUS console's computer and then waiting for these customer orders to rejoin.
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 21, 2019 3:15 AM
  • Hi,
     

    Any update is welcome here.
    If the issue is resolved, share your solution or find the helpful response "Mark as Answer" to help other community members find the answer.
     

    Thank you for your cooperation, as always.
     

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 25, 2019 8:26 AM
  • Please look at https://www.ajtek.ca/wsus/client-machines-not-reporting-to-wsus-properly/

    Run  through the page and it will help you troubleshoot the issues.


    Adam Marshall, MCSE: Security
    https://www.ajtek.ca
    Microsoft MVP - Windows and Devices for IT

    Tuesday, October 29, 2019 3:23 AM