locked
Memory leak causes system to run out of system resourses RRS feed

  • Question

  • Hi everyone. I am having a BIG problem with a new Dell Latitude 4310 with Windos 7 Pro. There seems to be a memory leak on the system that I am having a hard time figuring out where it’s coming from. When the system is turned on the system resources show it using 1.26 GB of memory. But as the day goes on, it chews up memory slowly. After about 4 hours it gives the error “out of memory” when trying to open a program. The steps I took to determine what is causing this are as follows:

    Looked into what processes running that were taking up the most amount of memory. Other then svchost running at about 100mb, there did not seem to be any other program eating up resources. Did a hardware diagnosis to see if it was hardware related. Everything checked out. Thought it might have been related to the e-port and being logged into the domain so I undocked and did not log into the domain. Turned off the wireless card but logged into the domain connected to the e-port.  There are a lot of errors in the application log and some of the errors are pointing the DCOM+ errors. I also did a virus scan and tried install a different antivirus program as well.

    One strange part of the puzzle is when it logs of to shut down, it takes about 2-3 minutes to log off and then shut down. Under eventsystem I get an error “The COM+ Event System timed out attempting to fire the StartShell method on event class {D5978630-5B9F-11D1-8DD2-00AA004ABD5E} for publisher  and subscriber .  The subscriber failed to respond within 180 seconds. The display name of the subscription is "wltrynt SENS Logon Spy Subscription". The HRESULT was 800705b4.”

    But I’m sure that there is no virus. If anyone has any idea what the problem is, please let me know or should I just reinstall Windows?

    Thanks for your help and if you need more information please let me know

    Sunday, January 30, 2011 7:46 PM

Answers

All replies

  • Please download RAMMap [1][2] and run it when you have the high Memory usage. Now save the data as a RMP file. Zip the RMP file and upload the zip to your SkyDrive [3] and post a link here. Also try to increase the size of the pagefile, so that modified data can be written to the pagefile!

    André

    [1] http://technet.microsoft.com/en-us/sysinternals/ff700229.aspx
    [2] http://blogs.technet.com/b/askperf/archive/2010/08/13/introduction-to-the-new-sysinternals-tool-rammap.aspx
    [3] http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Marked as answer by Leo Huang Monday, February 7, 2011 7:07 AM
    Monday, January 31, 2011 1:16 PM
  • Wednesday, February 9, 2011 3:43 PM
  • Sorry I was unable to give the exact way of posting the picks as it did not allow me to log back is as my user. I hope this will help though.

    Wednesday, February 9, 2011 3:45 PM
  • the pictures don't match. RAMMap shows 196MB modified and Res Monitor shows 2GB.

    Run RAMMap when you have the high modified usage and save the data as a RMP file, zip it and upload the zip.


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Wednesday, February 9, 2011 3:59 PM
  • I know. I tried to run RAMMap but it would not open. gave the error Out of system memory. That's why I got the screen cap from task manager. I'll try again when it's high and post once I have it.

    Thanks

    Robsky1

    Wednesday, February 9, 2011 5:11 PM
  • What is your pagefile size?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Wednesday, February 9, 2011 10:42 PM
  • Anything more on this? I'm having the exact same issue with some of my recently imaged Win7 Pro machines on the domain (Dell e6510). I am having to completely wipe and reimage to fix this but occasionally a newly imaged machine will do this after I add it to the domain and update drivers. Not sure what is causing it. Could be the order in which I'm loading the Dell drivers but I'm not sure. Hard to reproduce manually and hard to track down the source of the issue once it happens.
    Thursday, August 4, 2011 3:47 PM
  • Ok, I fixed my issue, which sounds exactly like yours. Uninstall the Dell Wireless Utility, you should notice an immediate change in logging off and I've seen no more low memory issues as of yet. I've resorted to installing ONLY the driver for the wifi, not the whole utility from Dell, as it has been causing the issue's described above with my machines.
    Monday, August 8, 2011 2:14 PM