locked
Outlook (Exchange on-premise) asks for password when in internet RRS feed

  • Question

  • Since a while my Outlook always asks for Username/Password as soon I am outside my LAN when I connect to our on-premise Exchange 2016 from the internet. This was not like that bevor. It accepts my credentials, so it is not a repeating popup, but it's strange behaviour anyhow. Either it is since a new update, I am yet running brand new 1803 (Build 9126.2072 click to run). Or it is because we recently have synced our AD accounts to Azure AD, without password synchronisation. But I have no Exchange Mailbox with Office365, we have not enabled this in our E3 plan.

    Any hints where I can look to?

    kind regards,
    Dieter Tontsch

    • Moved by Perry-Pan Thursday, March 22, 2018 7:10 AM
    Wednesday, March 21, 2018 5:20 PM

Answers

  • Hi Dieter Tontsch,

    Does this issue only happen to your account?

    Have you tried logging your account on another client to see the result? This helps determine whether the issue lies on Outlook client or the server settings.

    We could delete old cached credentials in Windows to check the result. To do this, please go to Control Pane > Credential Manager. Under Windows Credential,  locate the set of credentials that has Outlook in the name and then remove the password. Restart Outlook to check the result.

    In case there is something wrong with the profile, please create a new profile and then check if same issue occurs.

    What's more, according to my research, we could also check the registry setting via the following steps.

    (Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    Please refer to this article about how to back up and restore the registry in Windows)

    1.        Click Start, click Run, type regedit, and then click OK.
    2.        Locate HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security
    3.        Point to New, and then click DWORD Value.
    4.        Type PromptForCredentials as the name of the new registry entry, and then press ENTER.
    5.        Double-click the PromptForCredentials registry entry, and then type one of the following values in the Value data dialog box: 00000000
    6.        Click OK.

    If there are any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, March 22, 2018 7:10 AM
  • I found the exact reason why on my PC I always got asked for credentials by Outlook only when I was connecting from internet. For our External URL I have had stored credentials for a different user. This resulted from the fact that I have used the same url in Internet Explorer in order to access OWA with a different user, and have had chosen to save credentials. It showed up in Credentials Manager under Web Credentials. Once I have deleted these, I did not get asked for credentials with Outlook anymore. The registry key PromptForCredentials you pointed to did not help to me, but the your post pointed me to the right direction.

    kind regards

    Dieter

    Friday, March 23, 2018 4:34 PM

All replies

  • Hi Dieter Tontsch,

    Does this issue only happen to your account?

    Have you tried logging your account on another client to see the result? This helps determine whether the issue lies on Outlook client or the server settings.

    We could delete old cached credentials in Windows to check the result. To do this, please go to Control Pane > Credential Manager. Under Windows Credential,  locate the set of credentials that has Outlook in the name and then remove the password. Restart Outlook to check the result.

    In case there is something wrong with the profile, please create a new profile and then check if same issue occurs.

    What's more, according to my research, we could also check the registry setting via the following steps.

    (Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    Please refer to this article about how to back up and restore the registry in Windows)

    1.        Click Start, click Run, type regedit, and then click OK.
    2.        Locate HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security
    3.        Point to New, and then click DWORD Value.
    4.        Type PromptForCredentials as the name of the new registry entry, and then press ENTER.
    5.        Double-click the PromptForCredentials registry entry, and then type one of the following values in the Value data dialog box: 00000000
    6.        Click OK.

    If there are any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, March 22, 2018 7:10 AM
  • I found the exact reason why on my PC I always got asked for credentials by Outlook only when I was connecting from internet. For our External URL I have had stored credentials for a different user. This resulted from the fact that I have used the same url in Internet Explorer in order to access OWA with a different user, and have had chosen to save credentials. It showed up in Credentials Manager under Web Credentials. Once I have deleted these, I did not get asked for credentials with Outlook anymore. The registry key PromptForCredentials you pointed to did not help to me, but the your post pointed me to the right direction.

    kind regards

    Dieter

    Friday, March 23, 2018 4:34 PM