none
XMLHttpRequests in IE 10/11/Edge takes up to 20s to complete whilst they are sub 1s in Chrome/Firefox

    Question

  • We're running a large web application using angularjs, consuming a .NET Web API by making xhr calls.
    This works really well with Chrome/Firefox. 
    <o:p></o:p>

    The application is hosted on a machine with Win2k8R2 and IIS7.5, we've been able to reproduce the same error using different authentication methods, different client operating systems (Win7,10 and browsers (IE10,11,Edge).<o:p></o:p>

    Unfortunatley I'm not able to include the routes but I've marked the requests in the chrome network (bottom picture) taking more than 9s in the first picture (IE10).<o:p></o:p>

    Is there a solution out there?

    Friday, January 15, 2016 9:05 AM

Answers

  • Hi,

    According to your description, I understand that Internet Explorer cost much time than Chrome\Firefox when load a web application.

    How about disable all add-ons in IE? Add-ons can sometimes cause browsers to run slowly and crash, or they might pose a security or compatibility risk. Also, try clean boot to testing. 

    Since this issue is more related to Internet Explorer developer, I recommend contact Internet Explorer Development Team so that you can get more professional suggestion. For your convenience:

    https://social.msdn.microsoft.com/Forums/ie/en-US/home?category=iedevelopment


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Monday, January 18, 2016 6:37 AM

All replies

  • Unfortunately I could not post the pics here, or links. Please copy paste the links below:

    i.imgur.com/4UrQplt.png

    i.imgur.com/PBX9TON.png


    Friday, January 15, 2016 9:08 AM
  • Hi,

    According to your description, I understand that Internet Explorer cost much time than Chrome\Firefox when load a web application.

    How about disable all add-ons in IE? Add-ons can sometimes cause browsers to run slowly and crash, or they might pose a security or compatibility risk. Also, try clean boot to testing. 

    Since this issue is more related to Internet Explorer developer, I recommend contact Internet Explorer Development Team so that you can get more professional suggestion. For your convenience:

    https://social.msdn.microsoft.com/Forums/ie/en-US/home?category=iedevelopment


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Monday, January 18, 2016 6:37 AM