locked
Skype for business 2016 client cannot change IM font --- issue or bug? RRS feed

  • Question

  • Hello everyone,

    I want to know if anyone encounters the same issue as mine.

    1.In the Skype for business 2016 client, option->IM, I change the Font to Segoe UI (11):

    2. Open a chat and confirm the Font is changed.

    3.Insert hello and select this word , then right click to select change Font, you can see the Font is Calibri (11) but not the one I changed

    4.These 2 fonts are completely different, but the Segoe UI(11) which is setup in IM options cannot take effect at all!

    5. Every time before I want to send the IM using Segoe UI(11), I must to select all the content and right click to change font, then Segoe UI(11) can be applied.


    Can anyone help me on this issue? Is this a BUG for Skype for business 2016 ? My SFB client is with the latest patch.

    Thanks a lot!

    B.R.




    • Edited by Moore Zhang Monday, November 26, 2018 2:55 PM edit cmt
    Monday, November 26, 2018 2:28 PM

Answers

  • Hey there,

    Are you using another input method like Chinese? I had this same issue with my business Skype, but realized it was due to my using Japanese windows keyboard to input roman characters. I switched back to the plain English input and it went back to normal. You can change using "ALT+SHIFT" if so.


    Tuesday, January 29, 2019 6:45 PM
  • Hi Sharah,

    Yes I'm using the Chinese.
    I use "ALT+SHIFT" and reopen the chat window, the Font is OK to become Segoe UI (11) and the default method is English, but after I switch to Chinese and insert something, then switch back to English, the Font become Calibri (11) again...

    I would rather think this is a BUG for input method switch.

    Thanks for your reply.

    • Marked as answer by Moore Zhang Monday, May 20, 2019 3:05 AM
    Monday, May 20, 2019 3:05 AM

All replies

  • Hi.

    Set IM options in Skype for Business

    Change Font    Click to change the default font size, style, and color of the instant messages you send. To apply those font preferences to the instant messages you receive, select the Apply settings to incoming messagescheck box.


    MCITP, MCSE. Regards, Oleg

    Monday, November 26, 2018 6:15 PM
  • Hi Oleg.Kovalenko,

    Thanks for your reply.

    I've changed the Font in Step 1. , but the Font is not applied to the IM I send.

    Tuesday, November 27, 2018 12:22 AM
  • Hi,

    In my testing environment, it seems there is no problem to change default IM font in Options.

    Does it impact all the users in your organization? Have you tried with other version or device?

    If it only appears to you, please try to delete the Lync cache files and test again.

    1.Sign out Skype for Business -> delete sign-in information-> exit SFB

    2.Delete sip folder under: %UserProfile%\AppData\Local\Microsoft\Office\15.0\Lync.

    3.Restart computer to test again

    Moreover, you could also try to perform a clean boot on your computer to test if it could be fixed.


    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Calvin-Liu Friday, December 21, 2018 10:01 AM
    Tuesday, November 27, 2018 7:13 AM
  • Hi Calvin,

    Not all users want to use this font, but as my tests, all the SFB clients have the same issue.


    I do lots of tests in different scenarios (including various different versions of Skype
    clients and different computers ) ,
    ach time the Segoe UI(11) is configured in Options-> IM, while sending the message to other colleagues, the font would automatically become the Calibri(11).

    This should be a BUG of the SFB client.

    Tuesday, November 27, 2018 11:29 AM
  • Hi,

    I don’t have this issue, could you please check the following registry info:
    Path: “HKCU\Software\Microsoft\Office\16.0\Lync\xxx@xxx”
    “FontFace” and  “FontSize” value.

    It should be same as your configuration.


    Friday, November 30, 2018 10:08 AM
  • Hi,

    Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue. :) 

    Kind regards, 

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Teams.


    Friday, December 21, 2018 10:01 AM
  • Hey there,

    Are you using another input method like Chinese? I had this same issue with my business Skype, but realized it was due to my using Japanese windows keyboard to input roman characters. I switched back to the plain English input and it went back to normal. You can change using "ALT+SHIFT" if so.


    Tuesday, January 29, 2019 6:45 PM
  • Hey there,

    Are you using another input method like Chinese? I had this same issue with my business Skype, but realized it was due to my using Japanese windows keyboard to input roman characters. I switched back to the plain English input and it went back to normal. You can change using "ALT+SHIFT" if so.


    This is workable for none English version of SFB.
    • Proposed as answer by Ricky_Yin Thursday, April 25, 2019 1:54 AM
    Thursday, April 25, 2019 1:54 AM
  • Hi Sharah,

    Yes I'm using the Chinese.
    I use "ALT+SHIFT" and reopen the chat window, the Font is OK to become Segoe UI (11) and the default method is English, but after I switch to Chinese and insert something, then switch back to English, the Font become Calibri (11) again...

    I would rather think this is a BUG for input method switch.

    Thanks for your reply.

    • Marked as answer by Moore Zhang Monday, May 20, 2019 3:05 AM
    Monday, May 20, 2019 3:05 AM
  • Hello,

    I have the same problem that my font keeps changing to Calibri 10 even though I set it to be Segoe UI 10.
    Registry Path: “HKCU\Software\Microsoft\Office\16.0\Lync\xxx@xxx”
    “FontFace” and  “FontSize” value do show Segoe UI 10.

    My SfB version is 16.0.11328.20392.

    The main language of my client is US-English. My keyboard is German but I want my Windows to be English so I set the default language to be English (Germany). The second keyboard layout (accessible by using ALT-SHIFT) is English (United States).

    If I start a new conversation while the keyboard layout is set to German the font will be Calibri 10.
    If I start a new conversation while the keyboard layout is set to English the font will be Segoe UI 10.
    If I use ALT-SHIFT to shift to German layout while inside that conversation from then on the font will be Calibri 10. Even after shifting back to English layout the font will stay at Calibri 10.

    The same font change also happens if changing layouts by clicking on the task bar instead of using ALT-SHIFT.

    How can this issue be resolved?

    Thanks and kind regards,
    Steffen
    • Edited by Steffen-S Thursday, August 15, 2019 5:04 PM
    Thursday, August 15, 2019 5:02 PM