locked
SOMEONE PLEASE HELP!!! RRS feed

  • Question

  •  

    Heres the situation:

     

    just reinstalled:

    -win2003 std srv

    -active directory

    -IIS w/ASP.NET

    -SQL 2000 Sp3 & sp4*

     

    Tried reinstalling Sharepoint Portal Server 2003 and when it finishes and tries to go to the FarmSettings page it keeps coming up with "Unexpected end of file looking for </SPSWC:InputFormButtonSection> tag" tried reinstalling everything multiple time with and without SQL and with and without SP's but to no resolve. and if you go to any other page it just says something about missing a root element. I have never had this problem before reinstalling portal server! if there is anyone who may be able to shed the littlest amount of light that would be great. anything is better than nothing! Need to get this server back up and running.

     

    Thanks Dave.

    Tuesday, January 15, 2008 3:15 PM

Answers

  • It may be that your install media is messed up.

     

    Wednesday, January 16, 2008 1:55 AM

All replies

  • Try reinstalling, but before you do, remove all the content in the C:\Program Files\Common Files\Microsoft Shared\web server extensions\60 directory.  If you have custom templates and files in there, make sure they're backed up first, then restore them individually.

    Tuesday, January 15, 2008 4:48 PM
  • As I said this was a clean install ... reformatted and repartitioned. no custom anything just a fresh install and didn't work right from the finish of the setup.. it tried to open a file on the central administration called FarmSettings.aspx after the setup finished which is where I was getting the aforementioned error.. I am going to try this but why do you think this is the problem? Also is there a way to install the portal server to a different site other than the Default website? or just rename and report it after the setup is successful? (I have done this before it's been a while and I can't remember the exact steps!

    Tuesday, January 15, 2008 6:57 PM
  •  

    Nope that didn't help at all.... but I have to finish installing the rest of my apps I will try it again after that if anyone else has any solutions they would be appreciated! What about SP1 for Windows 2003 would that cause the problem because that is also installed atm? or even symantec corporate AV Server (I had the Auto-Protect off during install though)?
    Tuesday, January 15, 2008 10:21 PM
  • The error is telling you that it reached the end of the file without finding a close tag (</SPSWC:InputFormButtonSection>).  If you have a working Portal 2003 environment, you can compare the two FarmSettings.aspx files to see what the differences are.  I quickly did a search for farmsettings on two environments and came up with nothing.  Are you sure you've got the right file?

    Tuesday, January 15, 2008 10:28 PM
  • actually I guess it was ./SPS/FarmDatabase.aspx sorry I wasn't near the computer at the time of the post. It was what tried to open right after install ... I know that it didn't find the close tag but where??

    Tuesday, January 15, 2008 10:43 PM
  • I just got a copy. The last 12 lines of the file should read like this (make sure bolded line is there):

     

     

      

    Code Block

         <SPSWC:InputFormButtonSection runat=server>
            <SPSWC:InputFormButtonAtBottom runat=server id=btnOk AccessKeyLocID=SvrAdminFarmDatabase_Ok_AccessKey TextLocID=Page_OkButton_Text />
            <SPSWC:InputFormButtonAtBottom runat=server id=btnCancel AccessKeyLocID=SvrAdminFarmDatabase_Cancel_AccessKey TextLocID=Page_CancelButton_Text />
           </SPSWC:InputFormButtonSection>

          </SPSWC:InputForm>
         </SPSWC:RightBodySection>
        </SPSWC:MainBottomPageSection>
       </SPSWC:PageSections>
      </form>
     </body>
    </html>

     

     

    If it varies, then I would not trust the integrity of any of the other files either.  Let me know what you get.

    Tuesday, January 15, 2008 11:03 PM
  • Well I've decided to reinstall and try without SP1 (srry but I was in the middle of the reinstall when I got your last post) being on it I'll let you know but for some reason I still think I'm gonna have the same problem, so I'll let you know how it goes!

    Tuesday, January 15, 2008 11:26 PM
  • It may be that your install media is messed up.

     

    Wednesday, January 16, 2008 1:55 AM
  • Guess we're both on the same level with this one gary. I thought that might have been the problem to so I had run some tests on the cd and found there were read errors all through it then I checked back here and seen you posted my exact thoughts on this problem. Funny how the installation succeeded with no errors everytime though. Well I got a new cd and it worked great thanks for all your help guys!

    Thursday, January 17, 2008 2:25 PM