none
Verification of replica failed. Trying to promote Server 2012 Domain Controller

    Question

  • I am in the process of promoting a Server 2012 machine to a Domain Controller.  I continue to get the Verification of replica failed error. 

    When I first recieved the error I went to Active Directory Domains and Trusts and found that it said the Current Domain Function Level was set to 2000. So I elevated to Windows Server 2003 and attempted to promote the Server 2012 machine again and I received the same error. I found several articles that explains this needs to be done in Domains and Trust not Users and Computers and that is what I had done here but I have to be missing something, please advise.



    Friday, February 17, 2017 6:24 PM

Answers

All replies

  • Hi

     In first picture it gets "domain functional level" but the error related to forest functional level.Just check your forest functional level and if it is not at least 2003 then raise.

    Get-ADForest ; https://technet.microsoft.com/en-us/library/ee617216.aspx?f=255&MSPPError=-2147217396

    Also check this detailed article to migration steps;

    http://blogs.msmvps.com/mweber/2012/07/30/upgrading-an-active-directory-domain-from-windows-server-2003-or-windows-server-2003-r2-to-windows-server-2012/


    This posting is provided AS IS with no warranties or guarantees,and confers no rights. Best regards Burak Uğur

    Friday, February 17, 2017 6:43 PM
  • I see what I missed...


    Friday, February 17, 2017 6:44 PM
  • Hi,
    Thank you for the feedback and screenshot, can I think that the problem is fixed now?
    If you still have any questions, please feel free to contact us.
    And if the replies as above are helpful, we would appreciate you to mark them as answers, and if you resolve it using your own solution, please share your experience and solution here. It will be greatly helpful to others who have the same question.
    Appreciate for your feedback.
    Best regards,
    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 20, 2017 8:06 AM
    Moderator
  • Yes, this problem is fixed now.

    Thank you!

    G

    Monday, February 20, 2017 2:14 PM