locked
Client backup on Windows 2012 Essentials Server RRS feed

  • Question

  • Howdy!

    I am testing a Windows 2012 Essentials Server setup to replace my Windows Home Server.  So far, mostly so good but I have not been able to get the client backup to work consistently.

    Initially, I did not join my two other machines (one Win7 Pro and one now Win8 Pro) to the domain -- used the registry trick to avoid that.  The first few backups went well, and then it started consistently failing during the 1% mark. I checked the server and it appears that the backup application is crashing, and it's now reached the "auto-restart" limit in services and won't even start unless I manually do it.  Here's the event log from an attempted backup of my Windows 8 machine:

    Faulting application name: WSSBackup.exe, version: 6.2.9805.0, time stamp: 0x504a9faa

    Faulting module name: WSSBackup.exe, version: 6.2.9805.0, time stamp: 0x504a9faa
    Exception code: 0xc0000025
    Fault offset: 0x000000000004ebbf
    Faulting process id: 0x1088
    Faulting application start time: 0x01cdc5d7d1fbeda6
    Faulting application path: C:\Program Files\Windows Server\Bin\WSSBackup.exe
    Faulting module path: C:\Program Files\Windows Server\Bin\WSSBackup.exe
    Report Id: bf30cf21-31d6-11e2-93ff-c86000ccc740
    Faulting package full name: 
    Faulting package-relative application ID:  

    I then deleted the Win8 client from the server (hopefully freeing up the backup space), uninstalled the connector, rebooted, and reinstalled the connector. This time, the installation joined my machine to the domain.  I'm not thrilled about that (no more Homegroup) but can live with it, as I can still log into my local client account.

    That aside, I repeated the backup and got the same result as above.  

    The target of the backup on the server is a storage space made up from an external 2TB USB Western Digital Drive and a 1TB Seagate drive (total 3TB).  I created the space, and when I set up the backup, it offered to use it so I'm assuming that it's ok to use a storage space as the target of the client backup.  This is one reason I'm leaving WHS11 -- it can't back up to more than a single drive, which is a truly horrible limitation.  

    The client has 5 drives, but I only back up two of them: a 240GB SSD that serves as a boot drive, and a 4TB Hitachi D: data drive that has about 1TB of data on it (mostly photos and documents).  The other drives are used for video editing and don't need to be backed up, so I omitted them from the backup set.

    I do use symbolic links to redirect Documents, Photos, and Videos from my home directory on the C: drive to the D: drive.  Is that giving Backup fits?  As I said, it worked once or twice.

    I'm getting very concerned about not having a current backup, so I need to solve this problem.  Since it worked early on, I'm wondering if the backup database or registry on the server is simply corrupted beyond repair.  I tried repairing the client backup space and that succeeds each time.

    Question: is there a way to reset the client backup to its initial state?  Some magical command or registry entry?  I recall doing that once to an original Windows Home Server and it was a multi-step process that involved deleting shares and registry keys.

    Any advice at this point would be most welcome.

    (BTW, the server backup, onto two external 3TB USB3 Seagate drives) works perfectly.  It's the client backups that are broken.

    Thanks!

    Sunday, November 18, 2012 11:55 PM

Answers

All replies