locked
Windows Media Encoder not working on Windows 10 RRS feed

  • Question

  • Yes, we know Media Encoder is no longer being supported, but when we upgraded to Windows 10 from 7, the promise is that our software will work.  But since the upgrade, we have not been able to get Encoder to work.  We love the program and it's vital to our industry.  So please bare with us on trying to get this issue resolved.

    We were referred here from another forum admin.  We have successfully been able to get the software loaded and opened, but while setting up a new broadcast session with the wizard, we get error at the end saying "No such interface supported."

    Friday, December 9, 2016 7:23 PM

All replies

  • Have you tried right clicking the program and Troubleshooting compatibility?

    What was the other post perhaps saving anything that has already been tried.

    As this Windows Media Encoder is no longer support, have you considered either, keeping some machines back on a support OS to use? Or looking for a commercial product that can do same if this is 'vital' ?

    Friday, December 9, 2016 11:05 PM
  • We can directly try to run this program under compatibility mode.

    Right click the exe file for this program and choose Properties: Under Compatibility mode, Choose Windows 7 as the Run as OS:


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 13, 2016 9:44 AM
  • Yep, tried that about from Kate's post.  No luck. 

    • Edited by onesun1 Tuesday, December 13, 2016 9:32 PM
    Tuesday, December 13, 2016 9:28 PM
  • Great suggestion Kate.  I thought that would work, but no such luck.  Same error.  Would love to move on to another program, but all of our other offices are still on Windows 7 and still use this.  Mainly because it is so beautifully simple.
    • Edited by onesun1 Tuesday, December 13, 2016 9:57 PM
    Tuesday, December 13, 2016 9:42 PM
  • I am not sure but I am wondering if the program's DRM (digital rights management) conflicting with Windows 10 has something to do with it because after I get the error I can click on the properties.  When I click on all the tabs, everything is fine until I get to the "Security" tab (which houses the DRM feature) and "No such interface" pops right up every time. Even though nothings checked and the feature is not being used.
    Tuesday, December 13, 2016 10:08 PM
  • Windows 7 is in Extended Support until 2020 afaik so do you have any virtual machine equipment? If not perhaps get some build some Win7 machines in and run it on that in meantime. Then investigate alternatives for encoding.
    Tuesday, December 13, 2016 11:03 PM
  • Hi,

    Some components are working together to get this feature work, to know the detailed issue which module could be not compatible with Windows 10, we need help from the software's provider who may debug the source code to check in details.

    You can try Process monitor to capture the events when reproducing this issue and see if there is any clue or file missing such errors during this process.

    Thanks for your understanding.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 15, 2016 5:15 AM
  • Is there anyone who able to address this?

    • Edited by onesun1 Thursday, December 22, 2016 1:00 PM
    Friday, December 16, 2016 7:17 PM
  • It seems that some interfaces were deleted in WMVCORE.DLL after the "Windows 10 Anniversary Update" in 2016.

    My solution for the 32 bit version, is to avoid loading the new wmvcore.dll and load the old one instead by copying the old one in the Windows Media Encoder folder:

    1-Get a WMVCORE.DLL of a version before the update (I've taken one from a windows 7 installation version: 12.0.7601.17514 dated November 21, 2010. The file should be in C:\windows\syswow64 folder)

    2- On the Windows 10 computer, copy the file to the "C:\Program Files (x86)\Windows Media Components\Encoder" folder. As the dll is in the same folder as the application, windows will load it instead of loading the one in the c:\windows\syswow64 folfer.

    3- Run wmenc.exe. 

    To check which dll is loaded in the process, use Process Explorer from sysinternals. Set "lower pane view" in the menus to Dll. Click on wmenc.exe process and in the lower pane you will see the loaded dlls. Check that wmvcore.dll is loaded from the encoder folder (Path column).



    • Edited by danitru Thursday, August 29, 2019 9:50 AM
    • Proposed as answer by Joe_Syt Wednesday, April 1, 2020 7:39 PM
    Wednesday, August 28, 2019 5:15 PM