none
Unattend.ini processing error RRS feed

  • Question

  • Hi All

    We are looking to use MDT 2012 Sp1 on Windows 2008 R2 to deploy Windows 8 Pro.  The virtual Windows 8 reference PC was built, a couple of small apps installed, and then a SyPrep Capture was done (are more modifications required to the Win8 reference computer prior to doing this?).  I'm using an off-line USB media to do the install.  It progresses fine, until after the image is deployed, the Task Sequence executed and then it fails on reboot when parsing the Unattend.ini file (which I never touched during the config stage.  Please see error below from the Setupact.log file:

    Error code: 0x8030000b

    Pass: Specialize

    Component: Microsoft-Windows-Shell-Setup

    Ive checked that the right License key has been used, Ive also checked that there is no entry (via the Windows System Image Manager) for IEWelcomeMsg; which Ive seen on other bogs can be an issue.

    Thoughts:

    Should the Admin Account be enabled prior to capturing the image?

    Should IE 10 be installed prior to capture \ is it not already installed as part of Win 8?

    Any thoughts \ ideas much appreciated!

    Kind Regards

    Andrew


    Friday, July 5, 2013 11:04 AM

All replies

  • IE 10 is native to Windows 8.

    Have you tried running the Unattend.xml through WSIM to see if something is amiss?


    -Nick O.

    Friday, July 5, 2013 3:46 PM
  • Thanks Nick

    I haven't.  Is this easy to do?

    I presume this is like a dry-run\test?

    Friday, July 5, 2013 11:57 PM
  • In the Workbench, go to the task sequence properties, OS Info tab, and select Edit Unattend.xml. What MDT will do is actually launch WSIM. Once you are in WSIM, re-verify everything is correct. There is a validation button in WSIM that can also be used to parse the file.

    -Nick O.

    Saturday, July 6, 2013 2:07 AM
  • Thanks Nick

    My MDT 2012 is on x64 but the WIM I'm working on is x86 Image.

    Ive had to install a second server that is x86 and installed AIK.  Ive mapped to a drive to the workbench but when connecting to the Unattend.txt file it still has 'Validate Unattend.txt file' greyed out.

    Im new to WISM, what Ive done so far on the newly built AIK Server:

    1. Map a network drive to the Workbench share in focus on the MDT Server

    2. Open WISM, and then on the left hand screen, add in the Distribution Share just mapped.  Add in the Unattend.txt file from the same Workbench Share on the right handside of the tool.  Then when trying to add in the Windows 8 captured wim file that is from the Workbench I get an error 'Unable to load DLL 'wimgapi.dll': The specified module could not be found'

    3. I followed another blog that indicated that I should run at a command prompt 'where wimgapi.dll', but it did not see the file under any system path, as such I reinstalled AIK as instructed by the other blog.  But after the reinstall the same issue remains.

    Any thoughts much appreciated.

    Kind Regards

    Andrew

    Wednesday, July 10, 2013 12:40 PM
  • Few things here.

    The ADK must be installed for Windows 8, not the AIK. (For these purposes, the ADK is just the newest version of what was previously called the AIK.) You can find it at http://www.microsoft.com/en-ie/download/details.aspx?id=30652 .

    Just to clarify, this is Windows 8, right? I just want to make sure it isn't XP. (Unattend.txt is a file used by XP; Unattend.xml is a file used by Vista and above.)


    -Nick O.

    Wednesday, July 10, 2013 2:01 PM
  • Thanks Nick.

    Yep that's the version I had installed (and have also reinstalled as part of troubleshooting), and yep the gold build is a Windows 8 wim.

    Kind Regards

    Andrew

    Wednesday, July 10, 2013 2:07 PM