none
Failed to join machine to a domain during OSD TS. RRS feed

  • Question

  • Hi,

    I am trying to join a machine to a domain after apply the OS Image. Basically, my TS has the following steps:

    1- Restart in Windows PE;
    2- Format and Partition Disk;
    3- Apply OS Image;
    4- Apply Windows Settings;
    5- Setup Windows and ConfigMgr;
    6- Join Domain or Workgroup;

    When the TS runs the 6th step it fails whith the following error code: (0X8007054B)

    Thanks in Advance,
    Giancarlo.

    Wednesday, July 8, 2009 5:41 AM

Answers

  • Because when you are applying the image, you are in WinPE and using the drivers in the boot image. When the deployed OS is trying to join the domain, it needs to have the proper drivers. These are two distinct phases of the deployment that do automatically share drivers. From the steps that you've list in your first post, you are not applying drivers to the deployed OS. Make sure you add an Apply Drivers task after the Apply Windows Settings task.

    Is there a reason you've added step 6 above? The Windows settings task populates the sysprep.inf (for XP) or unattend.xml (for Vista) with the proper information to join the domain.
    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    • Marked as answer by Yog Li Monday, August 17, 2009 9:45 AM
    Tuesday, July 14, 2009 3:07 AM
    Moderator
  • Hi Jason,

    I'm using the same TS for another 2 different machine models and it is working fine. I was looking in the process which takes an image from the source computer, and after run the SYSPREP command the driver is unloaded. I got this information before the system restarts and initiate capturing the image in WinPE. Most propably the problem is related to sysprep. Do you know if there is way to not disable the network card during sysprep command?

    Tks,
    Giancarlo. 
    • Marked as answer by Yog Li Monday, August 17, 2009 9:45 AM
    Tuesday, July 14, 2009 3:15 AM

All replies

  • 0X8007054B = The specified domain either does not excist or could not be contacted.

    So you should start with checking your networksettings, domainsettings and the joindomain-account.
    Wednesday, July 8, 2009 5:49 AM
  • See %windir%\Debug\Netsetup.log for details.
    Wednesday, July 8, 2009 8:52 AM
    Moderator
  • I found the reason for this problem: When TS tries to join in the domain, the network card, for some unknown reason, is not loaded. If I run ipconfig does not show up the network adapter. Why the network is unavailable once I'm applying the OS from an image file? When I created the image file, all drivers were loaded and working fine.

    Tuesday, July 14, 2009 2:35 AM
  • Because when you are applying the image, you are in WinPE and using the drivers in the boot image. When the deployed OS is trying to join the domain, it needs to have the proper drivers. These are two distinct phases of the deployment that do automatically share drivers. From the steps that you've list in your first post, you are not applying drivers to the deployed OS. Make sure you add an Apply Drivers task after the Apply Windows Settings task.

    Is there a reason you've added step 6 above? The Windows settings task populates the sysprep.inf (for XP) or unattend.xml (for Vista) with the proper information to join the domain.
    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    • Marked as answer by Yog Li Monday, August 17, 2009 9:45 AM
    Tuesday, July 14, 2009 3:07 AM
    Moderator
  • Hi Jason,

    I'm using the same TS for another 2 different machine models and it is working fine. I was looking in the process which takes an image from the source computer, and after run the SYSPREP command the driver is unloaded. I got this information before the system restarts and initiate capturing the image in WinPE. Most propably the problem is related to sysprep. Do you know if there is way to not disable the network card during sysprep command?

    Tks,
    Giancarlo. 
    • Marked as answer by Yog Li Monday, August 17, 2009 9:45 AM
    Tuesday, July 14, 2009 3:15 AM