locked
Windows 7 (64-bit, Ultimate), Radeon HD 4850, broken system interrupts 100% CPU when idle RRS feed

  • Question

  • I have an HP media center m7248n, with an ATI Radeon HD 4850, trying to run a fresh install of Windows 7 64-bit.

    The problem is that 1 of my 2 cores is constantly in use.  So, the Task Manager shows up to 50% CPU use even when computer is idle.  Resource Manager shows System Interrupts taking an average of around 48% CPU use.  In other words, it's basically using about 100% of 1 of my 2 CPU cores.  xperf.exe showed the device causing the interrupts as "Unknown", but I know it's the ATI video card.  Because I took it out, replaced it with my old video card, and the old video doesn't have this problem (in the same PCI-E slot too btw).

    My Radeon 4850 runs fine in Windows XP 32-bit, but it's totally broken for both (my fresh install Windows 7 64-bit) (and my upgrade to Windows 7 32-bit).

    I tried ATI CCC (Catalyst Control Center) 9.7 and 9.9, and neither fixed the problem.

    This System Interrupts bug for my ATI Radeon HD 4850 is wasting 100% of 1 of my 2 CPU's.  Not good!  Does anyone at least know about this problem?

    ...

    Or, is there a work-around?  I am glad to try a work-around, I don't want to have to revert back to my old 32-bit Windows XP :-(, I am hoping to stick with my new fresh install of 64-bit Windows 7...  Thank you for any leads?

    ...

    Here is an example of other people reporting the same (or similar) problem:

    http://www.sevenforums.com/graphic-cards/12440-cpu-90-average-system-interrupts.html

    http://www.tomshardware.com/forum/530-63-windows-marvell-high-usage

    Has anyone out there ever seen any ATI video card work correctly (no system interrupts 100% of 1 cpu craziness) on any version of Windows 7, without this error?  Btw I'm using fresh install Windows 7 Ultimate 64-bit (same error on 32-bit too).

    One of those links suggests it has something to do with onboard ethernet LAN...  But I know it doesn't for me, because I disabled onboard LAN in BIOS and still got the same bug.  I also took out my tv tuner and unplugged everything except (DVI-to-VGA to monitor) and (USB keyboard/mouse), and still get the bug.

    This is a serious problem as it basically makes my system unusable..


    ...

    posted here too: http://forums.amd.com/game/messageview.cfm?catid=260&threadid=118786&enterthread=y
    Sunday, September 13, 2009 1:52 AM

Answers

All replies

  • Another one, same problem:
    http://www.sevenforums.com/graphic-cards/15152-radeon-4650-install-causes-100-cpu-usage.html
    Sunday, September 13, 2009 2:46 AM
  • Okay I found the work-around:

    http://www.google.com/url?sa=t&source=web&ct=res&cd=6&url=http%3A%2F%2Fwww.sevenforums.com%2Fgraphic-cards%2F15152-radeon-4650-install-causes-100-cpu-usage.html&ei=f1ysSqLiMJKcMdPwsfIN&usg=AFQjCNGZ7fkN0mID8Irq-i3kI-E4kIa-aw

    Device Manager -> System devices -> High Definition Audio Controller -> disable it

    This caused the "System Interrupts" CPU spike to go away :-)
    • Proposed as answer by elwyndfw Saturday, October 10, 2009 3:46 PM
    Sunday, September 13, 2009 2:54 AM
  • Keep in mind, this is a work-around not a fix.  Windows or CCC install should fix it automatically...  But at least it is now working again for me :-)

    Sunday, September 13, 2009 2:55 AM
  • dude if your running a sapphire 4850 hd 512 gddr3 you need to run either the onboard  sound and graphics  or the 4850's hdmi. one or the other needs to be disabled. onboard disable in the bios  or the cards ati hdmi drivers need to uninstalled with catalyst utility.When I installed the card, my cpu was spiking up to 100% then down to 50% then stay there. the sound stopped working. No sound through the onboard audio jack, no sound through the HDMI, even tried adding a new sound card...no sound. and  that cards audio hdmi is notorius for conflicting or trying to reinstall the catalyst drivers.t's nice that a video card has onboard sound .  installing a VIDEO card should not automatically preempt or disable a system's audio functionality. and it ends up with them both not working. i know it got me. but i also have onboard ATI Radeon HD 4200 gpu and hdmi out  . . had to reinstall sound drivers to get audio back. i had to uninstall all my ati drivers. then reinstall them seperatly from  the mobo's drivers.   Make sure to install the audio drivers for the HDMI connection separately if you plan to use it for sound in Windows 7 . Just installing the Catalyst drivers didn't do the job. but after all that, every thing is good. but it's the cards hdmi.  my 4850's sound now is disabled,and after all that thats all it took. go figure
    Sunday, September 13, 2009 2:25 PM
  • My motherboard's analog sound output still works, and that's all I've used so far, so I am fine, just concerned about the issue in general, or what to do if later I use (motherboard's digital audio output) or (HDMI sound output with Radeon HD 4850).  How to tell which audio is better btw?

    And just saying that overall, something should detect and then fix it...  Or, if there is no correct simple auto "fix", then something (Windows or CCC) should prompt the user about it (such as to pick which audio to enable, and where to change it later).
    Sunday, September 13, 2009 8:35 PM
  • As the system works fine with the old video card, the issue can be caused due to the current ATI card is not compatible with the onboard sound card (your Realtek AC'97 Audio on HP m7248n).

     

    I suggest you can try installing the latest driver for the Realtek AC'97 Audio, please check the following site:

     

    http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=23&Level=4&Conn=3&DownTypeID=3&GetDown=fals   

     

    I hope it will be useful. Also, you can consult ATI and Realtek for this compatibility issue.

     

    Good Luck!

    • Marked as answer by Linda Yan Friday, September 18, 2009 7:51 AM
    Monday, September 14, 2009 8:48 AM
  • I too am experiencing this issue.  System in question has Realtek audio and ethernet along with an ATI Radeon HD 3600 series video card.  The video card chipset may support audio, but the card itself does not have audio output.  Updating to the latest ATI and Realtek drivers do not resolve the issue.  However, disabling the Microsoft "High Definition Audio Controller" resolves the issue. 

    I am aware that this may be a workaround with an incompatibility between ATI and Realtek.  However, as my video card does not support audio-out, and Catalyst does not offer an option to disable the non-existent sound, this seems to be the most viable option at the moment.

    This is an older motherboard/cpu combination (hardware 4+ years old, designed for WinXP MCE):
    * Motherboard: MSI MS-7093 (HP OEM version - a1129n)
    * CPU: AMD Athlon 64 3400+
    * 2.5GB RAM
    * Chipset ATI Radeon XPress 200
    * onboard audio: Realtek ALC658C (does support dolby 5.1)
    * onboard ethernet: Realtek RTL8100C
    * Add-on Video: ATI Radeon HD 3600 Series 1GB (2 dvi ports, no audio out)

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00389436&tmp_task=prodinfoCategory&lc=en&dlc=en&cc=us&product=483901

    With "High Definition Audio Controller" disabled, Windows 7 runs like a champ on this aging system!
    Saturday, October 10, 2009 3:59 PM
  • I have a Dell Inspiron 530 with a Realtek ALC888 and a ATI Radeon 2600 which I upgraded to Windows 7 32-bit from Vista and I also experience this weird System Interrupts issue...
    • Edited by gartaud Saturday, October 24, 2009 5:54 PM
    Saturday, October 24, 2009 4:25 AM
  • I cannot get rid of the problem. The computer works fine after a reboot, but it appears that putting the computer to sleep and then resuming from sleep reliably triggers the issue.

    Under Sound, Video and game controllers I have
    ATI High Definition Audio Device (Location 0 (Internal High Definition Audio Bus) - ATI Technologies Inc., 9/18/2009, 5.0.7000.9)
    ATI Unified AVStream Driver (PCI bus 3, device 0, function 0 - ATI Technologies, 6/2/2009, 6.14.10.364 - IRQ 19)
    Realtek High Definition Audio (Location 2 (Internal High Definition Audio Bus) - Realtek Semiconductor Corp., 10/6/2009, 6.0.1.5953)

    Under System device I have numerous entries including
    High Definition Audio Controller (PCI bus 1, device 0, function 1 - Microsoft, 7/13/2009, 6.1.7600.16385 - IRQ 17)
    High Definition Audio Controller (PCI bus 0, device 27, function 0 - Microsoft, 7/13/2009, 6.1.7600.16385 - IRQ 22)

    What do you suggest?

    Disabling both High Definition Audio Controllers makes both the ATI High Definition Audio Device and Realtek High Definition Audio disappear from Device Manager but I still experience the System Interrupts problem when I resume from sleep (and I have not sound ouput)
    Saturday, October 24, 2009 5:35 PM
  • So I tried disabling devices one by one... Disabling the integrated network card Intel 82562V-2 10/100 Network Connection (PCI bus 0, device 25, function 0 - Microsoft, 3/26/2009, 9.13.4.10 - IRQ -2 (minus two)) stops the high cpu usage right away and reenabling it restarts the high cpu usage right away. How can the IRQ be minus two? I'm going to try updating this driver and google for this particular card. I guess ATI or realtek are not to blame in my case...


    Update: I installed the latest driver from Intel website but the problem is still here (Intel, 9/1/2009, 9.13.16.0)
    Everything is fine until I put the computer to sleep.
    When I resume the Intel 82562V2 generates interrupts like crazy. There is a setting to enable interrupt moderation which is enabled by default and set to adaptive moderation. It seems to work because if I disable it then the cpu usage climbs to 99% right away (both cores are running at full speed). But even when set to extreme moderation it pretty much use a full core to to deal with the interrupts (same as when set to adaptive moderation).

    I really don't know what to do at this point. I guess I could disable the Intel 82562V2 permanently and install a network card but I'm out of slots and would have to sacrifice something else.

    Anybody else having trouble with its network card and Windows 7?

    Btw, sorry for posting this under a thread that is ATI related. I initially believed that was also my problem and don't think so anymore. I should however add that my radeon 2600 uses an IRQ of -3 (minus three) which seems strange to me... so maybe there is some sort of conflict.

    Dell Inspiron 530 is a pretty common machine. Has anybody tried installing Windows 7 on it? Thanks.
    Saturday, October 24, 2009 6:39 PM
  • Try setting your monitor not to turn off, and your computer not to sleep. I did this and it stopped the system interrupts. I know it's not a fix, but it lowered my blood pressure for now. I hope this helps someone to figure out what this bug is being caused from. 
    Monday, January 11, 2010 1:58 PM
  • I had system interrupts issue also after upgrading my 64-bit Vista to Win7.  Thought it might be ATI card, but after reading forums, etc. looked at my Wireless D-Link (DWA-160) driver.  Although Windows said I had the latest one (dated 6.2008) I looked on D-Link website and downloaded one from 2009 and wow! no more sys interrupts on Task Manager and CPU is back to normal levels.  Now, I need to figure out why my monitor/ATI Radeon HD4850 won't go to its recommended 1920x1200 resolution.  Anyone have any ideas?
    Tuesday, February 2, 2010 1:09 AM
  • Same exact computer m7248n with ATI4650 and Win 7 installed at about the same time. Exactly the same problem, 80-90% CPU at idle and 100% on processor 1 all the time. Struggle with this for a long time - read every other site's comments to no avail. Then I saw this one.

    Applied Nina Lu's Realtek AC'97 fix and pemIam's HD audio driver disable - and problem FIXED! Idle is now 10% or lower, both processors the same. Never would have guessed it was an audio conflict eating up my machine.  Saved me buying another machine after just upgrading most things on this one.

    Thank guys!
    Thursday, February 4, 2010 1:24 PM