locked
Windows 7 scrolling issue RRS feed

  • Question

  • I recently disabled Aero to get Flight Simulator 2004 to work correctly (doesn't work right with Aero enabled).  I generally like to have Aero off as well.  But recently when I scoll on any windows or what not, I open the scroll box and can sort of see that I'm scrolling down, yet the words don't actually move up or down.  Sometimes this is the case and sometimes scrolling works correctly.  Also if I close out a tab on an application, sometimes the words are left behind as if the tab is still open.  Here is a photo to illustrate my issue.  This isn't limited to one program.  It also happens in Paint when I try to hit New and the tab just disappears and leaves behind what was there.  How do I fix this? 

    Running a HP DV9000 laptop with Windows 7 32 bit.  Came with Vista 32 bit but recently upgraded. 


    http://img.photobucket.com/albums/v237/jdudee101/win7issue1.png  The first picture. 

    http://img.photobucket.com/albums/v237/jdudee101/win7issue2.png  The second picture.
    Monday, March 1, 2010 5:39 PM

Answers

  • This is typically video drivers.  Make sure you're absolutely up-to-date.  Check Windows Update, and also check your PC manufacturer's website for updated drivers.

    Also I understand using Aero may not be an option while running that particular program, but did you know that Aero actually provides better performance when its on rather than off?  It's true.  When not using Aero, Windows defaults back to the GDI rendering system -- a technology first deployed in Windows 3 over two decades ago.  In this mode, your primary processor is responsible for asking every application to provide its screen image, then drawing to screen.  If one program is covering up another, and you move it... the program in the background actually has to spend CPU cycles re-calculating its image.  If that can't be done fast enough, you'll see those familiar visual copies of the foreground window as the background one struggles to re-draw itself.  GDI is also the number one cause of blue screen errors, slow computers (especially when multitasking) and other faults.

    Aero, on the other hand, offloads all visual processing to the graphics card, making your entire system faster and more reliable.  With Aero, programs will never appear "locked up" and won't cause visual artifacts, because their image is cached.  You'll be much happier with Aero on in most cases.






    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    • Marked as answer by Linda Yan Monday, March 8, 2010 2:14 AM
    Monday, March 1, 2010 8:27 PM
  • Flight Simulator 2004 is compatible with Windows 7. I agree with Shawn that the issue should be related to the display card and its driver. Please update the display card driver and see if the issue can be resolved. After that, enable Aero and check if the game and the display work properly.

     

    Also, you can troubleshoot the issue by going to Start -> Control Panel -> Troubleshooting -> Display Aero desktop effects. Follow the wizard to complete the troubleshoot.

     

     

    • Marked as answer by Linda Yan Monday, March 8, 2010 2:14 AM
    Wednesday, March 3, 2010 6:27 AM

All replies

  • This is typically video drivers.  Make sure you're absolutely up-to-date.  Check Windows Update, and also check your PC manufacturer's website for updated drivers.

    Also I understand using Aero may not be an option while running that particular program, but did you know that Aero actually provides better performance when its on rather than off?  It's true.  When not using Aero, Windows defaults back to the GDI rendering system -- a technology first deployed in Windows 3 over two decades ago.  In this mode, your primary processor is responsible for asking every application to provide its screen image, then drawing to screen.  If one program is covering up another, and you move it... the program in the background actually has to spend CPU cycles re-calculating its image.  If that can't be done fast enough, you'll see those familiar visual copies of the foreground window as the background one struggles to re-draw itself.  GDI is also the number one cause of blue screen errors, slow computers (especially when multitasking) and other faults.

    Aero, on the other hand, offloads all visual processing to the graphics card, making your entire system faster and more reliable.  With Aero, programs will never appear "locked up" and won't cause visual artifacts, because their image is cached.  You'll be much happier with Aero on in most cases.






    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    • Marked as answer by Linda Yan Monday, March 8, 2010 2:14 AM
    Monday, March 1, 2010 8:27 PM
  • Flight Simulator 2004 is compatible with Windows 7. I agree with Shawn that the issue should be related to the display card and its driver. Please update the display card driver and see if the issue can be resolved. After that, enable Aero and check if the game and the display work properly.

     

    Also, you can troubleshoot the issue by going to Start -> Control Panel -> Troubleshooting -> Display Aero desktop effects. Follow the wizard to complete the troubleshoot.

     

     

    • Marked as answer by Linda Yan Monday, March 8, 2010 2:14 AM
    Wednesday, March 3, 2010 6:27 AM