locked
Meeting Room emails are in German date format not English RRS feed

  • Question

  • Hi,

    We've consolidated some Exchange servers and this has included creating some Meeting room resource mailboxes on our German Exchange 2010 server (Sp1 + update rollup 3v3).

    When a user gets a reply from the meeting room (E.g. if the meeting room is already booked and it conflicts with someone else) then the message is sent showing the time and date as:

    Organizer and Time of Conflicting Meeting 
    Username - Montag, Juli 11, 2011 1:00:00 to Montag, Juli 11, 2011 1:30:00

    It shows Juli instead of July and Montag instead of Monday. Does anyone know if this setting change be changed? If so is it a property of the mailbox or is it a property of the resource attendant so if I change it for one mailbox it will affect every other meeting room?

    Thanks,

    Joe

     

    Thursday, July 14, 2011 4:02 PM

Answers

  • Hi Joe,

     

    Thanks for your update.

     

    Reboot the server sounds low technical but it actually resolved many technical issues. So go ahead and have a try.

     

    Based on my research, whenever Exchange returns the decline DSN message, it generates the date time in the format of the original message (meeting request). To be more specific, it is the property "PR_Message_Locale_ID". It is also worth to verify this attribute.

     

    So, please verify the following attributes:

     

    1.    The "PR_Message_Locale_ID" of the original meeting request (which was declined) from Sent Items via MFCMAPI tool.

    2.    Check the language code of the problematic e-mails using MFCMAPI, “PR_INTERNET_CPID” and “PR_MESSAGE_CODEPAGE”.

     

    You may download MFCMAPI from http://www.microsoft.com/downloads/details.aspx?familyid=55FDFFD7-1878-4637-9808-1E21ABB3AE37&displaylang=en. If you have any difficulty in this tool, please feel free to send me the meeting request as an attachment. My email address is V-Fiolia@microsoft.com.

     


    Fiona
    Tuesday, July 19, 2011 6:37 AM
    Moderator

All replies

  • HI Joe,

    You can assign yourself full mailbox access to the problematic room mailbox. Log into OWA with your account and then open the room mailbox through your OWA account. Once open, go to the Options|Settings|Regional and change the language to English. Save the changes and lets see if that fixes it up. then try to book duplicate MR and check conflict messages.


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Thursday, July 14, 2011 4:18 PM
  • Hi Anil,

    Thanks very much for your suggestion. I tried it and took the default of English US but when I try to book a room and there is a conflict the response still comes back showing the time and date in German :( !

    Maybe this feature always uses the local locale of the server and cannot be changed... Unless someone knows otherwise?

    Cheers,

    Joe

    Friday, July 15, 2011 3:04 PM
  • Are you sending email from a German client or a client with German regional setting?
    I think the response is in the same language that email client created it in.

    Is it also in german if you invite the room using OWA? 

     

    You can also try this.

    Set-Mailbox conferenceroom -Languages en-us

     

     

     


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    Friday, July 15, 2011 3:15 PM
  • Thanks Lasse,

     

    The client i am testing on is Outlook 2010 English (UK english) and OWA using Internet Explorer. Looks like an Exchange 2010 issue to me.

     

    Thanks for the -languages suggestion but I've already tried that :( and it didn't stop the issue

     

    Cheers,

    Joe

    Friday, July 15, 2011 4:07 PM
  • I used OWA to test this.

    Change language to English, did a meeting request, get the response back in English.
    set language to Swedish, did a meeting request, get the repsonse back in swedish.
    switched back to English and redo all things again and I always get the response in the langiage set in the client.

    Dont know why its not working for you.

     


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    Friday, July 15, 2011 5:24 PM
  • Hi Joe,

     

    Please run “Get-Mailbox –id <resource mailbox> |FL >c:\mr.txt” to see if the Languages value is set to “en-US”. If not change it and test again.

     

    If the issue continues, verify how many users are affected by this issue? Verify the affected users’ Regional settings (the mailbox setting in OWA/Outlook, but not the windows setting in Control Panel).

     

    Additionally, verify the windows regional settings of your HUB servers to see if it is set to German time.

     

    -Fiona

    Monday, July 18, 2011 6:34 AM
    Moderator
  • Hi Fiona,

     

    Thanks for the tips. I checked get-mailbox resource mailbox | fl and confirmed it is already set to en-us for language. I also checked the server (it is a multi role server with mailbox, hub and cas roles) and found it was set to German locale there. I got agreement from my Management to set this to English UK and tried again - still no luck :( It's 10 hours since the change and I just tried again with the same results :( I've also restarted some Exchange services hoping that would help (transport, mail submission, system attendant - I didnt restart the information store as this would affect users :(

    Please let me know anyone has any other ideas - maybe I need to restart the whole server to apply this change..

     

    cheers,

    Joe

     

    Monday, July 18, 2011 9:33 PM
  • Hi Joe,

     

    Thanks for your update.

     

    Reboot the server sounds low technical but it actually resolved many technical issues. So go ahead and have a try.

     

    Based on my research, whenever Exchange returns the decline DSN message, it generates the date time in the format of the original message (meeting request). To be more specific, it is the property "PR_Message_Locale_ID". It is also worth to verify this attribute.

     

    So, please verify the following attributes:

     

    1.    The "PR_Message_Locale_ID" of the original meeting request (which was declined) from Sent Items via MFCMAPI tool.

    2.    Check the language code of the problematic e-mails using MFCMAPI, “PR_INTERNET_CPID” and “PR_MESSAGE_CODEPAGE”.

     

    You may download MFCMAPI from http://www.microsoft.com/downloads/details.aspx?familyid=55FDFFD7-1878-4637-9808-1E21ABB3AE37&displaylang=en. If you have any difficulty in this tool, please feel free to send me the meeting request as an attachment. My email address is V-Fiolia@microsoft.com.

     


    Fiona
    Tuesday, July 19, 2011 6:37 AM
    Moderator
  • Hi,
    I used to have the same problem.
    I found that Exchange used the date and formats that were set on the System Account when sending Meeting Declines.
    I guess that the system account on your system still has German locale and format set and to check that, open the registry and look at the settings in HKEY_USERS\S-1-5-18\Control Panel\International

    What I did to solve my problem was to
    1. Configured my account with the Format settings I wanted for the server (Region and Language|Format)
    2. Went to the Administrative tab and copied my current settings to "Welcome Screen and system Accounts"
    3. Copied my current settings to "Welcome screen and system accounts"


    Hope this helps.


    :Martina

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, July 19, 2011 8:14 AM
  • Hi Joe,
    Are you still having this problem or is it solved?
    Please share your findings with us.

    :Martina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.
    Tuesday, July 26, 2011 2:19 PM
  • Hi,

    we were having a similar problem with the language of read receipts.

    Copy the settings resolved the problem for us.

    Thanks.

    Friday, April 6, 2012 7:59 AM
  • Hi Martina,

    I have the same issue, when user send a meeting request to a role based account and the decline message return incorrect date format. I checked user pc regional setting and also hub and cas server all set to en-au format. Could you please advice how you resolve this ? Is is a exchange issue or client issue ?

    Your request was declined because there are conflicts.

    The conflicts are:

    Organizer and Time of Conflicting Meeting  6/27/2013 2:00:00 PM to 6/27/2013 3:00:00 PM      

     All times listed are in the following time zone: (GMT+08:00) Time Zone  

    Cheers,

    Lee

    Tuesday, June 25, 2013 1:22 AM
  • Hi Fiona,

    I downloaded the mfcmapi tool and open up the decline message , ,I can see the line for

    PR_Message_Locale_ID , PR_INTERNET_CPID” and “PR_MESSAGE_CODEPAGE

    Cant tell anything wrong as it contain number and value

    could you please advice how to read ?

    Cheers,

    Lee

    Tuesday, June 25, 2013 1:40 AM
  • I found this which fixed my issue. This may apply to this issues or not . My issues was as a uk person the format of room declines was in the US format causing confusion.

    It was an outlook client reg fix

    HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\<current Outlook profile>\13dbb0c8aa05101a9bb000aa002fc45a

    create. Value: 000366a1 Type: REG_BINARY Data: 09 0C 00 00

    ref: http://social.technet.microsoft.com/Forums/exchange/en-US/fae183a4-3484-4042-9376-35649dc35459/date-format-in-meeting-request-responses-appears-to-be-hardcoded-to-us-format?forum=exchangesvrgenerallegacy

    Tuesday, February 11, 2014 9:46 AM