none
Project Server 2010 OLAP Cube Build Error - Roles RRS feed

  • Question

  • While trying to build an OLAP cube on the Project Server 2010, I got the following error

    [3/19/2012 2:03 AM] Cube build session started
    ===== Process Completed =====
    [3/19/2012 2:04 AM] Failed to build the OLAP cubes. Error: Error Setting Olap Database 'test' roles: Error: The trust relationship between the primary domain and the trusted domain failed.

    I've thrown every sort of permission on all the accounts... but unable to fix the issue!!


    Regards Prasad

    Monday, March 19, 2012 6:38 AM

Answers

  • Hi Prasad,

    according to the following Blog post http://blogs.technet.com/b/frenchpjblog/archive/2010/12/20/3376118.aspx if I translated correctly please try the following:

    1. Identify the OLAP Cube GUID by executing the following SQL script against the Published database:
      select WADMIN_AS_DATABASE_UID from MSP_WEB_ADMIN_CUBE
    2. Use the GUID to execute the following command against the Published database
      EXEC MSP_WEB_SP_QRY_GetAllCubeViewDomainAccount 'GUID CUBE'
    3. You will get a list of accounts - verify the Windows accounts and correct them if necessary. Maybe there's a disabled account which you need to delete?

    Other possibility: Try to build the Cube with another name.

    Monday, March 19, 2012 9:32 AM

All replies

  • Hi Prasad,

    according to the following Blog post http://blogs.technet.com/b/frenchpjblog/archive/2010/12/20/3376118.aspx if I translated correctly please try the following:

    1. Identify the OLAP Cube GUID by executing the following SQL script against the Published database:
      select WADMIN_AS_DATABASE_UID from MSP_WEB_ADMIN_CUBE
    2. Use the GUID to execute the following command against the Published database
      EXEC MSP_WEB_SP_QRY_GetAllCubeViewDomainAccount 'GUID CUBE'
    3. You will get a list of accounts - verify the Windows accounts and correct them if necessary. Maybe there's a disabled account which you need to delete?

    Other possibility: Try to build the Cube with another name.

    Monday, March 19, 2012 9:32 AM
  • Hi Prasad,

    Is the Analysis Services in a differente server from the Project Server? If affirmative, is the service account of Analysis Services a windows account?The Project Server service account that access the Analysis Services is in the group of Analysis Services Administrator and in the SSAS Users' group of the server where SSAS is installed?


    Best regards, Ricardo Segawa - Segawas Projetos / Microsoft Partner

    Tuesday, March 27, 2012 9:54 PM
  • Thursday, March 29, 2012 12:53 PM
  • I have made a note from one of the past solutions i read sometime back on TechNet. Try if it helps you:

    1. Identify the OLAP Cube GUID by executing the following SQL script against the Published database:
      select WADMIN_AS_DATABASE_UID from MSP_WEB_ADMIN_CUBE
    2. Use the GUID to execute the following command against the Published database
      EXEC MSP_WEB_SP_QRY_GetAllCubeViewDomainAccount 'GUID CUBE'
    3. You will get a list of accounts - verify the Windows accounts and correct them if necessary. Maybe there's a disabled account which you need to delete?


    Abhijeet M. Mohite

    Thursday, March 29, 2012 1:46 PM
  • Hi Prasad,

    Is your issue resolved.

    Did it help?


    Abhijeet M. Mohite

    Friday, March 30, 2012 6:20 AM
  • This is exactly what I have found in our case (an account in a trusted domain that was deleted)

    How exactly do you go about deleting it (and from which DB)?

    Wednesday, June 19, 2013 8:24 PM