none
Unable to Install FIM Data Warehouse Support Scripts on a Remote SQL Server RRS feed

  • Question

  • Hi,

    Busy trying to deploy FIM Reporting. I am at the stage where I need to run the FIMPostInstallScriptsForDataWarehouse.ps1, but of course this fails as SCSM DW and SQL are on different servers (and there is nothing in the Microsoft FIM Reporting Deployment Guide on this common scenario).

    I found this article and am working through it:

    http://social.technet.microsoft.com/wiki/contents/articles/17916.troubleshooting-fim-install-fim-data-warehouse-support-scripts-on-a-remote-sql-server.aspx

    However, everything was running smoothly until I tried to execute the following command (as per article):

    Could someone that may have worked through this article, or had a similar deployment help us out please.

    Thank you,

    SK


    Wednesday, July 16, 2014 4:57 AM

All replies

  • You are invoking a command on remote computer, but you have local path in file specified. Please copy directory Scripts on C: drive of remote server as well as subdirectory Data Warehouse Support Scripts with its content. Check if it helps.

    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Wednesday, July 16, 2014 5:19 AM
  • I have followed the article exactly, and have the \Scripts\Data Warehouse Support Scripts\ folder on both the SCSM DW and SQL servers.

    Maybe it would be easier to just install SQL Management Studio on the SCSM DW server and rerun the FIMPostInstallScriptsForDataWarehouse.ps1 from the DW server?

    Here is the original error when I tried to run FIMPostInstallScriptsForDataWarehouse.ps1 from the SCSM DW server:

    Checking to see if the Base Management packs for ForeFront Identity Manager have been deployed
    The term 'Invoke-SqlCmd' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again
    . The specified module 'sqlps' was not loaded because no valid module file was found in any module directory. No snap-ins have been registered for Windows PowerShell version 2. No snap-ins have been registered for Windows PowerShell version 2. Cannot find path 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds\Microsoft.SqlServer.Management.PowerShell.sqlps' because it does not exist.
    FIM Datawarehouse script installation FAILED

    • Edited by Shim Kwan Wednesday, July 16, 2014 5:30 AM
    Wednesday, July 16, 2014 5:25 AM
  • Quick Update: by deploying SQL Management Studio on the SCSM DW server, I was able to run the FIMPostInstallScriptsForDataWarehouse.ps1 script from the SCSM DW server.
    Thursday, July 17, 2014 4:07 AM
  • how to run this script through SQL management studio?
    Tuesday, July 19, 2016 1:37 PM
  • Deploy SQL Management Studio on the SCSM DW server.

    Open a PowerShell console (on the SCSM DW server) and run the file: FIMPostInstallScriptsForDataWarehouse.ps1

    Tuesday, July 19, 2016 11:10 PM
  • Thanks Shim.

    Am getting the below error.

    Invoke-SQLcmd: cannot open databse "DWStagingandconfig" requested by the login.

    login failed for the user. no-snap-ins have been registered for windows powershell.


    Wednesday, July 20, 2016 12:59 PM