none
Proxy PAC file not working on IE11 RRS feed

  • Question

  • Hi,

    I'll make this as brief as possible:

    Installed IE11 on Windows 7 and Proxy PAC file does not work, however Google Chrome, which gets its proxy settings from IE, is using the PAC file just fine. My PC was able to use the PAC file on IE8 and IE10. The 'Use Automatic Configuration Script' option is ticket and the PAC file path entered in this format: File://C:/Windows/pacfilename.pac

    Any ideas?

    Thanks.

    Thursday, November 21, 2013 1:27 AM

Answers

All replies

  • Hi,

    I recommend you to manually configure a proxy server in the pac file to test if you can connect to internet.

    http://support.microsoft.com/kb/2777643/en-us

    Thanks!


    Andy Altmann
    TechNet Community Support

    Monday, November 25, 2013 1:45 AM
    Moderator
  • I have the same problem with a PAC file configuration that has been working for many years -- It continues to work with Mozilla but not with IE 11 since the IE 11 upgrade.

    I did configure a hard coded proxy in IE 11 and that does work.

    I remember that we had the same problem when IE 8 came out and Microsoft initially tried to change the PAC file API -- > That change was reversed rather quickly once the problem was publicized. I hope this is not a re-occurrence of that change

    I should note that this PAC file reference is "inserted" into the Internet Options automatically some time after the initial system boot up so it is not necessarily there immediately on start up.  I did see some reference that suggested there were different settings for "when" or "how often" IE 11 checked for a proxy (PAC?) file. (not sure if this might be relevant).
    • Edited by king2201 Wednesday, November 27, 2013 12:42 AM
    Wednesday, November 27, 2013 12:24 AM
  • Same here.
    Saturday, December 14, 2013 2:59 PM
  • +1
    Saturday, December 21, 2013 8:34 PM
  • This is known to be an issue, and is intended (it is by design, i.e. it is deliberate) by MS.
    The "local" PAC file (i.e. where you use a "file://....." URI/URL, is not supported and has been deprecated.

    http://blogs.msdn.com/b/ieinternals/archive/2013/10/11/web-proxy-configuration-and-ie11-changes.aspx

    We use http://wpad/wpad.dat and it's fine. Also fine, is http://wpad.contoso.local/proxy.pac .


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Proposed as answer by king2201 Monday, December 23, 2013 2:58 PM
    • Marked as answer by Norton_San Monday, February 17, 2014 5:20 AM
    Sunday, December 22, 2013 6:18 AM
  • Thank you for the clear direction that a local proxy.pac file is not being supported by Microsoft going forward.

    However, in our environment, locating an actual server for an "http" file location will be a challenge.

    At least for the time being, I will have to advise my users NOT to upgrade to IE11.

    Thankfully, Mozilla/Firefox (actually our recommended option) continues to support the local proxy.pac file.

    Monday, December 23, 2013 3:04 PM
  • Hi Don,

    I have zscaler web proxy hosted on their platform (i.e. cloud). Using IE 11 with proxy enabled makes IE crash but it works fine in chrome.

    Please suggest if there is any fixes for this.

    Our DNS is local.

    Thanks

    Wednesday, January 27, 2016 3:42 AM
  • Hi Don,

    I have zscaler web proxy hosted on their platform (i.e. cloud). Using IE 11 with proxy enabled makes IE crash but it works fine in chrome.

    Please suggest if there is any fixes for this.

    Our DNS is local.

    Thanks

    It seems that you may have a very different problem (crash of IE), compared to what is discussed in this thread (proxy pac is not respected)?

    Are you trying to use a file: URI for pac or http: URI for pac?
    What is the crash message?


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Saturday, January 30, 2016 10:11 PM
  • Hi, all,

    i had the same issue. The PAC-Script did not work though it is stored on a webserver. All the other browsers are working properly. RegretullyI need IE 11 for Sharepoint datasheet view.

    Now I found a simple solution. Obviously the connection information are registered as garbage within the registry at least after click on advanced options to proxy-settings.

    1. I found the registry key 
      HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections
    2. I deleted the binary data and closed the registry
    3. I insertedd the pac-script into the Internetconnection via system configuration panel again 
    4. After restarting my computer IE 11 works fine again.

    Hopefully this helps.

    Kind regards

    Christine

    Wednesday, June 8, 2016 12:11 PM
  • Hi, all,

    i had the same issue. The PAC-Script did not work though it is stored on a webserver. All the other browsers are working properly. RegretullyI need IE 11 for Sharepoint datasheet view.

    Now I found a simple solution. Obviously the connection information are registered as garbage within the registry at least after click on advanced options to proxy-settings.

    1. I found the registry key 
      HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections
    2. I deleted the binary data and closed the registry
    3. I insertedd the pac-script into the Internetconnection via system configuration panel again 
    4. After restarting my computer IE 11 works fine again.

    Hopefully this helps.

    Kind regards

    Christine

    Hi Christine,

    many thanks for your contribution.

    After month of setting the proxy manually (and having troubles with some exceptions) this just finally solved the problem.

    Thanks and regards,
    Michael

    Wednesday, August 30, 2017 8:45 AM
  • Hi all,

    The removal of the Internet Settings\Connections key was the last step I had to implement, otherwise I also use the proxy IP and port next to the .pac file. 

    https://social.technet.microsoft.com/Forums/ie/en-US/c77ca3be-d58b-4b06-bb5d-2194332abb11/web-page-cannot-be-displayed-in-ie-11

    Thanks

    Ferenc

    Thursday, October 19, 2017 9:52 AM
  • Hi Christine where is this sytem configuration panel you speak of in step 3?
    Saturday, October 21, 2017 6:37 PM
  • Refers Tools ->>Internet options ->> Connections - >> Lan settings

    This method works for me, but if i power down my PC and turn it on again, it's not works... Any ideas?

    Tuesday, March 20, 2018 12:44 PM
  • I had this happen with a customer using Windows 10 Enterprise, V 1903 OS build 18362.418.   It was reproducible in our lab.  

    After upgrading to Windows 10 Enterprise OS to build 18632.449 it worked in our scenario. 

    https://support.microsoft.com/en-us/help/4522355/windows-10-update-kb4522355  

    Thursday, October 31, 2019 5:34 PM