none
DPM 2012R2 - Backing up Drive that's Volume Name (Guid) changes RRS feed

  • Question

  • We are in the process of migrating backups to DPM 2012 R2 and have an unforseen issue.

    We have a volume mounted on a server that we used to back up by driver letter on our legacy software but in DPM this does not work as the Volume GUID under this drive letter changes each month (it is a snapshot from a SAN that is mounted automatically before the backup so the most recent is always backed up to tape).

    As DPM uses these to track its backups it simply thinks the drive is not there once the underlying GUID changes.

    Is there a way round this? Or anything worth trying?

    Thursday, February 26, 2015 3:38 AM

Answers

All replies

  • Hi,

    As you said DPM use Volume GUID to recognize the volume. If GUID is changed, it will consider that it is a new volume.

    Instead of finding a workaround on DPM, is it available to mount the Lun directly instead of its recent snapshot?


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, March 3, 2015 1:26 PM
    Moderator
  • Hi,

    You can use the migrate-data source.ps1 script to re-associate the dpm replica to the new GUID.

    Using migrate-datasource

    https://technet.microsoft.com/en-us/library/ff399411.aspx?f=255&MSPPError=-2147217396


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, March 4, 2015 5:06 AM
    Moderator
  • Hi Mike, sorry only just spotted your answer.

    I have just tested this using the auto option and I get:

    newDataSource= H:\ oldDataSource= H:\

    Exception calling "MigrateDataSource" with "2" argument(s): "The remote
    procedure call failed. (Exception from HRESULT: 0x800706BE)"
    At C:\Program Files\Microsoft System Center 2012
    R2\DPM\DPM\bin\Migrate-DataSource.ps1:220 char:10
    +          $dpmServer.MigrateDataSource($newDataSourceId, $oldDataSourceId)
    +          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
        + FullyQualifiedErrorId : COMException

    Error in Migration


    • Edited by [Malco] Tuesday, March 10, 2015 11:37 PM
    Tuesday, March 10, 2015 11:29 PM
  • Update

    The server has 8 drives to cover that change guid each month  (F: to M:) and I've noticed that if I rerun the command it then misses the last letter it ran against (for example F:) and it doesn't show that one again.

    If I run it until it has got all 8 drives then run it again I get:

    Running inquiry on the PS
    Finished running inquiry
    Could not find any volumes for migrating automatically


    Is this just a case of it not being able to handle multiple volumes in one command?


    • Edited by [Malco] Tuesday, March 10, 2015 11:39 PM
    Tuesday, March 10, 2015 11:36 PM
  • Hi,

    Not sure wht you received the error 0x800706BE - remote procedure call failed.

    I would suggest using the manual method so you have complete control over the process.

    *********  IMPORTANT NOTE ***********************

    1ST LIST RETURNED IS THE DPM REPLICA VOLUME DRIVE LETTERS
    2ND LIST RETURNED IS THE PS DATA SOURCES LIST.


    EXAMPLE
    =======

    The Bolded items are inputs.  


    PS C:\Program Files\Microsoft DPM\DPM\bin> migrate-datasource
    DPMServer: dpm1
      auto for AUTO SEARCH for matching volume letters
      manual for MANUAL INPUT of 'from' and 'to' Volumes, to be migrated
    option( auto or manual): manual
    PSName: fs01
    Domain: nwtraders.com
    Running inquiry on the PS

    List of fileSystem datasources under protection(candidates for migration):
    1 E:\   File Server FS01

    Number: 1
    The old datasource selected is : File Server FS01   E:\

    The following are the list of Datasourcevolumes available for protection, which would u like to consider:
    (Migration not allowed from normal volume to a mounted volume)
    1 C:\

    2 E:\

    Number: 2

    The New datasource selected is  E:\
    Confirm migration (Y/N)? : Y
    newDataSource= E:\ oldDataSource= E:\

    Migration Completed for newDataSource= E:\ oldDataSource= E:\
    Running inquiry on the PS for App restore

    Run Consistency check to make replica Valid

    PS C:\Program Files\Microsoft DPM\DPM\bin>


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, March 12, 2015 2:50 PM
    Moderator
  • Thanks Mike, as the drives are mounted on the DPM server itself running it manually brings up an epic number of volumes. Auto seems to work if I run it as many times are there are volumes to match up due to the below error. It's like it can't recursively work through them.

    Exception calling "MigrateDataSource" with "2" argument(s): "The remote
    procedure call failed. (Exception from HRESULT: 0x800706BE)"
    At C:\Program Files\Microsoft System Center 2012
    R2\DPM\DPM\bin\Migrate-DataSource.ps1:220 char:10
    +          $dpmServer.MigrateDataSource($newDataSourceId, $oldDataSourceId)
    +          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
        + FullyQualifiedErrorId : COMException

    Error in Migration

    Thursday, April 2, 2015 3:14 AM
  • Hi,

    You might be better off working with the SAN vendor so you can take hardware snapshots without changing the disk signature so the volume guids don't change. That way DPM will always see them as the same volumes under protection after mounting the snapshot on the DPM server.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Thursday, April 2, 2015 4:23 AM
    Moderator
  • did you ever get this sorted.

    have same issue with ID changing on a volume and DPM failing then as protection group was setup to backup old VolumeID

    DPM 2012r2

    Cheers

    Colm

    Thursday, June 4, 2015 4:22 PM
  • Hi,

    Same solution use the powershell to reasociate the volumes.

    Using migrate-datasource
    https://technet.microsoft.com/en-us/library/ff399411.aspx

    I would use the manual method for better control.

    EXAMPLE
    =======

    The Bolded items are inputs.  


    PS C:\Program Files\Microsoft DPM\DPM\bin> migrate-datasource
    DPMServer: dpm1
      auto for AUTO SEARCH for matching volume letters
      manual for MANUAL INPUT of 'from' and 'to' Volumes, to be migrated
    option( auto or manual): manual
    PSName: fs01
    Domain: nwtraders.com
    Running inquiry on the PS

    List of fileSystem datasources under protection(candidates for migration):
    1 E:\   File Server FS01

    Number: 1
    The old datasource selected is : File Server FS01   E:\

    The following are the list of Datasourcevolumes available for protection, which would u like to consider:
    (Migration not allowed from normal volume to a mounted volume)
    1 C:\

    2 E:\

    Number: 2

    The New datasource selected is  E:\
    Confirm migration (Y/N)? : Y
    newDataSource= E:\ oldDataSource= E:\

    Migration Completed for newDataSource= E:\ oldDataSource= E:\
    Running inquiry on the PS for App restore

    Run Consistency check to make replica Valid

    PS C:\Program Files\Microsoft DPM\DPM\bin>


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, June 4, 2015 4:37 PM
    Moderator
  • Hi Mike, I managed to automate this using a tweaked version of the Migrate-datasource script as per your original reply. 

    Thanks for you help on this.

    Thursday, June 4, 2015 10:36 PM
  • Briiliant, thanks Mike
    Friday, June 5, 2015 11:11 AM