none
x of the loaded queries contained errors - but viewing errors shows none? RRS feed

  • Question

  • Hi guys, really strange issue I am seeing in Power BI (May 2017 version)

    I have a few exposed tables from Power Query. When loading the data to the model, one of the tables indicates there are some errors. I click on the View Errors link and it creates a new query but it returns 0 rows. 

    I first thought that it was because the preview in Power Query was too small for the same set (which is a bit of a limitation of the show errors capability if this is the case!) so I reduced the set right down so that it is small enough for the whole result set to fit (I can see them all if I scroll all the way down) but there are still no errors shown.

    How does PowerBI determine if there are errors and why is it not showing the errors in the output?

    How can I find these errors?

    Thanks for any help!

    Brett

    Wednesday, May 31, 2017 12:13 PM

Answers

  • This phenomenon typically happens when your columns contain data that doesn't match the data type of the column. This is allowed in Power Query, but not when the data is loaded.

    An example would be numbers with fractions, while your column's data type is whole number.

    Finding the errors: visually check if the actual data in each column matches the data type of the column.

    Solving the errors: make sure the data types of the columns match the data types of the values in the columns. 

    • Marked as answer by Brett G (VR) Wednesday, May 31, 2017 2:34 PM
    Wednesday, May 31, 2017 1:12 PM