locked
CHKDSK Running on every boot RRS feed

  • Question

  • I had several people report to me today that since Friday 4/12/2013 CHKDSK is running every time they boot so I sent an email to all of my users and in only thirty minutes I already have 40 responses from people experiencing this issue.  No errors are being found but it is causing very lengthy boot times due to to running CHKDSK.  Isuspect eventually almost all of my Windows 7 users are going to reply that they have this issue.  None of my Windows 8 users are experiencing this.
    Monday, April 15, 2013 4:45 PM

Answers

  • Hi Tony,

    I found the answer to the problem:

    http://support.microsoft.com/kb/2839011?wa=wsignin1.0

    It turns out that the update KB2823324 released last week causes an NTFS error after boot-up (see below), which sets the dirty flag on the boot partition, and forces a CHKDSK during the next update. Evidently it only affects Windows 7 64-bit machines, as far as I can tell.

    To fix the issue:

    1. Uninstall KB2823324 (Control Panel | Programs and Features | View Installed Update. Search for KB2823324 and uninstall it.)
    2. Reboot. The computer will still do one last CHKDSK. Let it finish.
    3. Check the System Event log and verify that the following error did NOT show up during the boot process:

      Event Type: Error
      Event Source: Ntfs
      Event Category: Disk
      Event ID: 55
      Date: <var>Date</var>
      Time: <var>Time</var>
      User: N/A
      Computer: <var>Computer_name</var>
      Description:
      The file system structure on the disk is corrupt and unusable. Please run the Chkdsk utility on the volume C:

    As far as I can tell, there is no utility to turn off the dirty flag on the file system, so the best recovery method is to let CHKDSK do its thing, and it will remove the dirty flag after running a scan.

    The only other option would be to disable Auto Check, which runs at start-up, looks to see if the drive is dirty, and kicks off CHKDSK if they are. I don't recommend this option because the system will lose the ability to heal itself should an actual system issue occur, like a power failure during a disk write, etc. If you still want to turn off Auto Check, follow these instructions to turn it off in the registry:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/how-to-disable-the-chkdsk-check-disk-on-start-up/35f58c69-7a6c-4e1b-aec3-26d7131ec643

    I hope that helps! Let me know if you find out anything more.

    • Proposed as answer by Ma8tthew Monday, April 15, 2013 8:28 PM
    • Marked as answer by Cloud_TS Friday, April 26, 2013 3:13 AM
    Monday, April 15, 2013 8:26 PM

All replies

  •  Hi

        Follow these steps to stop

    To clear the NTFS dirty bit on a drive/partition, try this. Note x: is the drive you want to clear, usually c:

    XP- Click on Start, All Programs, Accessories, Command Prompt
    Vista & WIndows 7- Click on Start, All Programs, Accessories. Right click on Command Prompt and select Run as Administrator

    Type fsutil dirty query x:. This queries the drive, and more than likely it will tell you that it is dirty.

    Next, type chkntfs /x x:. The /X tells Windows to NOT check that particular drive on the next reboot. Now manually reboot your computer, it should not do a chkdsk and should take you directly to normal Windows login.

    Once Windows has fully loaded, bring up another Command Prompt and enter chkdsk x: /f /r. Reply Y if asked if you want this to happen on the next boot. This should take you through 5 stages of the chkdsk scan on the next boot and will unset that dirty bit. Be patient as this can take an hour or more depending on the size of the hard drive or partition.

    Once booted back to Windows, open another Command Prompt and query the dirty bit again by entering fsutil dirty query x: and Windows will confirm that the dirty bit is not set on that drive.

    Monday, April 15, 2013 6:06 PM
  • Hi Tony,

    I found the answer to the problem:

    http://support.microsoft.com/kb/2839011?wa=wsignin1.0

    It turns out that the update KB2823324 released last week causes an NTFS error after boot-up (see below), which sets the dirty flag on the boot partition, and forces a CHKDSK during the next update. Evidently it only affects Windows 7 64-bit machines, as far as I can tell.

    To fix the issue:

    1. Uninstall KB2823324 (Control Panel | Programs and Features | View Installed Update. Search for KB2823324 and uninstall it.)
    2. Reboot. The computer will still do one last CHKDSK. Let it finish.
    3. Check the System Event log and verify that the following error did NOT show up during the boot process:

      Event Type: Error
      Event Source: Ntfs
      Event Category: Disk
      Event ID: 55
      Date: <var>Date</var>
      Time: <var>Time</var>
      User: N/A
      Computer: <var>Computer_name</var>
      Description:
      The file system structure on the disk is corrupt and unusable. Please run the Chkdsk utility on the volume C:

    As far as I can tell, there is no utility to turn off the dirty flag on the file system, so the best recovery method is to let CHKDSK do its thing, and it will remove the dirty flag after running a scan.

    The only other option would be to disable Auto Check, which runs at start-up, looks to see if the drive is dirty, and kicks off CHKDSK if they are. I don't recommend this option because the system will lose the ability to heal itself should an actual system issue occur, like a power failure during a disk write, etc. If you still want to turn off Auto Check, follow these instructions to turn it off in the registry:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/how-to-disable-the-chkdsk-check-disk-on-start-up/35f58c69-7a6c-4e1b-aec3-26d7131ec643

    I hope that helps! Let me know if you find out anything more.

    • Proposed as answer by Ma8tthew Monday, April 15, 2013 8:28 PM
    • Marked as answer by Cloud_TS Friday, April 26, 2013 3:13 AM
    Monday, April 15, 2013 8:26 PM
  • I don't suppose you've seen this with Windows XP users?  I've got a dual boot XP Pro / Win 8 Pro 64 system and I appear to be seeing the same thing on there.
    Saturday, May 4, 2013 5:43 AM
  • Hi Grungewart,

    We have not seen the issue with Windows XP, and we do not expect to since the KB fix in question, 2823324, is a fix that only applies to Windows Vista, 7, and Server 2008. The vulnerability that is fixed does also exist in Windows XP, according to Security Bulletin 2829996 - "Vulnerabilities in Kernel-Mode Driver Could Allow Elevation Of Privilege."

    A recent check of KB2823324 shows that this patch has been superseded by a new patch; I'm guessing Microsoft is aware of the issue described above and has fixed it, according to KB2840149.



    Friday, May 10, 2013 4:48 PM
  • I have seen this on my XP install.  SATA drive in AHCI mode, Partion drive D: flagged as dirty.  Did not find KB2823324 installed, but there was a Windows update just prior to the problem starting in the same time frame noted above.  Thanks to tyagiankit36 for his solution.  Seems to have resolved it. 
    Thursday, June 20, 2013 6:51 AM
  • I've had a couple of Windows updates for my XP SP3 system during the past two weeks and experienced the same problem (CHKDSK running on every boot).  Last week I corrected the problem thru regedit by changing the BootExecute entry to autocheck autochk *.  After the most recent Windows update the problem cropped up again.  CHKDSK says everything is ok and "fsutil dirty query c:" tells me the drive is not dirty.  Any hints?
    Monday, October 21, 2013 4:06 PM
  • Well I have it with Wondows XP!!!
    Friday, April 18, 2014 8:44 PM