none
How to Run FIM 2010 PowerShell Cmdlets on FIM Machine RRS feed

  • Question

  • Hello All,

    Not sure what I am missing here, not able to run the 'FIMAutomation' on a FIM 2010 machine.

    The below is the error message.
    Add-PSSnapin : The Windows PowerShell snap-in 'FIMAutomation' is not installed on this machine.

    Please let me know, where I have to look further to run the snap in successfully.

    Thanks and Regards,
    Anirban Singha
    India

    Monday, November 18, 2013 2:45 PM

Answers

  • Before you do that, try:

    Get-PSSnapin FIMAutomation -Registered | Add-PSSnapin

    e.g.

    Get-PSSnapin FIMAutomation -Registered | Add-PSSnapin



    Mike Crowley | MVP
    My Blog -- Planet Technologies

    • Marked as answer by AnirbanSingha Friday, June 20, 2014 4:20 AM
    Tuesday, March 4, 2014 8:06 PM
  • Anirban,

    Make sure the following DLL is registered on the machine you are trying to use it. This DLL is usually available on the any a machine where FIM Service is installed.

    This DLL is not available and this not registered on a FIM Portal or FIM Sync Service machine.

    Here is a sample registry keys that you need to add. Notice that this DLL is copied to a separate directory. You can name this directory what ever you want. Also make sure the Assembly Name and Version are matching the specific version of the DLLs you are working with.

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\FIMAutomation]
    "PowerShellVersion"="2.0"
    "Vendor"="Microsoft"
    "Description"="Registers the CmdLets and Providers in this assembly"
    "VendorIndirect"="FIMAutomation,Microsoft"
    "DescriptionIndirect"="ConfigMigration,Registers the CmdLets and Providers in this assembly"
    "Version"="4.0.3594.2"
    "ApplicationBase"="F:\\Program Files\\Microsoft Forefront Identity Manager\\2010\\Service"
    "AssemblyName"="Microsoft.ResourceManagement.Automation, Version=4.0.3594.2, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
    "ModuleName"="C:\\FIM-DLLs\\Microsoft.ResourceManagement.Automation.dll"


    Thanks,

    Jameel Syed | Identity & Security Strategist | jameel.syed@credexo.com | Simplified Identity and Access Management

    • Edited by Jameel Syed Wednesday, March 5, 2014 8:10 AM
    • Marked as answer by AnirbanSingha Friday, June 20, 2014 4:20 AM
    Wednesday, March 5, 2014 8:09 AM

All replies

  • Hello!

    Have you try to register again the FIMAutomation snap-in?

    See this usefull post from Brad Turner

    http://www.identitychaos.com/2010/03/fim-2010-registering-fimautomation.html

    Regards,

    Sylvain


    Sylvain

    Monday, November 18, 2013 3:20 PM
  • Before you do that, try:

    Get-PSSnapin FIMAutomation -Registered | Add-PSSnapin

    e.g.

    Get-PSSnapin FIMAutomation -Registered | Add-PSSnapin



    Mike Crowley | MVP
    My Blog -- Planet Technologies

    • Marked as answer by AnirbanSingha Friday, June 20, 2014 4:20 AM
    Tuesday, March 4, 2014 8:06 PM
  • Anirban,

    Make sure the following DLL is registered on the machine you are trying to use it. This DLL is usually available on the any a machine where FIM Service is installed.

    This DLL is not available and this not registered on a FIM Portal or FIM Sync Service machine.

    Here is a sample registry keys that you need to add. Notice that this DLL is copied to a separate directory. You can name this directory what ever you want. Also make sure the Assembly Name and Version are matching the specific version of the DLLs you are working with.

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\FIMAutomation]
    "PowerShellVersion"="2.0"
    "Vendor"="Microsoft"
    "Description"="Registers the CmdLets and Providers in this assembly"
    "VendorIndirect"="FIMAutomation,Microsoft"
    "DescriptionIndirect"="ConfigMigration,Registers the CmdLets and Providers in this assembly"
    "Version"="4.0.3594.2"
    "ApplicationBase"="F:\\Program Files\\Microsoft Forefront Identity Manager\\2010\\Service"
    "AssemblyName"="Microsoft.ResourceManagement.Automation, Version=4.0.3594.2, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
    "ModuleName"="C:\\FIM-DLLs\\Microsoft.ResourceManagement.Automation.dll"


    Thanks,

    Jameel Syed | Identity & Security Strategist | jameel.syed@credexo.com | Simplified Identity and Access Management

    • Edited by Jameel Syed Wednesday, March 5, 2014 8:10 AM
    • Marked as answer by AnirbanSingha Friday, June 20, 2014 4:20 AM
    Wednesday, March 5, 2014 8:09 AM